• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 510
  • Last Modified:

networking / Internet connection sharing

Hey ppl I need help regarding the following problems as soon as possible

I have a dell 600m inspiron with Intel Pro/wireless 2200bg network adapter  and a desktop with a Dlink DWL-G510 PCI adapter

I am using the following settings on them

On my desktop: -
IP Address :  192.168.1.1
Subnet mask : 255.255.255.0

On my notebook : -
IP Address :  192.168.1.2
Subnet mask : 255.255.255.0

1.
I am able to establish a connection in ad hoc mode the way I want it. However the problem is that I am able to ping and access my desktop from my notebook. But I am not able to ping or connect to my notebook from my desktop …. I have the same problem when using Wired Lan.

2.
I need to do an internet connection sharing. I have broadband cable connection with a static IP that goes something like 202.xxx.xxx.xxx . When enable internet connection sharing over Local area network I receive a msg like this
“When internet connection sharing is enabled , your lan adapter will be set to use IP address 192.168.0.1. Your computer may lose connectivity with other computers on your network. If these computers have static Ip addresses, you should set them to obtain IP addresses automatically. Are you sure you want to enable Internet Connection Sharing”.

If I say yes then it changes my ip of my lan network to 192.168.0.1. and my internet does’nt work.

Please help soon.

0
leicool
Asked:
leicool
  • 5
  • 5
  • 2
  • +1
2 Solutions
 
jhanceCommented:
>>But I am not able to ping or connect to my notebook from my desktop …. I have the same problem when using Wired Lan.

Notebook running XP SP2? ZoneAlarm?  Norton Internet Insecurity?  Some other firewall?  You may have ICMP (i.e. PING) replies turned OFF as well as other services disabled so no incoming traffic is permitted.
0
 
leicoolAuthor Commented:
>> Notebook running XP SP2? ZoneAlarm?  Norton Internet Insecurity?  Some other firewall?  You may have ICMP (i.e. PING) replies turned OFF as well as other services disabled so no incoming traffic is permitted.

xpsp2 is running .. firewall is disabled.. no other firewall ... dunno about ICMP .. but when i ping myself i get a reply ... just to be sure how to turn ICMP on ???

What about my 2nd question
0
 
Rob WilliamsCommented:
leicool, where you can ping in one direction and not the other it definitely sounds like a firewall issue. ICMP replies by the way is replies to ping requests. There is a specific section in the firewall to enable or disable this but if you have switched the firewall off, that is sufficient. I would deal with issue #2 first and then #1.

ICS will automatically configure your system to share the Internet connection and allow you to enable file and printer sharing if you wish. However, it is very specific as to the configuration, and any changes from the defaults will not allow the connections to work.
Check the box to enable ICS on the WAN connection of the desktop computer which will start the wizard. As you mentioned it will want to change the second adapter to 192.168.0.1, you have no choice bu to allow that. Then on the laptop change the network adapter to obtain an IP address and Obtain DNS servers automatically. It should automatically get a new IP address from the desktop, probably 192.168.0.2

Some good ICS sites with explanations and even video's:

http://support.microsoft.com/default.aspx?scid=kb;en-us;306126&sd=tech
Above complete with video
http://www.petri.co.il/configuring_ics_on_windows_xp.htm
http://www.annoyances.org/exec/show/ics
http://www.homenethelp.com/ics/ics-install-arch.asp
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
leicoolAuthor Commented:
sorry firewall was installed. got it uninstalled . is workign fine now ......... thanks a lot ...
issue 1 solved ... thanks

now for issue 2 : -
robwill  u said "As you mentioned it will want to change the second adapter to 192.168.0.1, you have no choice bu to allow that. "
There in lies my problem ...       i have a static ip ... when i enable ICS the n/w adapter gets set to 192.168.0.1 and my internet does’nt work.  ... no use of internet connection if ther is no internet na ...

Also u mentioned " Check the box to enable ICS on the WAN connection of the desktop computer which will start the wizard. " My net is connected to my LAN card.. Should i not enable ICS over the LAN card rather than over the WAN ?????

Please help .. thanks
0
 
ECNSSMTCommented:
>On my desktop: -
>IP Address :  192.168.1.1
>Subnet mask : 255.255.255.0

>On my notebook : -
>IP Address :  192.168.1.2
>Subnet mask : 255.255.255.0

>lan network to 192.168.0.1

your router is on the wrong subnet, the PCs will see each other in AD HOC but not the access point.
You want o get all devices on the same subnet for starters

e.g.
Wireless Router: 192.168.0.1 /255.255.255.0
Laptop:              192.168.0.2 /255.255.255.0
Desktop:            192.168.0.3 /255.255.255.0

DNS and default gateway information should be manually or automatically distributed to the PCs to enable internet access.  

One recommendation would be to turn on DHCP on the router and have the PCs request IP, DNS and gateway addresses from the router. Its less of an issue in the long run, but you will have to follow the instructions per the router to do so.  

Security wise..
I also recommend that SSID advertising be turned off, and possibily create a restriction list to only permit specific MAC addresses to wirelessly access your WLAN, and enable WLAN encryption.  The instructions will be spelled out in your router and Wireless NIC's manuals.  Of course, enable the security after you get the WLAN/LAN working (if you feel like it).
       
Regards,
0
 
Rob WilliamsCommented:
Maybe we need to clarify what you have for an Internet connection.
You say "There in lies my problem ...       i have a static ip ". Where is the static IP, on the WAN adapter,  and what is it? (Just the first 2 octets such as 192.168.x.x or 66.123.x.x)

ECNSSMT's recommendation assumes you have a router, do you? If so there is no need for ICS.

>>"Should i not enable ICS over the LAN card rather than over the WAN ?????"
No if you need ICS, i.e. you do not have a router, that is the connection you want to share. If your WAN IP is 192.168.0.x then it sounds like you have a router or combined router/modem which performs NAT (Network Address Translation) and automatically assigns you a private IP. If that is the case there should be no need for ICS unless the issue is, you are trying to do this wirelessly. If so you would need to log onto the modem/router and change it's LAN configuration to something other than 192.168.0.x

For the record, the best bet here is to buy a wireless router. They are so cheap now, and much easier to work with. ICS was a great option when routers were very expensive.

However, let us know about your WAN configuration and we can provide more details.
0
 
leicoolAuthor Commented:
Rob, ECNSSMT  well .. i think all r confused (sorry for that) ..

I HAVE NO ROUTER..

let me explain my setup in detail .........  

1. I have a cable net setup in the following manner . Co axial cable goes into cable mode. Ethernet wire from the cable modem goes into Ethernet card on desktop . The ip address of this eth card is 202.xx.xxx.xx . it has been assigned to me by my isp . it is a static ip and if i change it my internet does not work ...

2. Now on the same desktop comp i have a pci wi fi network card. Its ip is 192.168.1.1 and it runs in adhoc mode. i use this card to establish a wi fi ad hoc connection with my notebook who's ip address is 192.168.1.2 ...

i hope u ppl got a clear setup of my network .... Well i couldnt afford a router so had to settle for a pci card. Please help me if u can ... thanks ... if not possible then please suggest some alternatives . thanks very much for being so patient
0
 
Rob WilliamsCommented:
>>"The ip address of this eth card is 202.xx.xxx.xx . it has been assigned to me by my isp . it is a static ip and if i change it my internet does not work ... "
Good, as I thought in the beginning.
You need to enable ICS on this card. It will not change it's IP but will change the wireless card to 192.168.0.1. It also sets up a DHCP server on the desktop machine so it can hand out IP addresses as requested by connecting computers. This is why you want to set the wireless adapter on the laptop to get an IP address automatically. It will contact the desktop, and get an IP in the same subnet, likely 192.168.0.2

The instructions I sent you in the original post will walk you through this if you need more details.
0
 
leicoolAuthor Commented:
thanks so much .. will try it out first thing  tomorrow as its late here... i some how managed to use winproxy but its only temporary as it is a trial version. 1 more thing i will do as u say but i need  to know how can i tell if the dhcp server is running. i think i tried automatic config of ip but the laptop just could'nt get an ip it just stayed at 0.0.0.0 and nothing happened. also could u please tell me what other setting will i have to do on my laptop or in internet explorer. will i have to type in ip's for dns/gateway or will that be assigned automatically ???? and 1 last thing i will have to enable ics only on the eth card and not on my notebook or on the pic wifi card ? thanks
0
 
Rob WilliamsCommented:
If your laptop cannot get an IP using DHCP then you can manually/statically set it, though it is not recommended. Make sure it is in the same subnet (use 192.168.0.2 or similar) use subnet mask 255.255.255.0 and enter 192.168.0.1 as the gateway and manually enter the ISP's DNS servers.

If DHCP does work, it should automatically get gateway and DNS information from the desktop computer.

Yes, ICS is only enabled on the desktop, and only on the network adapter that is connected to the Internet, therefore in your case; not on the desktops wireless card, or on the note books wireless. Also not on the notebook's Ethernet adapter if there is one.
0
 
ECNSSMTCommented:
oops, I assumed it was NATed router... sorry
0
 
leicoolAuthor Commented:
thanks a lot RobWill and all others.  issue finally resolved. Did what robwell said .. Configured the desktop wi fi card manually .. to 192.168.0.1 and subnet to 255.255.255.0 and set the gate way and DNS to my isp's ip address as it was on the wired card. ON my notebook wifi card i set the ip to 192.168.0.2 and dns to same 255.255.255.0 . Now here i set the Gateway and DNS to 192.168.0.1 . This is because after doing an internet connection sharing the machine frome where ur sharing ur internet connection becomes a DNS server (or so i think). I still wan'nt able to figure out wheter DHCP was enabled and running and i think that is y the cards were'nt able to attain an automatic IP address.So i had to manually configure it .  No problems now though  .The internet works excellent and i just saved my self the cost of a router (Wish adhoc mode was faster though for larger file transfers) .  Thanks a million for all your replies .
0
 
Rob WilliamsCommented:
Very welcome, thank you.
--Rob
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 5
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now