Tomcat - SUSE 10 - Running but page won't load

I have just got Tomcat running, but when I go to http://localhost:8080 I do not get any page loading - it doesn't time out or anything, just sits there trying to load or something like that.
Using Ethereal I can see that the HTTP Get request is sent but there is no response from the server at all. But if Tomcat wasn't working at all I would get an immediate error, so Tomcat is there, it's just not quite right.

Any ideas how I can fix this?

(I tried to fix it by adding this line to /etc/sysconfig/j2ee
CATALINA_BASE="/srv/www/tomcat5/base"
but that hasn't helped)
LVL 23
basicinstinctAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
Have you made sure that port is open on the firewall? For testing I'd just disable it temporarily.
basicinstinctAuthor Commented:
I found out what was wrong - I needed to reboot.  I have now twice been a victim of needing to reboot to get something working under linux.  I would always have tried that first under windows, but I am new to Linux and for years I have been subjected to overinflated linux hype which included the claim that you don't need to reboot to get things working under linux.  REstarting apache and tomcat wasn't enough, had to reboot system - works now.
basicinstinctAuthor Commented:
By the way, thanks for your comment Rindi.  The firewall was a good idea to try, but as this test was running on 'localhost' (which maps to loopback 127.0.0.1) the firewall didn't get in the way.  Cheers.
rindiCommented:
No problem
GranModCommented:
Closed, 100 points refunded.
GranMod
The Experts Exchange
Community Support Moderator of all Ages

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.