• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6267
  • Last Modified:

Active sync windows mobile 5.0 tmobile MDA

Hi experts-
I have SBS2003
Exchange 2003 SP2
Tmobile MDA with windows mobile 5.0
Dynamic IP address from Cox cable.
I use no-ip to port redirect to my server so I can use a domain name to RWW/OWA
Cox Blocks Port 80.  But not 8080
domainname.com = ip adress:8080

I can use OWA and RWW no problem

I can also use OMA from IE on my MDA.

I have NO SSL on my SBS box.  

I set my MDA to active sync with exchange.  When I am plugged in via USB it will sync but it takes up to 10 minutes.

If I am not connected I get nothing but waiting for network. or support code 0x85010004

Ive tried using just the ip address of the server and the domainname.

Also this ROM version looks to be Pre Messaging and Security Feature Pack
Is that required?  How do I update if it is?
0
livegirllove
Asked:
livegirllove
  • 13
  • 9
1 Solution
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Why do you not have SSL on your SBS box?  It's created automatically when you run the CEICW (Configure Email and Internet Connection Wizard)?

Using SSL would be the way I would resolve this anyhow... if port 80 is blocked.

So you should run the CEICW again if you haven't since gaining the domain name you use from no-ip as your certificate domain name.

Then you may have to use one of these to KB methods to fix the OMA files:
http://support.microsoft.com/kb/817379 or http://support.microsoft.com/kb/883380 

Jeff
TechSoEasy
0
 
livegirlloveAuthor Commented:
hmm maybe i do have it but use ssl is uncheck everywhere i look.

anyway Ill try that now.

this is driving me crazy.
0
 
livegirlloveAuthor Commented:
yeah when I go to OWA it is http not https  that means no SSL right.  I think I did that because when I first installed I had no domain name or port redirecting
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
>>> "yeah when I go to OWA it is http not https  that means no SSL right."  

That only means that you have OWA configured without SSL.

What do you mean by "use ssl is uncheck everywhere i look"?

Jeff
TechSoEasy
0
 
livegirlloveAuthor Commented:
Under all the virtual directories in IIS under directory security / secure communications Require Secure channel is unchecked...

However now that I reran the internet connection wizard They are checked.

However I cant use RWW or OWA now. :(

oh wait I think thats because it is trying to do SSL over port 8080.  Can I change the SSL port or should I create a new port redirector for 443?  I'm worried that Cox blocks 443 as well
0
 
livegirlloveAuthor Commented:
crap.  OWA doesnt work internally either.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
you need to access it using https://server/exchange  (with the S).

Jeff
TechSoEasy
0
 
livegirlloveAuthor Commented:
correction it does work internally if I type the Local IP address correctly ;)

But it now has forms based authentication.  Which I had previously broken.
0
 
livegirlloveAuthor Commented:
yes
it actually redirected for me when i typed ipaddres/exchange

redirected to https://ipaddress/exchange
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
so, what error is it giving you?
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
It sounds as though you don't have a fully updated server.  The forms based authentication issue had been resolved long ago:  http://support.microsoft.com/kb/843539

But is also resolved with Service Pack 1.

Jeff
TechSoEasy
0
 
livegirlloveAuthor Commented:
Im still doing http://support.microsoft.com/kb/817379

ill update asap
0
 
livegirlloveAuthor Commented:
according to windows update.  I have every available update expect .NET 2.0
0
 
livegirlloveAuthor Commented:
With Wireless turned off on MDA
Exchange sync configured with my domainname.  Use SSL is required is checked
manually sync scheduled

when i manually sync i get to syncronizing folders and then after about 2 minutes just says waiting for network.





0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
SBS Service Pack 1 does not come from Windows Update.  See http://sbsurl.com/sp1

Jeff
TechSoEasy
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Well, it's difficult to analyze what you have turned on and what you haven't... why don't you review this guide which is designed specifically for SBS and Windows Mobile 5.0

http://www.microsoft.com/downloads/details.aspx?FamilyID=8BE70D72-1E5A-4128-A30C-DAFEEB43544D&displaylang=en

jeff
TechSoEasy
0
 
livegirlloveAuthor Commented:
i have sp1.

Ill check that link
0
 
livegirlloveAuthor Commented:
Got to installing the Certificate on the phone when it died.  T-mobile must have access to the root certificate turned off.  So I have to buy an ssl cert from one of the big guys.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Check out this thread from MSDN... you can use a free cert aparently:  http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=89024&SiteID=1

Jeff
TechSoEasy
0
 
livegirlloveAuthor Commented:
That free cert doesnt work with wm5 on my mda because i cant add a root cert.  thats a tmobile issue.  So Im going to buy one.
Couple questions first though.
Since I am using No-Ip and redirecting traffic to my Dynamic IP address when I use my home grown cert I get a warning that the cert cant be verifyied (understandable and will be fixd with a real cert) but then I get a security warning saying that the certificate was issued to domainname.com but the site is IPAddress.  

From everything I've read it seems that activesync cant handle any warnings or errors like this.  So that leaves me wondering if this is possible with a dynamic IP?

Im going to play around some more with the DNS records in No-Ip and see if I can figure something.  Any ideas?  I really dont want to give up my Cable package of $110/month for 8mps/1mps, all the movie channels, and unlimited local and long distance telephone.  grrr.  The cheapest static IP from them is $89.00 for just 768kbps/386kbps... and no phone or cable tv...
0
 
livegirlloveAuthor Commented:
cool update...

Since SSL uses port 443 which Cox does not block incoming/outgoing I can use a simple A Record instead of any type of port redirection.  So I can issue the sert to a domain name and avoind the problem above.

Im going to go ahead and award points.  But look for me in the next week or so to need help...
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
cool... no problem.

Jeff
TechSoEasy
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 13
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now