RPC over HTTP problem (RPC EndPointMapper Access Denied)


Hi,

I have been trying to setup RPC over HTTP for this client, and I have been having problems with this for a couple of weeks. I have tried almost everything on every document I could find, checked SSL (both certs on server and client are OK), checked firewall (ports are forwarded to respective Server), I can browse to rpcproxy server by IE through SSL, RPC registry locations are all OK.

I decied to run RPCDUMP tool and found out about this problem below. I can't find any information about this issue. ANy help???

C:\>rpcdump /P ncacn_http
Querying Endpoint Mapper Database...
RpcMgmtEpEltInqNext:(Access is denied. ).

rpcdump failed after 1 seconds

This is a single server environment, with Win2003 Server SP1, and STD 2003Exch Server SP2, Firewall is Checkpoint

Thanks
Oktay
oktaymftAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RiaanRouxCommented:
Is the SA running on your Front-End?

If you go to https://yourdomain.com/rpc, do you get any errors?  (Report them here)

Also see the following on a similar case:

http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21690015.html
0
ksharma4Commented:
0
oktaymftAuthor Commented:

Answer to Riaanroux,
Yes SA is running.
When I go to https://mydomain.com/rpc I get password screen multiple times. Then it fails. It is known to happen because of SP1.
When I go to https://mydomain.com/rpc/rpcproxy.dll I get a blank screen and I see the SSL lock in the bottom of the explorer. These show me that RPC directory is working on IIS.
That additional Document did not help, it is about two server scenario, I have a single server setup, and SA is working.

Answer to ksharma4
I have seen all those documents, and did all that.


Thanks guys but i think my problem is out of ordinary....
Still need more help.
Oktay
 
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SembeeCommented:
The key thing is the error message when you have had authentication refused.

You should get

"HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource."

If you get anything else, then the feature is not working correctly.

Ensure that you don't have any restrictions on the virtual directory. IP address, connections, permissions etc.
You should be concentrating on getting this to work internally first - so firewall ports (which there is only one - 443) should not be an issue.

Is sharepoint installed on this machine? That has been known to cause problems.

Ensure that both integrated and basic authentication are enabled on the /rpc virtual directory.

Simon.
0
RiaanRouxCommented:
If not already done, please also work through TechNet article 325930
http://support.microsoft.com/default.aspx?scid=kb;en-us;325930

0
oktaymftAuthor Commented:

Sembee,

This is the error message, as you described. I have ssen the articles about this, after SP install it happens.

HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource.
Internet Information Services (IIS)

I can browse internally and externally to the rpc folder and rpcproxy.dll file in that folder. RPC folder gives me the error and the file gives me blank page with an SSL lock in the bottom right corner. I think SSL is working fine.

From a few articles you have given to users, I have seen you told them to uninstall RPC from add/remove, and reinstall again. I tried that before seeing your articles. However I  did not delete existing RPC registry entries. I am going to try that tonight.

One question about that though, should I also delete the RPCPROXY folder from system32 ??? Does it get recreated after I re-install the RPC over HTTP?


RiaanRoux,

I saw that document too. Checked the versions of Windows and rpcrt4.dll in registry. They are both same version. After That I did the RPCDUMP and found the ncacn_http error and decided to ask it here. Because there is no document or info on how to fix that....

Thanks...
Oktay
0
SembeeCommented:
I haven't suggested removing the rpcproxy folder from system32 before, and I haven't seen that it was necessary. It is settings more than the files that have got the problem. The files themselves don't change - it is how they are used.

Simon.
0
oktaymftAuthor Commented:


NO No, I have only seen that you recommended uninstall and reinstall in some other question...

You did not mention anything about the file or the folder.
0
oktaymftAuthor Commented:


Sembee this is the question with your answer on it. I was referring to this...
Q_21402441.html

That is actually what I am going to try...
0
SembeeCommented:
I only usually recommend removing the feature from Add/Remove Programs, and then flushing the registry entries. Nothing else as it is just settings that get upset with this application - not the files themselves.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.