Shaded Group Header Displays Across Entire Page

I have a report that I used in Crystal 8.5. In that report I shaded two of the group headers. The shading stops at the right edge of the last field on the report.

When I bring up the report in CRXI, the shading now extends the full length of the page - that is the shading extends beyond the last field. When I export the report to Excel, the shading extends over all 256 columns.

The question: in CRXI, how do I restrict the group header shading so that it extends to the end of the fields in the report and not to the end of the page?

I am a beginning user in Crystal.

Denver930Asked:
Who is Participating?
 
janmariniCommented:
I don't have CRXI installed here so I can't take a look and try to reproduce your problem.  

But on CR 9.0 I provide shading to my headings within a box control.  If this is the same in CRXI, click on the box control to select it, right-click and select Size and Position - change the width property to something that you can see in your designer (try 7.5) and then modify it to reach the edge of your last field.  I f you have problems finding the control in the Heading, look under the Report explorer for something similar.

Let me know if you need more help.

-Jan
0
 
Denver930Author Commented:
Thanks, Jan.

For those interested, In CRXI, the commands are Insert/Box. Then create and select the box. Next, right-click and select Format Box. Finally, check the Fill Color check box in the Format Editor and choose a color.

Your suggestion works . . . but, when the report is exported to Excel, the shading/color is lost.

The original technique - highlighting the header in Section Expert, selecting the Color tab, checking Background Color and finally, choosing a color - works but extends the shading to the right edge of the page. When exported to Excel, the header is shaded across all columns, not just the report data columns.

If no one else responds, I'll award you the points in a day or so. Thanks for showing me a new technique.

- Dennis



0
 
mlmccCommented:
How are you exporting?  Are you exporting the data only or report format?

mlmcc
0
 
Denver930Author Commented:
mlmcc,

File\Export\Export Report

Format: MS Excel 97-2000 (XLS)
Options: Column width based on objects in the: Whole Report
              Show gridlines option checked.

Thanks for your input.

- Dennis
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.