Installing mysql administrator and query browser on Redhat Enterprise

Hi experts,

I have installed the latest version of Mysql server from their website on our Redhat Enterprise server 4.
ang i am guessing the service is running.

when i try to install mysql administrator from this link http://dev.mysql.com/downloads/administrator/1.1.html 
under Linux x86 generic RPM (statically linked against glibc 2.2.5) downloads

i get the following error message

error:Failed dependincies:
libstdc++.so.6(GLIBCXX_3.4.4) is needed by mysql-administrator-1.1.6-1.i386

i would appreciate any help on this issue

thanks
cakirfatihAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ZentooCommented:
There are couple of rpm package here you can download
I recommend those Fedora one coz it is similar with Red Hat enterprise
After you download the rpm package
http://rpmfind.net/linux/rpm2html/search.php?query=libstdc%2B%2B.so.6(GLIBCXX_3.4.4)

run
rpm -Uvh packagename

Regards,
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ZentooCommented:
Addtion:::
The error mean it needs dependency to be able to install Mysql admin, you need to download and install its dependencies here is libstdc++.so.6(GLIBCXX_3.4.4) and you can find it at the following link

[code]  http://rpmfind.net/linux/rpm2html/search.php?query=libstdc%2B%2B.so.6(GLIBCXX_3.4.4)  [/code]
0
cakirfatihAuthor Commented:
this is what i receive

# rpm -Uvh libstdc++-4.0.2-8.fc4.i386.rpm
warning: libstdc++-4.0.2-8.fc4.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        libstdc++ = 3.4.5-2 is needed by (installed) libstdc++-devel-3.4.5-2.i386
        libstdc++ = 3.4.5 is needed by (installed) gcc-c++-3.4.5-2.i386

thanks
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

cakirfatihAuthor Commented:
this might be also helpful

]# rpm -q libstdc*
package libstdc++34-3.4.0-1.i386.rpm is not installed
package libstdc++-3.4.4-2.fc3.i386.rpm is not installed
package libstdc++-4.0.2-8.fc4.i386.rpm is not installed

thanks
0
ZentooCommented:
It seems like you have alots of packages which you havent installed. What package manager you are using?
Is that YUM or APT-GET?

If you have APT-GET I recommend you to use
http://dag.wieers.com/home-made/apt/FAQ.php#B1
and follow the instruction to setup the repository and then apt-get install packagename

or if you are using YUM
http://dag.wieers.com/home-made/apt/FAQ.php#B4
and then yum install packagename

Regards,
0
ZentooCommented:
Addition::
Iam using Gentoo so Iam not sure about Red Hat but I think it come with YUM in default.
You can use Yum to install packages which it help to resolve the dependencies problems

Hope this help,
Regards,
0
cakirfatihAuthor Commented:
redhat enterprise does not support YUM unfourtunatelly.
i can only use the redhat update manager, as far as i know
0
ZentooCommented:
I think the best way for resolving dependencies problem is to install yum
If you want to try, please go to http://linux.duke.edu/projects/yum/download.ptml
and download your suitable yum version.

and then try to follow the website I gave u above.

Gd luck!!

Regards,
0
jonnymccullaghCommented:
You could also go searching for the dependencies and install each one until MySQL Admin installs.
For example, if you do a google search for  libstdc++ or check rpmseek you should be able to get an rpm which will install the C Complier libraries needed by your program.
0
ircpamanagerCommented:
it is a bug in Mysql for RHEL or CENTOS.        http://bugs.mysql.com/bug.php?id=16491
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.