Exchange 2000 SMTP Delivery Delay to Remote Destinations

One of my clients is running single instance of Exchange 2000 on a W2K server.  This morning, the Exchange server crashed due to a HD becomming full.  Prior to the crash, it was functioning perfectly.  The hard drive became full because one workstation was submitting about 50 requests per second for Windows Updates (SUS had previously been installed on this server), and the IIS log files used up all of the available drive space.  We were able to resolve the SUS problem, and clean up the hard disk.  After a server reboot, it appeared as though everything was functioning perfectly.

They are able to send and receive internal mail without difficulty, and are able to *receive* SMTP mail without difficulty.  However, all *outbound* SMTP messages are being delayed about 30 minutes before delivery.  No settings on the Exchange server have been changed, and DNS appears to be functioning properly.

Any help would be appreciated.

...Tim
TAgee_ATSAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BembiCEOCommented:
Would say, there maybe a bottleneck on your internet connection. Have a look at your mail headers to see the difference between sending and receiving mails. If your SUS is quite fresh, it will download a few Gigs of Updates, dependend on your configuration settings. This may take a while.

You can temporary stop the SUS service to see, if something changes. Also have a look at the settings for the virtual smtp server, how long the time is set to resend waiting mails.

Some other reasons may be:
- Heavy processor load
- Less memory
- low disk space (you should have more than 100 MB free).

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TAgee_ATSAuthor Commented:
Bembi...the Internet connection appears to be fine.  They have a full T1 that is not being taxed too heavily.  They are also no longer using SUS.  Free disk space is > 25 GB.  I'll check on processor and memory stats.
BembiCEOCommented:
As you said, the mails will be delayed, have also a look on the mails within the queue. You can open the queue and then search for mails and then open the mails. There is usually a reason at the bottom of the dialog.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.