aspnet_wp.exe not running in task manager

Hi,

I am working on C# asp.net web application. It is building and running fine, but I dont see aspnet_wp.exe in task manager. I need to see this process as I want to make sure this process (asp.net worker process) is running under a specific account.

Please help.
Thanks.

enggAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Carl TawnSystems and Integration DeveloperCommented:
Do you have "Show Processes from all Users" checked ?
0
Carl TawnSystems and Integration DeveloperCommented:
Also, if you are running under the VS's built-in web server rather than IIS, then you won't have a aspnet_wp process at all.
0
enggAuthor Commented:
yes, I do.
Thanks.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

enggAuthor Commented:
Ok. i will check.
0
enggAuthor Commented:
how can I find out? Can we make it run under IIS? if yes, could you tell me how?
0
enggAuthor Commented:
I used aspnet_regiis.exe -i, but its not making any difference.
0
Carl TawnSystems and Integration DeveloperCommented:
Are you running IIS5 or IIS6 ?
0
enwhyseeCommented:
Do you have w3wp.exe instead?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
enggAuthor Commented:
Thanks carl, enwhysee.

Yeah, thats what the problem was.  I was running IIS6 on Windows Server 2003 and asp.net had w3wp.exe running. I checked the option - 'Run www in IIS 5.0 isolation mode' in IIS and that started aspnet_wp.exe.

I am not sure if this is a good solution as by checking that option, I am not making use of advanced features of IIS6.
Thanks.
0
enwhyseeCommented:
Why not leave it running as w3wp.exe? Here are some differences for IIS5 isolation mode: http://www.directionsonmicrosoft.com/sample/DOMIS/update/2002/07jul/0702riawns_illo2.htm
Its one purpose is backward-compatibility, but you would be losing some IIS6 features.

You could check what account w3wp.exe is running as by going to Task Manager and selecting [x] Show processes from all users.

To *set* what account w3wp.exe is running under, you'd need to change or create something called an application pool. In IIS manager, you should see one or more application pools listen (such as Default). Right-click on the application pool of choice, pick Properties, and then go to the Identities tab -- you'll see an option to configure the account. To configure which application pool your site is using, right-click on your site entry in IIS, go properties, and then the Home Directory tab. You'll see the "Application pool" choice.

Hope this helps!
0
enggAuthor Commented:
Thanks enwhysee!
I have been given something else to work on, so am not working on this right now. I will let you know when I try your solution.
0
enggAuthor Commented:
Sorry about the delay.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Fonts Typography

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.