Cable modem OK. Router OK. But they can't communicate...

A customer's XP desktop PC connects to the internet fine when connected directly to their Comcast "RCA DCM315" cable modem.  But when I tried to add either of two routers (EITHER my linksys wrk54g router, or their Dell TrueMobile 2300 wireless router) -- we can't ping the internet -- wired OR wirelessly.  

I tried using the RESET Button on all three devices, and also power cycling.  I also dropped the PC firewall.  I checked the network device TCP/IP settings and found nothing. (everything I saw was set to AUTO -- DHCP, DNS, etc)

Both the wireless adapter and wired adapters of the test PC connect to BOTH routers.  I can ping the gateway (router OR modem, separately - never both at same time.)  And I kept re-cabling back and forth, to ensure the direct "PC to modem" setup still worked, and it always did -- although often it required power-cycling the modem.

The dell router's "internet explorer" based config util has a diagram that shows the wireless and the LAN (wired) connections working fine, but has a red X over the "internet" connection (to the modem.)

I didn't think to use the "router status" menus (internet explorer), until I had left.  

I confirmed that my travelling test router (the wrkg4g) DOES till work at MY home with MY home comcast router. (as opposed to the customer modem, described above)

When connected directly to the cable modem, ipconfig says the gateway is
67.180.186.1

when connected to the Linksys router, it's the default
192.168.1.1

for the Dell router, it's
192.168.2.1


The weirdest thing is -- I got the dell router working fine, a few weeks ago.  The customer says they kept losing wireless and had to keep connecting directly (wired), and then that stopped working -- but I can't be sure of her observations.

So now I don't know if the change is in the PC, the router(s), or the modem.


REVIEW / BOTTOM LINE:
(1) the cable modem seems to be working fine, when connected to PC directly.. BUT
(2) neither router -- not even my trusty, dependable, test router (a linksys wrk54g) -- communicates with the modem.
(3) all 3 devices were re-set to factory settings. no help.
(4) I got the modem and dell router to work together fine a few weeks ago


Any guesses as to what's causing the problem?
dgrrrAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin MaloneSystem AdministratorCommented:
first plug in the linksys router with default settings and check the status page to see if the router is receveing an ip address. if not click on the renew button and observe the error message.
strungCommented:
Have you tried using the MAC address cloning feature of the routers? Comcast may be keying on the MAC address of the customer's computer.
Craig_200XCommented:
When connected directly to the cable modem, ipconfig says the gateway is
67.180.186.1

A customer's XP desktop PC connects to the internet fine when connected directly to their Comcast "RCA DCM315" cable modem

those two things mean that it IS looking at the mac address and ONLY giving Internet access to it!

solution is to call Comcast and give them the MAC address of the router you want to use.
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

strungCommented:
... or use the MAC address cloning feature of the router to "spoof" the MAC address of the computer that does connect.
BudDurlandDirector of ITCommented:
I know that with the cable modem I got from Charter, it's important to power up the router first, count to 10, then power up the cable modem.  The cable modem learns the MAC address of the connected device when it starts up, and won't talk to anything else.
dgrrrAuthor Commented:
BudDurland -- you're kidding!  THe holy grail of router tech support so far has been, "turn on modem, and ONLY THEN turn on router..."


to ALL -- Comcast in fact said they pinged the MODEM and said all was ok.  I asked if they need to add some mac address on their end, and he said, No, it doesn't matter what's on my side of the modem (router, pc ,whatever). BUT -- he was first level and not bright.

So I ask you -- if comcast communicates with the modem and it's mac address -- doesn't there involvement end there? why is the mac address of the router (either cloned or added to comcast) matter?

thanks -- this is important to me!
Craig_200XCommented:
Dgrr,

lets look at this.

your router works elsewhere right now, right?? so its not your router, it probably isnt a fluke that yours doesnt work AND the other router coincidentally doesnt work. So it should be safe to say both routers are ok.

STRUNG mentioned MAC spoofing... and not to ignore the COMCAST rep, but lets try STRUNGS idea of MAC spoofing... if that works, that dispells the statement of the comcast rep. and will PROVE there is MAC settings... to me this seems to be the logical explanation for the situation.. unless something is not as you stated, I cant think of anything else that would cause this problem.

Craig_200XCommented:
actuallly ......could be some quirk with the modem.. to test :  request a tech with a new modem to be dispatched..
dgrrrAuthor Commented:
researching another question today, I found many google pages that said, "cable companies reference the MAC of your router or PC".  But (yet) another comcast person today said, "we reference the MAC of the cable modem. Not the PC or MAC."

But if the latter is true, I don't see why mac cloning would exist in the first place... Could "comcast" be some kind of exception?  (or could their 1st tier support be dummies?)
Craig_200XCommented:
yes and yes

Unfortunately most tier 1 support does have people that may be missing some crucial facts.....if two people at comcast said this I would bet its as they say... but I still wouldnt be shocked if you did try mac cloning and proved them wrong.... if they cant tell you whats wrong. try the other..

Comcast in my experience HAS some areas which still use mac-to-ip assignments... they also have areas that dont.

If that doesnt work I would have a tech come out and test the existing router on the tech's modem. I have seen wierder things happen.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Justin MaloneSystem AdministratorCommented:
refer back to my origional post. I beleave that mac address is not the problem but in order to look in the right direction we need to start at the router itself. log onto the router useing the 192.168.1.1 user [blank] pass admin
click on the status tab and look at your ip address. if it is a private address that you are receveing from the cable modem then it is useing nat and your problem is double nat. if it is a public address it is a problem with routeing on the router (doubtful senerio) and lastley if it is not receveing an address at all... well then we can go from there. but my guess is you will find the first senario as the problem.
campbelcCommented:
Ok, lets start here.

With your cable modem powered on and connected to the router (verify link lights).

In knowing a couple local admins with Comcast, I know Comcast doesn't care what the MAC of your router is. Comcast actually authorizes your modem to communicate and then gives it a 10.x.x.x IP which is a private IP on Comcast's network.

Verify that the router doesn't have anything other then the default config. Comcast doesn't require any login and assigns IP via DHCP.

Then with your PC connected to the router, please verify a few things:

IP address of your PC: from a command prompt (ipconfig /all)
Can you ping the router?
Can you ping this IP: 69.51.159.21
Can you traceroute to this IP: tracert 69.51.159.21

Is is possible that you don't have a DNS server specified?

Craig_200XCommented:
Campbelc,

FYI: I worked for Comcast 3 years ago. They were using MAC addresses then - I provisioned cablemodems so I am extremely familiar with Comcast. I also subscribed to the service after my working there until beginning of last year -  they were still using mac addresses in that area as of then. I have ALSO heard of few issues recently where they are STILL using mac addresses to assign IPs, so the practice of finding out what the ISP is using is the better part of valour unless you have direct experience in that particular area.. so maybe in YOUR area comcast doesnt care, but thats not true in all areas yet. There would not be so many responses from different Experts to check this if it were not a real possibility.

As far as Comcast giving you a private/internal IP.. I highly doubt that. that would be a first in my experience. Can anyone else verify this?  I cant see too many people wanting Comcast to control their network... slim chance that would fly with residential customers and business customers would be screwed with hosting servers.
dgrrrAuthor Commented:
to all:
When I return to site (unpaid again, lol) I WILL try mac cloning, if for no other reason to be thorough.  Tonight, Comcast tier 2 said their modems do NOT care what I plug into the modem -- they check the MAC of the MODEM only (at least in my area). This fits with my experience in general.
BUT
In another thread, I ask why comcast consistenly assigns me different "gateway IPs" (67.x.x.x vs 24.x.x.x) depending on whether I connect PC to modem (67), or Router to modem (24) -- AND I (again) asked about which device MAC comcast uses (in my area) to authenticate service.  This tech said, they authenticate with the MODEM MAC -- but he also guessed that the other issue -- the varying gateway (67 vs 24) issue -- comes up becuase Comcast "peeks thru the modem", "sees" the differing MACS of the PC NIC vs the ROuter -- and hands out differing gateways....  So modem MAC autheticates, but the next device MAC affects gateway ip...?    I must ask what you think, in this thread, because you guys sound very knowledgeable.  (craig_200x - is this what you meant by "some areas which still use mac-to-ip assignments"




to  squallkill99 and others:
YES -- when I return I will do precisely what you say -- look at the router status page.  Failing to do so when I was there reveals my lack of foundation knowledge, which this thread is really helping with.

to campbelc:
"Is is possible that you don't have a DNS server specified?" -- you mean on the "router status" page, right? (dns1, dns2, dns3?)

to campbelc  and Craig_200X:
about "Comcast giving you a private/internal IP" -- is this related to diagnosing the "double nat" issue that "squallkill99" mentioned? (pub vs private gateway?)

Craig_200XCommented:
mac-to-ip does not give different gateways... so you getting 2 different gateways is another unusual thing in my opinion -- it could be a different dhcp server assigning devices a different route.. which I cant explain... as far as the latter question at me / campbelc, no its not related to squalkill - is referring to the modem being a dual purpose device - a modem and a router (which gives NAT addresses) and you placing a router "behind" the modem/router if thats the case... in effect 2 devices nat'ing..  

I am curious to see the outcome of this. all these comcast techs saying there is no mac reservations... it sure would be funny if the cloning worked.. lol



dgrrrAuthor Commented:
I will update this thread, after going back to site (within 72 hours, prob)
dgrrrAuthor Commented:
Okay.  Weirdness, intermittency, darkness, end times.

Seriously -- I was at the site today.  I re-set all devices.  Fresh ethernet cable.  Tried the cable modem alone, PC connected. Tried it with the dell router, didn't connect. Router status page said:  Internet "inactive" (IP's were all 0.0.0.0).   Tried Mac Cloning -- NO DIFFERENCE.  

THEN I swapped in my Linksys router. Now the PC connected to the web fine.

So I told the customer it looked like their dell router had a bad wan port. To be sure, on the Linksys, I powercycled everything, rebooted, waited. All still working.  Left the Linksys there as a loaner.  Then, AS I'm leaving, internet access failed again.  At this point, the Linksys router status page DID show an Internet IP and a Gateway IP (see below), but I could not access the web.  

I re-set both modem & router again, no help. I power cycled them, no help.  I power cycled them again -- this time noticiing that the "internet" lights were OFF on the modem.  Pressed the "button".  Now the linksys connected.  (!)

So at this point, I'm thinking:  either the functionality of that button, which turns off two of the four lights on the modem (killing web access), is shorting out and turning itself on and off, OR I'm an idiot and was pressing that button on and off constantly without realizing it, e.g. when I recabled the units.   It IS a unshielded button on the face of the unit, making unintentional use more likely...  But then again, why would I get the failure as I'm leaving, when no one touched the modem or router?  (Unless, again, it's an internal problem.)

In any event, I told them to make Comcast give them a new modem, as you guys suggested, just to rule that out, while I also get your feedback on the following.

ROUTER STATUS PAGES:

LINKSYS ROUTER STATUS PAGE (whether it reaches the web OR NOT.  In EITHER CASE, it sees the following)
external router IP (wan port):  24.5.27.91
external router gateway IP (comcast):  24.5.24.1
comcast dns 1 server:  68.87.76.178
comcast dns 2 server:  68.87.66.196
IPCONFIG ip address:  192.168.1.105 (as I remember)
IPCONFIG gateway: 192.168.1.1


By the way, I discovered an old screenshot in my notes from a month ago, from WHEN the DELL MODEM was accessing the web OK (several weeks ago). The router status page showed the following, instead of all zeros, which it shows now when hooked up)
external router IP (wan port):   24.5.27.20
external router gateway IP (comcast):  24.5.24.1
comcast dns server:  68.87.76.178
IPCONFIG ip address: 192.168.2.2
IPCONFIG gateway: 192.168.2.1


I know what you're going to ask next -- when the linksys router was NOT reaching the internet BUT DID display the above IPs, did I ping those or other IPs along the route to the web.  Eh, no. I will have her do this over the phone and get back to me.  I'll have her ping the linksys router status page IPs above, plus any you suggest, including campbel's suggested IP:  
69.51.159.21

thx!
Craig_200XCommented:
quirky modem is right!! maybe it likes attention and drama....


if it got on with the linksys...  doesnt sound like mac - to ip as I first thought


also the ip 69.51.159.21 doesnt ping anything for me.. maybe that was an example....


you can try pinging 4.2.2.2 (dns server at vz)

campbelcCommented:
My guess would be cable modem has gone bad.

Can you ping your external gateway? 24.5.24.1 ?
If not, try doing a "tracert 24.5.24.1"

The tracert will let us know where its failing at least.

As for pinging 69.51.159.21, that is a DNS server here in town for a 3rd party ISP. Pings great here. Also does the 4.2.2.2 and their other 4.2.2.1

C:\Documents and Settings\Home>ping 69.51.159.21

Pinging 69.51.159.21 with 32 bytes of data:

Reply from 69.51.159.21: bytes=32 time=29ms TTL=113
Reply from 69.51.159.21: bytes=32 time=28ms TTL=113
Reply from 69.51.159.21: bytes=32 time=29ms TTL=113
Reply from 69.51.159.21: bytes=32 time=28ms TTL=113

Ping statistics for 69.51.159.21:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 28ms, Maximum = 29ms, Average = 28ms

C:\Documents and Settings\Home>
Craig_200XCommented:
Dgrr,

pinging that 69.x.x.x doesnt work for me, like I said, so that may not work for you

Campbellc - "My guess would be cable modem has gone bad." - is that an after thought? coz Hes already replacing the modem, knowing thats common link in the prob.

Joe JenkinsCommented:
I have been using Comcast Cablemodems and HSD service since 1999.  I know for a fact that we use MAC addresses of the installation machine.  Try getting the MAC of the Linksys router (Don't use the Dell one, for the love of Pete.. ), calling Comcast and tell them you have a new PC and you need a new MAC Address Provisioned.  I have done this myself numerous times and it corrects many problems.  Chances are the MAC Cloning part of the router configuration program you will have to have the MAC of the one the service was installed with to have it work.  You're better off getting them the new MAC of the router.

Joe Jenkins
Craig_200XCommented:
Joe,
this was my original suggestion, but he has tried that, even called back and tried again and they still have told him they dont use mac to give IPs.

Thanx for reconfirming my idea that they still use MAC addresses though!..

Joe JenkinsCommented:
Bah, you know, when I read this thread at first, I definitely didnt' see where you said that!  I see it now though.

The only other solution I could see then would be to have them send one of their techs out to do an onsite check.  Try plugging a computer directly into that cable modem and check to see if you get an IP.  If so, replace the router.  

:)

Joe
dgrrrAuthor Commented:
PC plugged directly into cable modem always connects, but... (see all above).  

But I am curious, re: mac cloning  or mac registering with cable co --
Since the cable modem + Linksys router combination SOMETIMES connects to the web, and sometimes doesn't.... doesn't that (that it works "sometimes") rule out a mac address issue?

Will have lady do above mentioned ping & tracert & get back.
campbelcCommented:
You seem to have some sort of problem with me Craig. Aren't we all in this for the same reason, to help dgrrr solve this issue? Keep your snippy comments directed at others to yourself. Although after reading your comment history on other questions, you seem to want to disprove everyone's comments.

I find it quite weird that you can't ping the 69.51.159.21 address, can you ping 24.5.24.1? That is the default route that dgrrr listed above the last time his router reqeusted a DHCP address.

Anyways, I talked to our local Comcast network admin here last night and he confirmed once again that they do NOT care about the MAC of your local pc or router. They simply authorize your modem's MAC address and nothing more. He also said I could take my modem to a buddy's house across town, plug it in and reconnect there without any issues.

Now mind you, he did have a few beers and we had been playing softball for the past 10 hours, so who knows.

Ok, do this:

Connect the modem, router, PC. Login to the linksys and post the status information (ip,subnet,gateway, dns info of the router and then do a "ipconfig /all" from the pc command prompt (start, run, cmd" and post that complete information.)

Connect the modem directly to the PC. Do a "ipconfig /all" from the command prompt and post those results.

When you have connected using the 2 scenarios above, try a ping and a tracert to the outside default gateway.

Thanks dgrrr, I'm here to help not collect points. If I solve the issue great, if not, I hope we can all collaborate together to get you a solution. =)
Craig_200XCommented:
Nope CampbellC, no probs. just letn you know he was already doin that. and no I dont want to disaprove of others comments. I come here to learn and help out, coz I know Im not the brightest person and can learn a thing or 2, or 3, sometimes I can be blunt. sorry. I reread that and I can see where your comin from - sorry bout that..
strungCommented:
Two suggestions:

1. Try the MAC address cloning feature of the router. (What have you go to lose?).

2. If you have not already done so, download and install the latest firmware upgrade for the router.
dgrrrAuthor Commented:
Sorry for keeping you waiting for points dudes -- waiting to get back to site.
dgrrrAuthor Commented:
I'm just going to assign points. But I'll post back if and when I get to chek it out.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.