Fedora Core 5 fstab mounting ntfs volume

I currently have this line in my /etc/fstab file to mount my NTFS volume which works correctly - however when I try to write to the drive, it says its a read only filesystem.  How can I make this writeable by myself, not only root?

/dev/hdb1       /mnt/windows    ntfs    ro,defaults,umask=0222  0 0

LVL 1
jpipitoneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ppfoongCommented:

You mounted it as read-only, the option "ro" as in "ro,defaults,umask=0222".

Change the "ro" to "rw", umount /dev/hdb1 and mount it again.

** There must be some reasons why it is mounted as read-only by default. Possibly NTFS can only be mounted as read-only because your kernel does not support writing to it.

The kernel must be compiled with NTFS write support in order to support rw to NTFS. Even then, write support to NTFS is quite limited, there are some restrictions, such as, you can't simply create/delete files.


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nedvisCommented:

Change your fstab file  line  that  reads:

/dev/hdb1       /mnt/windows    ntfs    ro,defaults,umask=0222  0 0

to

/dev/hdb1      /mnt/windows      ntfs      rw,defaults,umask=0000  0 0

-----------------------------------------------------------------

Additional info : http://fedorasolved.org/post-install-solutions/setting-up-ntfs-read-write-support


nedvis
0
nedvisCommented:
To install NTFS driver easily via yum just make sure livna repository is enabled. It's all it the excellent HOWTO here:
http://home.gagme.com/greg/linux/fc5-tips.php
0
jpipitoneAuthor Commented:
Thanks guys...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.