Certificate Services and Windows Server 2003

Hi guys!

Im going nuts with trying to get a certificate installed and setting up SSL on our server.

Im trying to install a Standalone CA Server on a Windows 2003 Server in a 2003 Domain. I then want to configure SSL for the default web site. I have IIS installed on the system.

Computer Name is TESTBOX

Here are the steps Im using: ===============================

1) Install Certifcate Services
- Add/Remove Programs - Certificate Services. I select the Standalone Root CA option
- Common Name for this CA: TESTBOX

2) Create a certificate request file.

3) Issue it in CA

4) Open the certificate - copy to file - save as a .cer extension.

5) In IIS - Directory Security - Process and install certificate. Point to the .cer file. Done.

Im just stumped....I cant this to work whatsoever.

I dont see a padlock when I type in https://localhost.....just says web page cannot be displayed.

Please help!!!

Simon

Simon

LVL 1
Simon336697Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

markpalinuxCommented:


Make sure you right click on the properties of the folder or site in iis and select ssl , also make sure that the port 443 is there. I do not think that port 443 always gets added by default, add it then stop and start the site ( or iis) then you should see it.

Mark
0
Klint_turneyCommented:
MAke sure you have "Execute Scripts" Checked in IIS because when it attemps to issue it will need to run I think it was a asp script
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TheCleanerCommented:
Simon,

Are you trying to give your website a certificate for external use?  If that's the case then the internal CA won't be trusted externally anyway, so you could use SelfSSL from the IIS resource kit to create and use a self-signed cert.  http://www.visualwin.com/SelfSSL/

For a walkthrough for setting up the SSL cert from the CA see here: http://support.microsoft.com/kb/299875/en-us

For enabling SSL/443 in IIS:  
http://builder.com.com/5100-6389-5055536.html

You can also use this:  http://www.msexchange.org/tutorials/SSL_Enabling_OWA_2003.html  as a reference, since your SSL site is basically the same idea as the OWA site, so you can basically substitute your site for OWA.
0
Simon336697Author Commented:
Thank you guys for all your help.
It turned out the only reason the dialog box for the certificate wasnt coming up was the permissions in IIS.

Simon
0
TheCleanerCommented:
heh....well glad you got it resolved...thanks for the points.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.