Urgent 500 points Citrix Program neighborhood login problem

I’m trying to connect to a citrix apss and desktop from my server using Citrix Program neighborhood  but I keep getting the following error message:
“Cannot connect to the Citrix MetaFrame server. An I/O error occurred while your request was being processed”.

All my clients outside of the firewall login fine. We have no internal pointing citirx clients in the network.

It when i am at the admin terminal checking in CPN it come up with this error message.

In the syslog i get Event ID 6004.
A driver packet received from the I/O subsystem was invalid.  The data is the packet.

I have changed nothing on the setup for months

What could it be the cause of the problem.
Thank you for your help.
Regards,

LVL 16
ellandrdAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Darwinian999Commented:
Try disabling Session Reliability in the properties of Program Neighbourhood.
mgcITCommented:
Are you trying to connect from one of your citrix servers, or another server?  
ellandrdAuthor Commented:
Yes from one of my citrix servers
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

mgcITCommented:
well if your citrix farm is functioning normally I would try reinstalling the latest version of Program Neighborhood.  Also refresh the application set.  you can try a custom ICA connection to narrow down which server is giving the error if you have more than one citrix server.
ellandrdAuthor Commented:
anything else?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gsgiCommented:
Did you get it fixed?  What was it?  Thanks.

-gsgi
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.