Crystal Reports XI Server web tools unavailable

hi all, we just installed CRS XI Server on a windows 2003 server box and cannot get the web apps operational.  Using iis/asp.net.

the .net admin launchpad shows page that "You are not authorized to view this page."  

the .net info view page is displaying the message:  "All of your system's 0 Concurrent Access Licenses are in use at this time or your system's license key has expired. Try again later or contact your administrator to obtain additional licenses."  for the default login that is supposed to be available upon install.

the central configuration manager comes up ok, with all services running except one that is stopped - winhttp web proxy auto discovery service, not sure what the problem is there.

i checked the iis permissions for business objects and crystal reports viewers in iis, and settings look correct.  not sure what else to look for.  i registered the product and used the permanent license provided by business objects.  the install didn't present any errors, opened a case with business objects but nobody will respond, after 5 days.

any help would be greatly appreciated.  thanks.
aaalifeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

frodomanCommented:
aaalifeAuthor Commented:
this solution assumes you have access with login to cmc, which i currently do not.
ladylinetCommented:
Hi aaalife, I had that some message when I first time installed CR XI Server, regardless of that I have entered proper license key there.
 I had to go and update license key in CMC. If you don't have access to CMC, look for Business Object License Manager link... If you don't have access to either, ask your administrator to check for you, it's just web interface...

Lady Linet
JavaScript Best Practices

Save hours in development time and avoid common mistakes by learning the best practices to use for JavaScript.

aaalifeAuthor Commented:
I'd ask the admin, but he is me.  cmc login doesn't let me in, the default, guest, admin, none authorize the access.
ladylinetCommented:
Administrator with no password doesn't let you in? That's a problem also, and I belive I solved it by allowing aspnet extensions to run on server...

Lady Linet
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
I've run into issues due to asp.net extensions.  There's a definite install sequence required for Crystal Reports Server (assuming the .NET interface) to work well out-of-the-box:

1)  IIS (look under the Documents tab within the businessobjects website properties in IIS and look for default.aspx - if it's not there, you have a problem)
2)  .NET Framework and ASP.NET
3)  Crystal Reports Server
4)  Crystal Enterprise (if applicable)
5)  Crystal Analysis (if applicable)


Also, the services are running, but are they enabled?  Check the <Enable/Disable Servers> button within the CMC.  Also, this should prompt you for to login again.  If you can't login here, you may need to recreate the Enterprise DB through the <Specify CMS Data Source> button.

~Kurt
aaalifeAuthor Commented:

IIS/documents/businessobjects and crystal reports server both did not have default.aspx.  i added but no help, still getting you're not authorized for administration console.

Any attempt to log into infoview results in web page message --> An error has occurred: No 508 compliant <TITLE> found in resource strings.

windows 2003 server box doesn't have .net 1.1 on it.  only .net version on it is 2.0, surely this is not a problem.

asp.net 2.0, asp, and business objects web intelligence web services are set to allowed in IIS.

Crystal Enterprise and Analysis not installed.  There is an option during the install to use Apache/Tomcat with Java infoview and java admin launchpad.  starting to wonder if this would be easier, but i don't want to go down this path just yet.
aaalifeAuthor Commented:
ok, this is weird, but when i turned on directory browsing for the default web site in IIS, then go to start/program files/.../admin launch, i get the directory of the admin site, bunch of urls, when i press on the default link, i can log into ccm as admin and do whatever.  

i turned off directory browsing for the business objects and crystal report viewers folders and then could not get into any of the sites.

anybody have ideas as to what is going on with my web server??  there are a couple intranet pages being run off this server, isn't that ok?

why would directory browsing effect access rights??
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
My apologies, the order should have been:

3)  Crystal Reports Server
4)  Crystal Reports (if applicable)
5)  Crystal Analysis (if applicable)
"
Regarding Directory Browsing, here is a snippet from the IIS (5.1) documentation:

Directory browsing

To allow the user to see a hypertext listing of the files and subdirectories in this virtual directory, select this option. Virtual directories will not appear in directory listings; users must know a virtual directory’s alias.

Important   Your Web server will display an "Access Forbidden" error message in the user’s Web browser if the user attempts to access a file or directory and both of the following items are true:

Directory browsing is disabled.

The user does not specify a file name, such as Filename.htm."

It would appear that your issues relate specifically to your IIS configuration.  I run Crystal Reports Server off my laptop and have Directory Browsing disabled (unchecked) and have never had an issue, but I also don't have any other customized configurations.

~Kurt

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aaalifeAuthor Commented:
IIS 6 (windows server 2003) is supposed to be locked down out of the box, and microsoft claims IIS 6 is a complete rewrite from 5.x versions.

i've successfully installed crs xi on windows 2000 servers before without a hitch, but something about the out of the box safety features is preventing proper usage.
ChrisGSJohnsonCommented:
Go to Control Panel->Add/Remove Programs->Windows Components->Application Server and make sure that ASP.NET is enabled before installing Business Objects.  I couldn't get the .Net web pages to open either.  Then I found a post that suggested checking the checkbox and then re-installing Business Objects.  It worked for me.  I hope that this helps.  Thanks.

Chris
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.