cvs - cannot connect via wincvs

cvs repository is installed on linux. i can successfully login with command on the linux:

cvs -d :pserver:abc@localhost:/usr/local/cvs login

however, when i tried to use wincvs to access it on XP, i got the following error:

cvs [login aborted]: connect to 192.168.0.102:2401 failed: No route to host

then i shut down the firewall on XP and tried again, i got the same error. do u know what's wrong with my setting?

many thanks.
andersyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dushan De SilvaTechnology ArchitectCommented:
can you try to telnet to cvs server. Please try following command on command line and let me know the result

telnet 192.168.0.102 2401

BR Dushan
Dushan De SilvaTechnology ArchitectCommented:
And if you can telnet try to "fetch list" before checkin.

BR Dushan
Dushan De SilvaTechnology ArchitectCommented:
Following solution might help for you.

http://www.experts-exchange.com/Programming/Q_21797872.html

BR Dushan
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

andersyAuthor Commented:
hi,

i cannot make the connection with
telnet 192.168.0.102 2401

i'd like to know if linux blocks the port from external. as i can login to cvs locally on linux.

thanks.
andersyAuthor Commented:
btw, ping to that machine is ok.

>ping 192.168.0.102

Pinging 192.168.0.102 with 32 bytes of data:

Reply from 192.168.0.102: bytes=32 time<1ms TTL=64
Reply from 192.168.0.102: bytes=32 time<1ms TTL=64
Reply from 192.168.0.102: bytes=32 time<1ms TTL=64
Reply from 192.168.0.102: bytes=32 time<1ms TTL=64

Ping statistics for 192.168.0.102:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
Dushan De SilvaTechnology ArchitectCommented:
ping working mean network connection between to server is okay.
But telnet not working sence there is a come problem.

1.) Please login to cvs server installed machine and try to login cvs server using above same command which you have tried.(in Linux also same) with the same user details.

2.) If you can not connect check cvs server is up.

3.)  If user detais are wrong check passwd file under CVSROOT

4.)  If you can log, please check for any firewall issue in both side. (cvs installed server side outgoing 2401 port is open and your side incomming 2401 port is open correctly. )

If you need more info, don't hesitate to reply.

BR Dushan
andersyAuthor Commented:
thanks, BR Dushan,

1. it's ok to login cvs on linux.
cvs -d :pserver:andersy@192.168.0.102:/usr/local/cvs login

2. N/A

3. N/A

4. port 2401 should be open, i check it with nmap,
PORT     STATE SERVICE
22/tcp   open  ssh
25/tcp   open  smtp
80/tcp   open  http
111/tcp  open  rpcbind
631/tcp  open  ipp
2401/tcp open  cvspserver
3306/tcp open  mysql

do u have any clues why i can't login with wincvs on XP?

many thanks.
Dushan De SilvaTechnology ArchitectCommented:
You are Welcome!
Yes, if cvs server is up and you can log into that with same user details.. and you can't telnet to cvs server with 2401 from your machine,  then could be the problem is in your machine's firewall.

And are you in same subnet and is there any ipmappings(iptable..etc) in your network, when you are connecting to the cvs server... please make sure all the tree(paths) comming from cvs server to your machine's ports are working properly... and you can check it in each point with telnet. To check path you can use tracert command. (tracert 192.168.0.102).

Please check it.

And is anyone in your network working with WinCVS correctly now?


BR Dushan
andersyAuthor Commented:
hi BR Dushan,

i have no idea about tracert, but i got the following result:

C:\>tracert 192.168.0.102

Tracing route to 192.168.0.102 over a maximum of 30 hops

  1    <1 ms    <1 ms    <1 ms  192.168.0.102

Trace complete.

would u kindly let me know if it's ok? btw, is it the problem on the firewall of linux. how can i can it?

many thanks.
Dushan De SilvaTechnology ArchitectCommented:
Hi andersy,
Tracert command is showing how you are going to perticular place one by one. For a example
tracert www.google.com 
will shows, the connecting path of each server/routers one by one till google reach.

In here your results shows, your machine is directly connected with the cvs server.( no network mapping ...etc).

------------------------------------------------------------------------------------------------------------------------
Here is the conclusion.(If you can not "telnet 192.168.0.102 2401" from your machine.)
CVS server is up and no problem with it.
Difinitly problem is in following two points.
1.) Check 192.168.0.102 server's OUTGOING 2401 is not blocked by firewall.(Try to "telnet 192.168.0.102 2401" from another machine in the network.)
2.) Check firewall/spyware in your machine's have blocked INCOMMING 2401 port.

BR Dushan
andersyAuthor Commented:
Thanks for your comment. I'll check these points.
Many thanks.
Dushan De SilvaTechnology ArchitectCommented:
You are Welcome andersy !

BR Dushan

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
andersyAuthor Commented:
Thanks, BR Dushan.

It works when I add an entry in iptables to accept port 2401.

Thanks for your help.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.