the specified network name is no longer available when tying to access/map linux fedora core 4 shared directory from XP box

I have a Fedora core 4 linux box with the /root directory shared to everyone.  it is set as visible and I just did a "chmod 777 /root" to it.  I want to be able to map the /root directory from an XP box on my company's domain.  

The smb service is running and all the dns settings etc are correct on both boxes.  They can ping eachother by hostname.  When I use the "net use" command or try to map the /root directory through windows explorer, i get a system error 64 "the specified network name is no longer available"  This should just work!  I am able to reach a fedora core 2 box with the same method.

I have put the fedora core 4 box in a workgroup titled workgroup, and when i browse from the map network drive option under tools in a windows explorer box, I can see the hostname of the linux box under entire network>microsoft windows network>workgroup>hostname,  but i cant choose it or expand it.

when i go to run and enter \\the ip of linux box i get: the specified network name is no longer available..again.
jsmithpAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pablouruguayCommented:
check if you dont have SElinux active in
/etc/sysconfig/selinux
you need to set this
SELINUX=disabled

0
pablouruguayCommented:
and chenge the parameters in the files inside

 /etc/security i think is chroot.conf
0
paullamhkgCommented:
or you can set the security policy on SELinux

have a check here http://www.nsa.gov/selinux/papers/policy-abs.cfm

It show you how to config the SELinux policy :o)
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

jsmithpAuthor Commented:
selinux has been disabled all through this, to be honest I wasnt sure what it was used for.. But nehow its been disabled, and when i tried to enable it once, it gave a warning that enabling it would change all the directory names on next restart which would take a long time.. so i never bothered trying with it enabled.. always been disabled.
0
jsmithpAuthor Commented:
Now, im not very interested in security at this point.. I just want to be able to access my root directory from this xp machine..
0
jsmithpAuthor Commented:
I have proven it is on the windows side.. i can access this /root share from any other computer on the network using this users log in... windows firewall is down.. whats going on? is the nic card failing?
0
pablouruguayCommented:
if you can access to this computer from other windows the problem is the windows.
maybe. service pack or cable or NIC ....
0
jsmithpAuthor Commented:
tried a new nic card in the xp box..no difference
tried deleting and re-adding the computer account from active directory, no difference..
0
rindiCommented:
Test the xp box for malware:

Turn off System Restore (Control Panel, System).

start msconfig (Start, Run, msconfig), select the startup tab and remove the ticks from any programs you aren't sure of what they might be.

Let your PC be restarted

Download and install Spybot S & D (http://www.safer-networking.org/en/index.html)
Let the installer activate the teatimer and update Spybot.
Click on "make registry backup", wait until done and click on next.
Let the scan finish, then select all the found items and select clean.
If the system wasn't able to clean out everything it found, let it reboot. Spybot should startup before you logon, do another scan.
Again select all found items and clean. When finished select "immunize", then close spybot.

Download and install Adaware (http://lavasoft.com).
Let the installer do an update, then scan the system.
Select all found items and let them be removed.
A reboot may also be necessary here.

If either Spybot or adaware or both still weren't able to remove all malware, reboot your system to safemode and let the tool which couldn't remove a malware do another scan. If it is adaware, change the scan settings to scan within archives, then start a scan.
Again select all found malware and let them be removed.



if you still have malware on your system after that, download the latest version of HijackThis:
http://www.hijackthis.de/downloads

Reboot, then without loading anything else run hijackthis and save the log. Paste the log to the following website:

http://www.hijackthis.de/en

Click the "analyze" button and you will have an analysis of your log. Then click
on "Save Analysis" and paste the URL you are redirected to here.

next make sure your AV Software is uptodate and running. Let the system do a thorough AV scan.
0
jsmithpAuthor Commented:
ok im gonna try that now.. spyware is known to cause random problems like this!
0
rindiCommented:
At least on m$ boxes :)

(although there seems to be a virus that just came out that can infect different plattforms).
0
jsmithpAuthor Commented:
removed some adware, but didnt solve the problem.. However I came across an sftp client called winscp, which allows me to remotely authenticate to the remote linux machine from the windows box, and drag and drop files ala ftp.  This will please the user, but I am still concerned what is causing the problem in the first place.
0
rindiCommented:
Have you checked with hijackthis for anything else (not necessarily malware) that might cause your problems?
0
wnrossCommented:
Hi, Sorry to poke in the dark here, but
1) is windows firewall enabled or disabled?  If enabled, ensure that windows networking is open
2) is your linux box registered in DNS?  If not, then that will cause your spradic connection issues
3) Can you connect via ip address (ie: START| RUN , \\192.168.10.14\root )

Also, how do you have your SAMBA server setup? Windows XP in a DOMAIN environment does not act like the Windows XP running at home, totally different naming lookup works here.

Check
- workgroup =
- announce vserion =
- preferred amster=
- domain master =
- security =
- use spnego =

Cheers,
-Bill
0
Gabriel OrozcoSolution ArchitectCommented:
mmhh... what the samba logs have to say? clear the logs and then review them for the machine that is having trouble. I suspect it will thell you what is wrong. if not much information, increase log level to, say... between 3 to 6 (6 is way too much information) logs should reside in /var/log/samba

Also... did you applied the patch for sign_or_seal.reg to that box?
0
jsmithpAuthor Commented:
The xp box is in a 2003 server AD environment. The linux box is on the same corporate network, but is not "on the domain".  The linux box is acting as the samba server, and authentication is not even an issue at this point, because the shares are accessible to everyone accross the board, a straight up 777 situation.  I beleive there is a problem with the xp machine, because other xp machines on the network can type in \\linuxbox\sharename and access the shares with no authentication required.. but i still get the same error on his end "the specified network name is no longer available"  Ive given up for now, since the sftp client has enabled him to do what he wanted.. but id like to solve the problem too.  I havent done a hijack this yet.. but i dont think this is really any malware caused issue.. i did remove some minor adware however using windows defender/microsoft antispyware.
0
jsmithpAuthor Commented:
And btw, windows firewall is disabled here through group policy, so no, its not on.
0
Gabriel OrozcoSolution ArchitectCommented:
... did you applied the patch for signorseal.reg to that windows box?

http://www.see.ed.ac.uk/it/network/domain/signorseal.reg

downloadit, save to a directory, double-click as admin user, restart and try
0
jsmithpAuthor Commented:
this patch does what?
0
Gabriel OrozcoSolution ArchitectCommented:
tell windows to use one of multiples correct ways to communicate with other windows machines.

this option has the side effect that makes windows work with samba
0
jsmithpAuthor Commented:
Now this linux box is in a workgroup named workgroup.  If i go to map network drive, on any other xp box besides the one im having trouble with, I can expand workgroup, and see this linux computer, and all of its shares.  If i try to do the same on his computer, i can expand workgroup and see the linux box.. but if i try to expand it, i get "access is denied, u may not have access to this network resourse. contact your administrator to see if you have rights to this machine".. it doesnt matter who is logged in to his machine, they all get that message.
0
jsmithpAuthor Commented:
I will consider trying that patch, though i am hesitant to alter the registry with a .reg file that i am not familiar with.
0
Gabriel OrozcoSolution ArchitectCommented:
it's harmless

since you can revert the patch very easily.
also read it. it's only one line modified.
0
GranModCommented:
PAQed with no points refunded (of 500)

GranMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.