Error in Formula

One of my users is using CR 8.0 and has a formula:

HFWDateToDate ({CALLLOG.DUEDATE})

When she presses F5 to refresh she gets a msg box stating:

"The remaining text does not appear to be part of the formula"
stratasoftAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

peter57rCommented:
Hi stratasoft,

It's a long time since I saw these but I think the HFW functions are supplied with a helpdesk system (HEAT?) which includes CR as its reporting tool. (They are not part of standard CR)
There is nothing wrong with the expression you have posted so either there is more to the formula than you have posted or there is some other issue at work.

What  (precisely please)is highlighted when this message appears?

Pete
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
EwaldLCommented:
If the text HFWDateToDate is highlighted in blue, then the function is known to crsytal repports.
I'd guess though that the text is in black, like any other "random" text you would write (ie "somefunctionnamethatdoesnotexist()" would be in black, "left()" would be in blue since it's know on cr)

if it really is black, then cr doesn't know the function and some external dll will be missing like peter57r indicated.
0
mlmccCommented:
Agree.  I assume the data is saved with the report thus it works when the report is first run.  You need to find the DLL that has the HFWDateToDate function.  Look for dlls named CRUFLxxxx

mlmcc
0
stratasoftAuthor Commented:
The user was running Heat from a Citrix Server.  But running Cyrstal Reports from their local computer.  So the Heat Dll's were not on their computer.  I installed Heat on the local PC

Thank fixed it --- Thanks for the info
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.