network configuration

trying setup a session to a test machine that is on the other side of the world so I can reinstall solaris and setup some test apps. I can connect to it via a ssh session that I create from a windows terminal server that is in the same subnet. I need to get it where I can connect to it with a ssh session from my side of the world without going through the windows terminal server.  

The test box is a solaris 8 box at the moment.

I can ping the default gateway from my workstation and I can ping the default gateway from the test machine but I cannot ping from my workstation to the test machine or vise versa.

Have something wrong with the broadcast I belive.

Getting this from a ifconfig -a

lo0: flags=1000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
hme0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
        inet 134.32.65.177 netmask ffff0000 broadcast 134.32.255.255
        ether 0:3:ba:1:ab:5f

the ip is 134.32.65.177, the broadcast should be 134.32.65.129, and netmask 255.255.255.192.


don't think I have the /etc/resolv.conf right for one thing but not sure what to put in it.

Any ideas,

Thanks,



 

bt707Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yuzhCommented:
Check the DNS settings in your Solaris box, make sure:
 make sure your /etc/resolv.conf

  has the correct DND server infor, eg:
  nameserver 123.123.20.5
  replace "123.123.20.5" with your DNS server IP

   check your /etc/nsswitch.conf  file, and make sure hosts use dns:

hosts:     files dns [NOTFOUND=continue]
                     ^
# you can just modify the record to make it use files and DNS
3. If you had done step 1 & step 2 and it still not working, try:
to specify the defaulterouter:

vi /etc/defaultrouter
and put 123.123.10.1   in the file, replace "123.123.10.1 " with your router IP

or
echo "123.123.10.1" > /etc/defaultrouter

then reboot.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Artysystem administratorCommented:
I aggree with yuzh about setting correct /etc/defaultrouter
I disaggree with him that you need to reboot.

These values are hardly a correct:
netmask ffff0000 broadcast 134.32.255.255

Please look for correct netmask and boradcast values on your Terminal Server:
ipconfig /all

Then apply new netmask and broadcast to your solaris machine:
ifconfig hme0 netmask x.x.x.x broadcast y.y.y.y

where x.x.x.x is the same netmask as on Windows machine (in the same subnet) and y.y.y.y is the same broadcast value:

after setting this values try to ping sombody outside. If it works, make your changes permanent:
edit /etc/hostname.hme0 (there should be one line with host name) and change it as following:

inet 134.32.65.177 netmask x.x.x.x broadcast y.y.y.y

also please paste here 'netstat -rn' output from Solaris and 'cat /etc/resolv.conf' and 'cat /etc/hosts' and 'cat /etc/nsswitch.conf'


bt707Author Commented:
Thanks to both of you, I got it going, problem was the /etc/netmask

Will split the points here as both gave some good info here and all is working now.

Thanks again
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.