• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3899
  • Last Modified:

Local Area Network Connection Randomly Disables Itself

As the title says, The Local Area Network Connection on my server sometimes randomly Disables itself, Almost as if someone went to the network connections tab and right clicked and Clicked "Disable"

Has anyone ever heard of this happening before?  Could it have anything to do with the amount of bandwidth traveling through the network card at any given time?

I have checked the Event Viewer to see if there was any signs of an issue, but none seem to present themselves.

Any comments would be greatly appreciated.
0
1Parkplace
Asked:
1Parkplace
  • 8
  • 6
  • 3
  • +7
1 Solution
 
Craig_200XCommented:
in the properties of the network card in device manager there might be an option that allows the computer to "manage" the network card, make sure this is disabled.
0
 
sda100Commented:
Hello 1Parkplace

It won't be the amount of data throughput.  It could easily be a network address conflict.  How many other machines are on your subnet, and do you use static or DHCP addressing?

Are there any errors in your system/application event logs?  (Click Start-->Run-->"eventvwr")

Steve :)
0
 
sda100Commented:
Hello 1Parkplace,

Sorry - I read your question again - you've already checked the event logs...
0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 
Rob WilliamsCommented:
Check the network adapters properties in device manager, and see if power management is enabled. If enabled, it can switch off the adapter, though I don't believe it would show as disabled.

0
 
1ParkplaceAuthor Commented:
Yea, We are using DHCP Addressing, The Machine in question is within the Exclusion Range, and also has a DHCP Reservation for its IP address.

However the machine in question has a statically assigned IP address.

There was a setting on the network card itself that said something to the effect of "Let the system shut off this device to save power", I took this off just in case.

Yea, there is nothing in the event viewer which makes me suspicious.

Has anyone ever heard of SQL Server causing something like this to occur if it catches an exception?

Drew
0
 
Rob WilliamsCommented:
>>"There was a setting on the network card itself that said something to the effect of "Let the system shut off this device to save power", I took this off just in case."
That might actually do it. Especially common with random disconnects.
0
 
Danny_LaroucheCommented:
It may occure when there is too many errors. verify the network cable
0
 
Craig_200XCommented:
>>"There was a setting on the network card itself that said something to the effect of "Let the system shut off this device to save power", I took this off just in case."

thats what I was talking about. this is an annoying feature, IM not really sure WHAT reason that is good for at all... anyone know what real use that option serves?
0
 
Rob WilliamsCommented:
>>" anyone know what real use that option serves?"
"Real use" or MS design? :-)   It is intended to save power. Might make some minuscule difference on a stand alone system, but creates nightmares on networked computers.
0
 
Computerguy107Commented:
It is possible that your network cable is flaky. If that doesn't work I would replace the NIC in your server.
0
 
mattacukCommented:
I would check the quality of the cable,  if the RJ45 jack isnt secured onto the wires correctly this happens all the time.
0
 
masnrockCommented:
I wouldn't be surprised if had been the power management setting that you just made sure was turned off. It's an annoying little setting.
0
 
pseudocyberCommented:
I agree with Danny.  If the card is misconfigured for the network port, it may be seeing excessive Ethernet errors - which the Windows OS doesn't report very well if at all.  Look on the network equipment side at the port on the switch for Ethernet errors - FCS errors, Alignment Errors, Late Collisions - or any collisions at all.

make sure the NIC and the port are configured the SAME - if port is Autonegotiate, then make the NIC the SAME.  If the port is 100 Full, then make the NIC the SAME.

Whether your NIC will disable itself with excessive errors or not depends on the driver - in my experience, this is farily atypical.  It would be more expected for the network port to disable itself.
0
 
1ParkplaceAuthor Commented:
I am sorry for the delay, I did not realize that I had left it open.  I will go ahead and accept the answer that helped me out.

Thank you RobWill.
0
 
Rob WilliamsCommented:
Thank you 1Parkplace,
--Rob
0
 
Craig_200XCommented:
ahem.. no point split at least? I did put this as the first solution way at the top
0
 
Bill_FleuryCommented:
I really don't see how you could think your answer was the same as RobWill's Craig.
0
 
Rob WilliamsCommented:
Little vague Craig, but I have no problem with it if 1Parkplace agrees with you, and wants to split the points. For that matter if you folks feel it is the same answer, you are welcome to them all as the first one to respond with that answer. I'm happy with any decision on this one. They are just points <G>
--Rob
0
 
Rob WilliamsCommented:
Sorry Bill I didn't refresh before posting and see your reply. Regardless, I am easy....but don't tell anyone. :-)
--Rob
0
 
Craig_200XCommented:
Vague?

how is directing him to the network card properties in device manager and telling him to disable the option to allow the computer to "manage" the network card...

any different than:

Check the network adapters properties in device manager, and see if power management is enabled. If enabled, it can switch off the adapter, though I don't believe it would show as disabled.

if anything I said it 8 minutes earlier/faster...sure RobWill said the word power and it might shut it off ...  I really dont know how both of you can say its different... are you looking at the same post I am... reread the very FIRST response all the way at the top and then tell me we are talking vague, and you cant see how they are the same..
0
 
Bill_FleuryCommented:
Power managment is alot more detailed than telling someone that "there's something to do with managing it there".  Regardless, the author of the question returned and selected the answer that helped him out.
0
 
Craig_200XCommented:
Bill, I didnt say there is not a lot to it.. I merely directed him to the same spot Robwill did, you can choose to ignore that as you are doing. Robwill didnt explain power management more than a sentence either, so Bill keep denying the obvious.

I know were not talking about alot of points.. let me know what ever it is you guys are drinking or smoking, so I can get some.
0
 
Rob WilliamsCommented:
Craig, I would have to say my answer too, is a little vague, although the only choices are on or off, where as your answer simply points to the network card properties, where there are many configurable options.

Selfishly, Experts-Exchange is like a puzzle to me, I get great pleasure trying to find the solution to a problem, much like a chess game. In turn, those answers help me troubleshooting in the real world. As a result, points are of little consequence. I would be happy to "go to bat" for you, so that you may have all the points if it made you feel better. However, EE is not only intended to assist the person asking the question, but to assist others following in their foot steps. It is therefore very important, the most correct or useful answer be flagged as correct, to assist those in the future.
0
 
1ParkplaceAuthor Commented:
I'm going to leave my points with RobWill.  Craig when you posted I was thinking, what the heck is he talking about.  Then when RobWill Posted I said to myself "Oh yea, i know where that is!"

This is why I chose his over yours.

No hard feelings, i appreciate you attempting to answer my question and I know you had good intentions.

Thanks,

1parkplace
0
 
Craig_200XCommented:
its cool. thanx at least for trying to understand.. im sorry for my attitude - thanx for bearing with me in that.. RobWill u the man. and to Bill - sorry.

Im glad it was an easy fix for 1Parkplace..
0
 
Rob WilliamsCommented:
No problem Craig. Unfortunately because of the way forums work I know there is a tendency to try to get an answer in quickly, and detail is often overlooked or missed.
Cheers !
--Rob

Thanks for you patience with all of us 1Parkplace.
and, thanks for your continued efforts with clean-up Bill.
Did I cover everyone ?  :-)
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 8
  • 6
  • 3
  • +7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now