License, Nonsense

Hello citrix fans,
I have a farm with two W2k servers running Presentation Server 4
These servers were upgraded from a working MetaFRAME XP FR3 Farm (which worked perfectly)
When upgraded there were how you say "Problems" which resulted in rebuilding the farm from scratch. (Not too hard).

The problem occurs with licensing. The licence server is installed on our main domain controller.
It has been installed without the License console interface.

Upon running a Server Status and Diagnostics,
It shows 150 licenses all able to be checked out.
Problems occur with users logging on they recieve a "cannot connect to the Citrix Metaframe server. The Citrix Metaframe server is not available, please try again later."

The user can be put in by disconnecting a session. But this message can occur whether there are 70 80 87 93 or 100 users in. very innconsistant.

We are currently arguing with Citrix right now who do not want to help us as it is a technical issue.  

Oh yeah we have also set up another machine to be the licence server, changed the name on the lic file.
and setup the Farm to use the new server same problems??  

It must be the licence file right!!  

Thanks for your time,,  

Licensing log file

12:12:50 (lmgrd) -----------------------------------------------
12:12:50 (lmgrd)   Please Note:
12:12:50 (lmgrd)
12:12:50 (lmgrd)   This log is intended for debug purposes only.
12:12:50 (lmgrd)   There are many details in licensing policies
12:12:50 (lmgrd)   that are not reported in the information logged
12:12:50 (lmgrd)   here, so if you use this log file for any kind
12:12:50 (lmgrd)   of usage reporting you will generally produce
12:12:50 (lmgrd)   incorrect results.
12:12:50 (lmgrd)
12:12:50 (lmgrd) -----------------------------------------------
12:12:50 (lmgrd)
12:12:50 (lmgrd)
12:12:50 (lmgrd) Detecting other lmgrd processes...
12:12:51 (lmgrd) Done rereading
12:12:51 (lmgrd) FLEXlm (v9.2i) started on dc1 (IBM PC) (4/12/2006)
12:12:51 (lmgrd) Copyright (c) 1988-2004 by Macrovision Corporation. All rights reserved.
12:12:51 (lmgrd) US Patents 5,390,297 and 5,671,412.
12:12:51 (lmgrd) World Wide Web:
12:12:51 (lmgrd) License file(s): C:\Program Files\Citrix\Licensing\MyFiles\citrix_startup.lic C:\Program Files\Citrix\Licensing\MyFiles\license_20060407075433.lic
12:12:51 (lmgrd) lmgrd tcp-port 27000
12:12:51 (lmgrd) Starting vendor daemons ...
12:12:51 (lmgrd) Started CITRIX (pid 1320)
12:12:52 (lmgrd) CITRIX using TCP-port 1075
gram Files\Citrix\Licensing\MyFiles\CITRIX.opt"
12:12:52 (CITRIX) Server started on dc1 for:      CITRIX            
12:12:52 (CITRIX) MPS_STD_CCU      MPS_STD_CCU      MPS_STD_CCU      
12:12:52 (CITRIX)
12:12:52 (CITRIX) Licenses are case sensitive for this vendor
12:12:52 (CITRIX)
12:12:52 (CITRIX) Not logging IN messages
12:12:52 (CITRIX) Not logging OUT messages
12:12:52 (CITRIX) TCP_NODELAY enabled
12:13:21 (CITRIX) DENIED: "MPS_STD_CCU"  [f5f4cd30:MPSCLIENT] (Licensed number of users already reached (-4,342))
12:13:23 (CITRIX) DENIED: "MPS_STD_CCU"  [c5bab681:MPSCLIENT] (Licensed number of users already reached (-4,342))
12:13:27 (CITRIX) DENIED: "MPS_STD_CCU"  [5bde2322:MPSCLIENT] (Licensed number of users already reached (-4,342))
12:13:28 (CITRIX) DENIED: "MPS_STD_CCU"  [ff5aff76:MPSCLIENT] (Licensed number of users already reached (-4,342))

e.t.c (goes on for ages)
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

>> Oh yeah we have also set up another machine to be the licence server, changed the name on the lic file.

You cannot simply rename the lic file or change the server name inside the file (unless you know something that many people do not) so I'm not sure this is a valid test.

Have you tried installing the license server on another machine and then re-downloading the licenses from
MaxitransAuthor Commented:
sorry mgcIT, my wording was a bit misleading. we have rehosted the license server and generated the new license file from and then configured the farm to point to the new license server, but are still getting the same errors
ok what about TS Licensing?  Have you checked to make sure you haven't run out of that?
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

MaxitransAuthor Commented:
yep we are on windows 2000 AD and have 30 TS CAL's with 16 available (nearly all our users are 2000Pro or XP Pro with the license builtin
ok well that eliminates the "easy" fixes that I can think of.  Did this just start happening when you rebuilt your farm, or has it been running PS 4.0 fine then all of a sudden started having problems?  Also what about RDP connections?  When the server reaches it's limit can you connect via RDP?
MaxitransAuthor Commented:
we had the same problem initially when we upgraded ps3 to we went for the drastic option of uninstalling the farm completely and then performing a clean ps4 install with a new farm of the same name with the same settings. When the server reaches the limit (or whatever it decides on at the time) we cans still connect via rdp.

Is there anywhere that will tell me what the errors in the debug license server file are? I would really like to find out why this error occurs:

(CITRIX) DENIED: "MPS_STD_CCU"  [ff5aff76:MPSCLIENT] (Licensed number of users already reached (-4,342))
I think that there's a hotfix for this for Windows Server 2003 & PS4, but when I had a look I couldn't see one for Windows 2000 Server. Do you have the PS4 Hotfix Rollup Pack installed?

See if these articles are any help:
MaxitransAuthor Commented:
Hi Darwinian, yep we have the ps4 hotfix rollup installed, just for the hell of it I reapplied the hotfix last night but it didn't seem to help
Citrix are normally pretty accomodating when it comes to licensing issues, so I'd call them and tell them about the errors in the licensing log. Normally they don't support customers directly without charging them, so you might have to go through whoever sold you the Citrix licenses, who should be a Citrix partner and have direct access to their support.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MaxitransAuthor Commented:
yep we have been talking to citrix, they consider this a technical issue, not a licensing issue. The only way we will get support direct from them is to enter a $3500 support agreement for 15 incidents and 1 year term. We are loathe to do this as we have never needed support yet in the last 2 years, so I'm pretty sure if they fix this problem our other 14 incidents will be a waste of money.

Its frustrating that even though the license log specifically states "licensed number of users already reached", citrix support won't believe it is a licensing problem

Good idea with the reseller though, I'll talk to them and see if they can log a support call for us. If we don't get anymore usual ideas and tips I'll award the points to you Darwinian
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.