• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 493
  • Last Modified:

Problem with Single Sign-On when configured using Internet Sites

In the past, we've done a successful proof-of-concept with Java servlets that use Single Sign-On to share authentication with Domino to access Notes databases.
This Domino server was configured using the "R5 method" of configuring web sites, in "Web - Web Configurations". This worked perfectly.

We're now testing on a new Domino server, and going forward we'd like to use the new method of configuring web sites, in "Web - Internet Sites", as recommended by IBM.
The same setup, with an LtpaToken and everything, now gives us a very odd error message on the Domino server console:

HTTP JVM: NotesException: Notes error: Creating administration request to create mail file for %A...
HTTP JVM:       at lotus.domino.local.Session.NgetSessionToken(Native Method)
HTTP JVM:      at lotus.domino.local.Session.getSessionToken(Unkown Source)
HTTP JVM:      at com.our.own.class.<init>(ourownclass.java:94)
...

Domino seems to choke on getSessionToken(), but the error message looks very odd. It seems completely out of context (why would a login action fire off an admin request for creating a mail file...?!) and the %A seems to indicate that the message is not correctly formatted by Domino.

To me this looks like a Domino bug, but on the other hand I find it hard to believe that I would be the first one setting up SSO using Internet Sites as opposed to Web Configurations.

Any help here?

The proof-of-concept set up was a 6.5.4 server and the new server is a R7 server, so is there anything we need to do in this regard? Different Notes.jar required? Different JRE?

Many thanks
0
int21dotorg
Asked:
int21dotorg
1 Solution
 
int21dotorgAuthor Commented:
Strangely enough, I pasted javascript:window.alert(document.cookie) in my browser, and it showed LtpaToken=AAEC........................etc.etc., so the cookie seems to be created, but Domino just seems to choke at some point.
0
 
SysExpertCommented:
DId you upgrade to R 7.0.1 yet ?

Have you checked for the message on the IBM support site ?

http://www-306.ibm.com/software/lotus/support/

I hope this helps !

0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now