WordPerfect 11 Macro locks-up (crashes) after updates are applied

It's a very simple macro. It opens a .frm (simple memo) with the merge command and walks through adding information to the memo. The macro worked before we updated WP11. I tried re-recording the macro and it worked when I played it. Next I exited WP11 and relaunched WP11. Tried to play the macro again. It goes through the first steps of allowing entries into the form, but crashes (locks-up WP11 or generates a WP11 Recovery Manager screen) when it tries to merge the information into a new document.

Here is the macro:

Application (WordPerfect; "WordPerfect"; Default!; "EN")
FileOpen (Filename: "P:\pgmemo.frm")
MergePageBreak (State: On!)
MergeRepeat (NumberToRepeat: 1)
MergeBlankField (State: Remove!)
MergeCodesDisplayRun (Display: Hide!)
MergeRun (FormFileType: Current!; DataFileType: NoData!; OutputFileType: ToNewDoc!)

The last line is the one that crashes.

Thank you,

Jeff Forville
jforvilleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

moorhouselondonCommented:
Are you running the latest updated version of WordPerfect: Service packs are on Corel's website.  

Try copying and pasting the FRM document to a brand new document.  There could be some difference in the structure of the document templates between versions of WordPerfect.  Try recreating the FRM document - which presumably has Merge codes in it - there might be some idiosyncracy with the codes that make up the Merge Codes between versions of WordPerfect.  Just delete each Merge Code and re-insert it should be sufficient.
0
jforvilleAuthor Commented:
Moorhouselondon:

Thank you for your assistance.  Using the latest version (Updates and service packs) of WordPerfect is what initially caused the problem.  I tried your suggestion and the problem still exists.  The only merge code is KEYBOARD.

Jeff
0
moorhouselondonCommented:
What printer is being used?  Try defining a HP LaserJet 4 or similar (which has a well behaved printer driver), and temporarily set this to be the default printer.  Go into the FRM document, set this to use this printer and resave the document.

Now try running the macro again.

If the problem clears then the printer driver you have been using needs to be updated.  

Having run this test, don't forget to delete the temporary printer driver.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

jforvilleAuthor Commented:
moorhouselondon,

Again, thank you for your response.  That also did not work.  The default is a HP4050.  There are many users who are using this macro and are connected to a number of different printers, and all are having the same exact problem.

Jeff Forville
0
moorhouselondonCommented:
Try reducing the lines in the Macro:-

(1) Get rid of FileOpen and do the opening in the MergeRun (use FormFileType: FormFile, and specify "P:\pgmemo.frm" as the FormFile.
(2) Get rid of MergeRepeat.

Then if there's no change experiment with:-

(3) Try setting the OutputFileType as ToFile
(4) Get rid of MergePageBreak and MergeCodesDisplayRun

Let us know how you get on
0
jforvilleAuthor Commented:
moorhouselondon,

No good. It's wack!

Thanks.  Jeff
0
moorhouselondonCommented:
OK Last possibility.  Move:-

P:\pgmemo.frm

to somewhere on the C drive which has unrestricted user rights.  WordPerfect can be a bit particular about network drives sometimes...
0
jforvilleAuthor Commented:
Moorhouselondon,

That was one of my first moves.  Again, it worked find until I applied the latest updates.  Turns out that may be the only solution - reinstall and don't apply updates.

Thanks for your help.

Jeff
0
GranModCommented:
PAQed with points refunded (500)

GranMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Office Suites-Other

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.