File Attributes on W2K3 File Server

Hi,

We have a network where the main file server was Windows 2000 Server SP4. Recently, we purchased a new server, and I have built it on Windows 2003 SP1.

I've copied over a few shared folders to this new server and changed the client mappings to reflect this. All seems to be well.

However, on the W2K3 server, if I go to one of the shared folders, there is a description called 'Attributes'. Some files have an attribute of A, some R.

Does anyone know what this means? I thought it would be read-only, read/write etc, but all files seem to have the same security permissions but diffferent attributes?

I expect it's something very simple that I'm going to look stupid asking about ;)

Thanks in advance.
LVL 2
Dilan77Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris DentPowerShell DeveloperCommented:

R - Read Only
A - Archive Bit

Attributes are entirely seperate from Security. Attributes like Read-Only will override whatever the security settings say about writing, but it's just a case of removing a tick so it's not a way to make a file secure.

The Archive Bit is used by Differential (changes to the file system only) backup jobs to determine whether or not a file should (or has been) backed up. Once done the Archive Bit will be reset which indicates that it has been backed up.

HTH

Chris

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dilan77Author Commented:
Hi

Thanks for the quick answer.

Sorry, could you expand on the Read Only attribute?

Who sets this?...and who can change it? For instance, with Security, the permissions can only be set by accounts with the rights to change the permissions. What is the situation with attributes?

Thanks
Chris DentPowerShell DeveloperCommented:

I couldn't tell you who sets it, it's not something that's turned on by default. You may find it's set to on if you've copied a file off a read-only disk (like a CD for example).

You might notice that on 2003 Server Read Only is always ticked but shaded grey. This is to allow administrators to easily disable the Read Only attribute on everything without setting it to On first.

So you could remove the tick, set apply to Subfolders and Files then OK which will say you're going to "Unset Read Only". Next time you go in it'll still be shaded grey and ticked, but it's not really On.

To set Attributes it you need the "Write Attributes" permission on the file, it comes by default with Full Control and Modify permissions.

Chris
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Dilan77Author Commented:
Hi Chris

Thanks for the explanation. Much appreciated.

Yup, I'm having the exact same issue you mentioned with the Read Only attribute always ticked but grey. I copied my User folder over from the wk2 server to this one. However, I'm unable to make any changes to any files in this folder. The Security permissions seem to be set correctly - I have full control - but in the Properties>General pane, there is a grey Read Only checkmark. I've removed the tick, set Apply to Subfolders etc and, as you say, the next time I go in the shaded tick is still there. You mention it's not really on, but I still cannot save/delete/modify any files in this folder? I've logged out of my machine for the changes to take effect too.

I've also used the: attrib -r <folder_name> command at the Command Line, but this seems to have had no effect.

Any ideas?
Cheers
Dilan

Dilan77Author Commented:
Sorry, forgot to mention, the User folder is shared and I've changed the Share permissions from Read only to Full Control for everyone.
Chris DentPowerShell DeveloperCommented:

> However, I'm unable to make any changes to any files in this folder. The Security permissions
> seem to be set correctly - I have full control - but in the Properties>General pane, there is a
> grey Read Only checkmark.

It's not a problem, rather a feature (if it can be called that).

You are actually removing the attribute when you first untick it and select apply to subfolders. You don't need to worry about the fact it stays grey after that, it's just like that to make life easier when you're trying to get rid of the attribute.

The Read-Only attribute is not causing any problems you're running into.

Chris
Dilan77Author Commented:
Hi Chris,

Yeah, it wasn't the read-only attribute that was causing the issue - it was a red herring.

I disconnected the share and then recreated it by going to the File Server Management console (C:\WINDOWS\system32.filesvr.msc) and then 'Add A Shared Folder'.

Thanks for all the help and explanations.

Cheers,
Dilan
Chris DentPowerShell DeveloperCommented:

Pleasure :)

Chris
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.