Printing with RDP and VPN

I have someone that is connected to my server VPN and is trying to print via RDP to her printer. The printer is a HP4250 and its connected thru a parallel cable and is assigned as a lpt port on both computers. Also the drivers on both computers are the same as well and both of them have printer resources available checked off. Yet when you try to print, terminal services says that the printer is not available. Can anyone help me out with this?

The server is a windows 2000 server edition and the computer is a windows xp machine.
jamessaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fm250Commented:
let her make sure she checked the printers when she connect in the local  resources tab. also reinstalling the driver for the printer in the server might help.
jamessaAuthor Commented:
She did check printers.  The printer driver was reinstalled.  She connects to other networks with the printer and it shows up for her then.
fm250Commented:
did you reinstall the driver in the server?
Cloud as a Security Delivery Platform for MSSPs

Every Managed Security Service Provider (MSSP) needs a platform to deliver effective and efficient security-as-a-service to their customers. Scale, elasticity and profitability are a few of the many features that a Cloud platform offers. View our on-demand webinar to learn more!

Danny_LaroucheCommented:
Do you have both Win2000 and XP drivers on the server
jamessaAuthor Commented:
No, just XP
jamessaAuthor Commented:
Which driver should i put on the 2000 server?  2000 or Xp?
Rob WilliamsCommented:
Check in the System Log of the Server's event viewer. If the drivers are not being found (i.e. not correct) there should be an error reported with Terminal Services as the source.
jamessaAuthor Commented:
The funny thing is I don't see anything about it in the event viewer.
Rob WilliamsCommented:
Odd, usually any connected RDP printer that is not recognized, due to lack of drivers, shows up as an error. By the way to the best of my knowledge it is the 2000 drivers you want to install on the server.

This is an HP4250 we are talking about, right? There is also an HP4250 print server.

How did you install the drivers. Best method is not to use an exe file but rather open the printers window, on the menu bar choose file | Server options | Drivers | add | and point to the .inf file

Which driver did you install, if PCL 6 try the PCL 5 or even the HP universal driver. All available from their web site.
Danny_LaroucheCommented:
Both drivers should be there. During installation it normally as "what other drivers are needed..." or something like this. Make sure the checkboxes for 2000,2003 and XP are checked
Rob WilliamsCommented:
Danny, you really only need "other drivers" if they are to be installed on new machines from the server, don't you?
scrathcyboyCommented:
If the drivers for the printer are different than on the "server" (system cabled to printer) she will have exactly this trouble.  XP use unidrivers that dont always work right on HPs.  Need to go to Pserver, see version of driver it installed, remove all from her XP system, and "GET" the driver from the Pserver machine.
jamessaAuthor Commented:
This is a hp4250 laser printer.  I installed the drivers the way robwill stated.  I installed pcl5 driver for XP on the server.
jamessaAuthor Commented:
Could it be a firewall issue?
Rob WilliamsCommented:
>>"Could it be a firewall issue?"
Shouldn't be. You could disable on the XP machine but the TS traffic should be allowed access to the local resources.
Have you tried any other printers? That might narrow it down to a driver or connection issue.
jamessaAuthor Commented:
No I have not, but she connects to other peoples networks the same way with no issues.
Rob WilliamsCommented:
Very bizarre. So it must be the connection or the 2000 server/drivers.
I had a Dell laser printer using LTP1 cable the other day that the only way I could get it to work was to install it on the server as if it were a local printer. Then connected from the client in the normal fashion, not using that printer I had created, but the standard TS port you have been using and it worked fine. I haven't been back to clean it up and find out why that is the case, but it did work for some reason. If you are desperate, give it a try.
RiceyRiceCommented:
A few things to try

1. Install an alternate local printer onto client machine, using the HP Laserjet 4 driver (An oldie but a goodie, it will still work on the local client, and that 2K server will have a far greater chance of picking it up) and just have the user try to print to that one.
2. Install the HP4250 drivers on the server.
3. If they are VPN'd, share the 4250 from the client, have the server connect to it and print over the VPN instead of the RDP.

A great resource on TS printing in 2000 Server:

http://www.brianmadden.com/content/content.asp?ID=62

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jamessaAuthor Commented:
The HP 4 driver is installed on the client maching.  No go there.  I will try the VPN idea.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.