Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 335
  • Last Modified:

Wine installation error!

Hello,
I'm tryin to install Wine ( latest ) in suse 9.3 and i'm get an error that i don't have some mods.


host1:~/wine/wine # rpm -i wine-0.9.11-SuSELinux100.i586.rpm
warning: wine-0.9.11-SuSELinux100.i586.rpm: V3 DSA signature: NOKEY, key ID 0175623e
error: Failed dependencies:        
        libGL.so.1 is needed by wine-0.9.11-0.1      
        libGLU.so.1 is needed by wine-0.9.11-0.1        
        libasound.so.2 is needed by wine-0.9.11-0.1        
        libasound.so.2(ALSA_0.9) is needed by wine-0.9.11-0.1      
        libasound.so.2(ALSA_0.9.0rc4) is needed by wine-0.9.11-0.1        
        libglut.so.3 is needed by wine-0.9.11-0.1        
        liblcms.so.1 is needed by wine-0.9.11-0.1        
        libstdc++.so.6 is needed by wine-0.9.11-0.1

I tried downloadin Mesa-3.4-5.src.rpm which was meant to install some of these mods..but still it didn't work.When i installed Mesa it didn't gave me any errors with the Mesa installation.
Any ideas how to fix this? ..I'm a linux newbie..so please give me details

btw, this is my second topic..cuz on the old one no one did response..i thought i did post in the wrong section
0
viganothing
Asked:
viganothing
1 Solution
 
Duncan RoeSoftware DeveloperCommented:
libstdc++.so.6 comes with gcc 3.3.4 or newer. What is your gcc rev? (type "gcc --version" to check).
What I am thinking is - does Suse use RPM normally? Perhaps the software you want is already installed but not by rpm.
Try this: "locate libGLU.so.1". Found in /usr/X11R6/lib?
Find out and install what's *really* missing.
The use --nodeps option of rpm to install wine.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now