[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

USB flash drive problem, no drive letter, no access

Posted on 2006-04-12
30
Medium Priority
?
1,632 Views
Last Modified: 2007-12-19
I've got USB problems,  have researched all the USB drive related issues, no answers for me yet. My  problem is this:  I have had 3  computers suddenly "give up the ghost."  when it comes time to recognize and assign a drive letter to a USB flash drive, or a USB zip-750 removable disc, or a camera dock for casio camera.  All these devices normally work in winxp with no drivers, and no installation..

I've checked all the mapped network drives, other issues, no help.  THe flash drives (three of them, 2 sandisk 1 gig, 1 other,  the ZIP 750 is Iomega)  all work fine on other computers. I thought it might be some software utilities that I've used, but no, I've tested that theory to exhaustion, I get no problems on other computers.  

WHat happens is this: 1) plug in drive or insert zip disk.    2) computer "beeps", and the icon shows up in systray for "mass storage device", so I know the hardware and part of Windows(XP, SP2)  knows its there.    3)  no drive letter in explorer.    4)  go to Disk Management,  the drive shows up as a FAT or FAT32 drive,  I try to assign a drive letter,  I get a message that the "device is not enabled,  restart computer to enable device."
5) multiple restarts, no help.    6)sometimes, I can assign a drive letter, and access the drive through that letter by typing it into explorer, usually not.  After I unplug it, and plug back in,  then I cant use that letter anymore, and the device is not recognized.  The drive letter shows up in explorer, but no good,  it gives me various error messages when clicked.  after restart, I can use that drive letter again.

I do have a habit of making images of the boot drive every month or so.  In each case, when I restored an image from late november 05, or early december 05,  the USB problem went away.  I  restored images from Jan 06, Feb 06,  in each case, the problem came back immediately.  

This tells me that it's a windows issue, the hardware is all working fine, and works perfectly  (assigns drive letters, autoplay ok, removes drive letters when I unplug, etc.)  when I restore a hard drive image  (boot drive  only, all other drives/partitions are the same)  from  12-05 or so, and then goes crazy when I have a more recent version, with more windows updates, and some software changes.  All three computers have different motherboards, I do not use drivers from sandisk, iomega, etc, the windows drivers work fine when they work.

Any help out there??? I suspect it has something to do with the way that windows assigns drive letters, but have tried all the fixes on this board and several others.  I KNOW it's not a hardware problem,  I KNOW it's windows, possibly incombination with other software, but I'v installed/uninstalled several large packages  (roxio 6,  roxio 7,5) and some smaller utilities, backups, etc,  too numerous to mention, plus the "mix" of software is different on all three computers, so I'm pretty sure that its WINDOWS alone that's causing this problem.  THanks,  JOhn S.
0
Comment
Question by:jshamrai
  • 8
  • 5
  • 4
  • +5
24 Comments
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16441454
do you have the latest windows update on all the machines?
latest motherboard updates on all machines?
0
 
LVL 9

Expert Comment

by:sda100
ID: 16441698
Hi jshamrai

Try removing all the USB devices in device manager.  To make sure you can see all hidden and uninstalled devices, do the following:

1. Click Start
2. Click Run
3. Type cmd.exe in the textbox and click OK
4. Type set devmgr_show_nonpresent_devices=1 and hit ENTER
5. Type cd\windows\system32 and hit ENTER
6. Type start devmgmt.msc and hit ENTER
7. When the device manager opens, click the View menu
8. Click Show Hidden Devices

Remove everything from the "Universal Serial Bus Controllers" section, then reboot.

Windows will detect all that it needs to next time it starts.  Does this help the problem?

Steve :)
0
 

Author Comment

by:jshamrai
ID: 16441871
I've tried removing everything in the USB controllers section.  I can't remember if the "hidden devices" trick was used when I did that,  I can try it again and make sure that the hidden and nonpresent devices are included.  I didn't help when I did try it,  same errors.

On the motherboard/ and windows updates.   I don't know how to say this, must try to be polite and not make too many comments about the imbecility of Gates and company..........................  lets try this:  99.99 %  of the  "windows updates"  are plugging security holes in the operating system, which the hackers then proceed to punch more holes in, at the rate of 1-2 major "new" security holes per week.  THis has been going on for at least 5 years, that I can remember, the number of "windows-based" viruses is over 150,000 now, and growing at pretty much the same rate as it was in 2002.  All this, while we are constantly reminded how important it is to have the "latest updates."  If these updates were working, then at least the rate of new security holes would have slowed by now, methinks.   Anyway,  as I tried to explain in the original question,  when I am using a windows install which is restored from an image from 12-01-05,  the usb problem is gone, it works perfectly.  When I'm using a system which has the added advantage of more recent  updates (from december and january), that's when the problem rears its ugly head.  I've stopped using windows updates on most of my computers since about august, 05, when windows update fried a computer for me.  I do update some of them, and just by chance, the ones with the  "USB BUG"  are more updated (windows) than the ones that work.

THe motherboards are fine.  As I said, the problem goes away entirely when I restore an older image.  I would just stick with this, except that we are using USB devices more and more at work, and the next time this happens, I'd like to know how to actually "FIX" it, rather than backtracking.  We need to upgrade and change software from time to time,  I would like to be able to use Windows Update  (for security),  but have stopped using that on most of our computers, since I'm not looking forward to trying to fix this problem again and again, and I kind of suspect that one of those wonderful  "windows updates"  has somehow contributed this problem.  I'm not sure of this, but have ruled out all kind of other stuff.  

Sorry to be so verbose,  I'll try removing more devices, hidden, nonpresent, imaginary and otherwise,  see if that helps,        John S.

0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
LVL 14

Expert Comment

by:ppfoong
ID: 16442355

I remember that USB flash drive can only be the only one drive plugged to the USB port, and cannot share USB resource with other disk drive kind of USB device.

You can try plugging your USB devices in the way that their USB port is not sharing resource with the one you plug in the flash drive. In most motherboard, there are shared and non-shared USB ports.

0
 
LVL 4

Expert Comment

by:samb39
ID: 16442646
This article suggests assigning a higher drive letter to a new volume to avoid a drive letter collision.

http://support.microsoft.com/?kbid=297694

This thread describes two other people with very similar problems, and the cure was to go into Device Manager and change the drive letter of the removable disk.

http://www.experts-exchange.com/Storage/Q_20950260.html
0
 
LVL 93

Expert Comment

by:nobus
ID: 16443368
hey jshamrai, i understand your frustration. i must say that a lot of questions here lately are about just the same problem you have, and a real cure still has to be found. the best you can don is as said above; but maybe this can help too :

http://ntcompatible.com/Desperately_need_help_---_USB_Devices_Not_Recognized_t32356.html
0
 
LVL 93

Expert Comment

by:nobus
ID: 16443376
you can also try this :  usb drive not listed in My computer, but listed in Computer management

Start->Run->cmd /k reg query hkcu\software\microsoft\windows\currentversion\policies\explorer
(You can copy everything after Run-> into your Run's Open box and hit <Enter>
! REG.EXE VERSION 3.0

HKEY_CURRENT_USER\software\microsoft\windows\currentversion\policies\explorer
    NoDriveTypeAutoRun  REG_DWORD       0x91
    NoStartMenuEjectPC  REG_DWORD       0x1
    NoWelcomeScreen     REG_DWORD       0x1
    CDRAutoRun  REG_DWORD       0x0
    ClearRecentDocsOnExit       REG_BINARY      01000000
    NoSMMyPictures      REG_BINARY      01000000
    NoSMMyDocs  REG_BINARY      01000000
    NoDrives    REG_BINARY      33FFFE03

The hex value of 33FFFE03 seems to equate an invalid assignment

Start->Run->cmd /k reg delete hkcu\software\microsoft\windows\currentversion\policies\explorer /v NoDrives /F
May require a reboot afterwards - just ensure that command comes back "successful".
the highest decimal value that should ever exist there would be 67108863 (or hex, 3ffffff), which effectively 'hides' every drive from A to Z.  

let me know if it helps !
0
 
LVL 1

Accepted Solution

by:
MHurtares earned 1500 total points
ID: 16447725
This has become a common problem that is caused by Microsoft's security patches.  Here is a thread that covers this issue, some with a lot of detail.  Maybe one of these may help:
http://techrepublic.com.com/5208-11183-0.html?forumID=89&threadID=192306
0
 

Author Comment

by:jshamrai
ID: 16450799
Thanks for the suggestions, guys.  I've tried removing unhiding all the "hidden and non-present" devices, removing all usb devices and drivers.  That has gotten me a little ways,  most of the time I can assign a drive letter with device manager after the system restarts and re-installs drivers, however, if I assign letter E:, for example, to the usb drive, then I can access it, read/write etc  in windows explorer.  BUT,  when I do the "safely remove hardware", and the drive shuts down  (light goes off),  and then I remove and reinsert the drive, then e:\  is no longer pointing to the drive.  E: shows up in windows explorer as a drive, but I get an error    "e:\  refers to a location that is unavailable, ............".

I can then go to disk manger, assign a new letter, and access the drive, but when I remove it  (properly, or improperly, just pull it out, doesn't matter),  then the next letter is also "frozen".    After reboot, then the letters are available again.

Also, I'm losing contact with the iomega zip-750 drive the same way, pretty much same symptoms.

I do have an older Lexar media usb drive that actually works fine on one  of the "problem" computers, but not the other.  It seems that whatever happened to cause this, somehow it "remembers"  that drive, and never forgets or forgives.  Does anyone know where all the info on a particular usb drive is stored in the registry???    I'v e found a few spots, but there are probably many more.

I'll try the tech republic link.  I'll be gone for a few days,  try it when I get back.  What is the rule on how long this goes on before we give up??

If it were just these two usb drives, then I could live with that.(  by the way, I've plugged these drives  (sandisk mini) into at least 7 0r 8 other computers with win xp or win 2000,  every one of them just picks it right up, gives it a drive letter, opens explorer to the drive,  etc.  no problems.
Also,  it's not a matter of the order of drive letters, or networked drives.  All letters from D:\  to I:\  are available,   the hard drives  (except c:\,),,  cd-dvds,  network drives, etc,  start at J:\     I learned long ago that it was best to leave some "space" for the usb devices, we plug and unplug them all the time,  and they have plenty of drive letters available.............

So I know the drives themselves are fine, I use them every day to backup and copy stuff,  they never even blink, except on these computers.  As I've said,  I quit doing windows updates about 6 months ago on most of our computers, and the ones which have NOT had recent updates seem to be more trouble-free, although I dont'   keep precise track of that.


I'll be back in a few days,  try again,  thanks again for the advice.

0
 

Author Comment

by:jshamrai
ID: 16483530
OK,  I've tried removing all the hidden/nonpresent devices related to usb.  It changes the picture slightly, in that I can now assign a drive letter predictably.    (there are always at least 4 available drive letters on each of these computers before the first mapped network drive).

THen, I can access the drive through windows explorer, read/write. All works ok....  However, after disconnect  (either "safely remove"  or just unplug it), that drive letter no longer works,  get an "unavailable location"  error.  I can reassign another letter, and same thing after removal.

Once I've assigned  several drive letters to the same drive, unplugged several times, then I have to reboot to free up those drive letters.

After removing all devices, and restart, windows does find a "new device", loads drivers, and then tells me that the new device is "ready for use."     However, the drive letter is not assigned unless I do it manually. THis applies to the digital camera, zip 750 drive (iomega), as well as the sandisk USB flash memory drives.  

I'm about to give up on this problem, I think there is a glitch in the way that windows handles the assigning of usb device drive letters, and once it gets "triggered",  you are stuck with either reformat/reinstall,  or just make sure you image the system/applications drive frequently so you don't have to start from scratch.   Untill Microsoft decides to tell us what the problem is, I think we're stuck.  I've tried using regmon to see what reg keys are being accessed, and maybe find a clue,  but as soon as I plug in the USB drive, I can shut down remon about .5 seconds later, and there are over 800 registry accesses, all kinds of crazy stuff,  it looks like it would take a week or more of work to figure this out.

Thanks for the tips,  and I'll keep trying from time to time, but I think the idiots at MS have won this battle for now,  

John Shamraj
0
 
LVL 4

Expert Comment

by:samb39
ID: 16504261
I just read an interesting thread that suggests the problem is draining too much power with too many USB devices, and that the cure would be to buy a high-quality Belkin powered USB hub.  That sounds like a likely general solution to the bizarre and inconsistent problems so many people have with USB devices.

http://www.experts-exchange.com/Hardware/Q_20915592.html

0
 

Author Comment

by:jshamrai
ID: 16860010
This is from the original poster of the question.  It's not really anwered.  I have no objection to "closing" it, since we aren't
getting any closer to the solution.  

I do, however, think it's good that we make it clear that there is a problem that a lot of people have had, and probably will
continue to have, which hasn't bee addressed.  It adds up to a lot of wasted time and frustration.

This usb problem in my situation was absolutely not  a hardware problem.  The hardware all works fine if I reboot the computers into another operating system  (dual-boot, windows xp or 2000).  The usb drives (4 of them) all work fine in other computers.  

I can fiddle with the drive assignments enough in Disc Manager to even reformat the drives, and then access them on the problem machines.  Then I can read/write/delete, etc.   HOWEVER,  the next time I plug that drive into the same machine, using ANY USB port, it is not recognized, and usually the drive letter assigned is now "locked", cant be used for anything.  

Other drives sometimes work in the "problem" machine, sometimes not.  I've had this problem mostly with Sandisk drives, but also with a casio camera, and with a 2 zip-750 drives.  I'm pretty sure that the problem is in Windows XP, since the mix of sofware on the computers is varied.  I've tried all the fxes here, and some others, not much help.  Some of the fixed  (registry edits, removing devices)  will give me temporary access, but every one fails after removal/reinsertion.  

I think that somehow Windows XP has "blacklisted" the particular drive  (not by volume ID, since I've checked and changed that, no help),  and remebers it.  When it sees that same drive again,  it denies access.   What is needed here is someone who understands all of the steps that WinXP uses in detecting and mounting a removable USB device,  and which step in the sequence is used to remember a previously mounted device, and then DENY ACCESS to that device.  That may lead to a solution, I'm pretty sure that's what is happening after going through multiple scenarios and ruling out just about everything else under the sun.


So, we can close this for now, but it hasn't been anwered, and I'm willing to bet that it will come back again.   John Shamraj
0
 
LVL 93

Expert Comment

by:nobus
ID: 16860219
i found this too :
in regedit navigate to :  HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
Delete All of the \DosDevices\ ... values corresponding to external usb drives/keys/thumbdrives etc
0
 
LVL 1

Expert Comment

by:MHurtares
ID: 16861834
I had a problem where a webcam would not work on any other USB port other than the original port that it was installed from.  I know you said that the problem arises upon reinsertion, but try reinsertion to only the same port.  It is just a thought, even though it is not logical.
0
 

Author Comment

by:jshamrai
ID: 16863284
I've tried reinsterting in the same port, as well as other ports.  When this problem rears its ugly head, it doesn't matter which port, the action of winxp is the same.  The computer recognizes the drive, the lights go on, the "found new hardware"  icon starts up  (if the usb devices or the drive have been removed in device manager),  the computer says  "your drive is ready to use",  etc.   All indications are that the motherboard and the lower-level  functions of windows are recognizing the drive.  The windows xp Disk Management can ALWAYS  see the drive, it shows as a removable drive, the size of the drive is always correct  (512 mb,   1024 mb, 2048 mb,  750mb,  etc. Whatever the size of the physical drive or flash memory chip, usb or compact flash, or secure digital or whatever,  that is correctly recognized by the Disk Manager under "admin tools")

So, the computer knows the drive is there, it knows what size it is, it knows what it is,   but when I try to assign a drive letter, then there's a problem. Same if I try to mount the drive in an empty NTFS folder, which I usually do, for easy "shortcut" access, and to not have to use up a drive letter.   WinXP will not let me USE or Mount  the drive, and if I insert another USB drive  (different brand), the other brand works.    So I'm pretty sure that this drive itself, whether zip 750, sandisk usb, or memory card in a camera,  has been somehow identified and "tagged" by windows XP,  and access is denied from that point on.  Repeating what I've said earlier,  if I restore the operating system from an image  (which may be 2 months or 2 weeks old),  then the problem disappears.   If I boot into another windows install on the same computer  (dual-boot),  then it works fine. Once the problem occurs,  then I've tried ALL of the registry edit/remove devices/let windows re-detect and re-instell drivers,  all these fixes.  None of them accomplish anything,  except sometimes the "fix"  will let me assign a drive letter to the USB drive on a one-time basis,   but that is lost as soon as I remove and re-insert the drive.  I've tried just about all possible combinations of these "fixes."  

The problem remains, and I've checked on other forums,  many users are reporting a similar problem with USB storage devices, cameras, etc.  Sometimes the suggested fixes are working, but there is a fair number of situations where "reformat, reinstall Windows" turns out to be the only fix......   Most of these users don't seem to have the luxury of just rolling the system back to a few weeks or months ago,  so they are losing MANY hours of their lives reinstalling and fixing something that shouldn't be broke in the first place.  

What we need here is quite simple actually:  we need to know exactly what windows does when it sees a USB storage device,  where it keeps or saves information on devices, how it knows that it has seen a particular device before,  and what is going wrong when it decides to "blacklist"  a particular drive.  I've tried removing all the "dos devices",   all sorts of places in the registry where it seems there are references to these Sandisk or Zip or SecureDigital  usb storage devices.  No help yet.  There is some other place where windows is keeping this information,  and so far, Microsoft isn't telling us where it is.  Maybe they don't know,  

I guess we'll see,     John Shamraj
0
 
LVL 1

Expert Comment

by:MHurtares
ID: 16864866
Try removing Service Pack 2.  I have heard these issues only happen with SP2.
0
 

Author Comment

by:jshamrai
ID: 16867334
Removing SP2??!!   That's an interesting idea.  It might work,  but why do we have to throw away all the "improvements" that came with SP2 just to get a stupid usb drive to work??  Why can't we just get a straight answer on what exactly winxp is doing, why and how it chooses to suddenly start blocking access to a particular device??   I say "blocking",  because I'm pretty sure that it's an active process, not a passive "oh, I didn't know it was there"  type of a problem.  And, the drive always works fine until a certain point  in time, when it suddenly becomes "unavailable"  to the higher levels of the windows interface, even though the disk manager knows it's there, can see it, access it, etc.    

 I've even been able to reformat these drives  using the "problem machine",  with windows xp, going thu the disk managment utility,  and then the computer turns around and tells me that this drive, which it has just finished formatting,  

                                     "is not enabled.  Restart the computer to enable this device."  

(or some similar message)  Of course, restarting any number of times, with the drive inserted or not inserted, has not made any difference.

I guess I could just go back to DOS 6.22 and avoid this problem entirely.   Even if removing sp2 does work, I think that the increased security of SP2  is worth more than solving this nagging problem.  But, it would be nice to just be able to just fix it and move on, and it would be nice if the people at Microsoft would just tell us just what is causing this.   it's probably a pretty simple fix if you know exactly where the information is stored that winxp is using to "remember" that it has seen a particular usb storage device.  We've uncovered a bunch of these places, without much help from MS,  but I think there's still a place or two in the registry that keeps this information, and we haven't found it yet.

thanks for all the suggestions, guys,  I'm still hoping that someday someone will stumble upon the answer, so people can quit wasting their time re-formatting, reinstalling entire systems for one stupid little glitch.    John Shamraj
 
0
 
LVL 93

Expert Comment

by:nobus
ID: 16867877
could you try running sfc /scannow from the run box, to see if that helps?
0
 

Author Comment

by:jshamrai
ID: 16884921
Yes,  I've run the system file checker, multiple times.  It doesn't find any problems, and doesn't have any impact on the usb problem.  THe system is fine in every other way, as far as I can tell.

I'm pretty sure that the system is "remembering"  a particular USB device, or maybe remembering a certain type or class of device, and treating that device differently from other devices.   The fact is,that even when it's acting up badly,  I can insert another usb drive  (different brand name),  and it works fine.  So, this tells me that it's not just USB devices in general that are being mishandled, but certain devices, either identified by that particular device  (as in a serial number or other id number),   or a certain class or type of device, maybe brand name or other identifying characteristic.  

This problem has never caused my to lose function with ALL usb devices, or even ALL usb flash memory drives. Only certain ones.    JOhn SHamraj
0
 
LVL 93

Expert Comment

by:nobus
ID: 16886130
another thing to try : try connecting usb devices thru an usb hub
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 17625542
nobus had the last attempt...waiting for original asker to comment
0
 
LVL 1

Expert Comment

by:MHurtares
ID: 17628736
I found this interesting article that may address the problem:
http://support.microsoft.com/kb/892050/en-us

I have also heard a "powered" hub fixes most of these issues, but not all of them.
0
 
LVL 88

Expert Comment

by:rindi
ID: 17629496
As this seems to work with a certain "image" and not with others, can you try to check the differences in those images?
0
 

Author Comment

by:jshamrai
ID: 17635492
The microsoft hotfix addresses the issue of a "new " device going unrecognized.  My problem was a device that had previously been inserted.  A new device  (usb flash drive)  was usually recocnized, then it would be "unrecognized" the second (and subsequent) times it's inserted.    I can try to find the hotfix and run it,  may help.

The usb powered hub would probably make sense with some devices, though a flash drive takes little power, and the other main device I had problems wtih   (Casio Camera) was in a powered "camera dock",  which supplies its own power, and probably draws no power from the computer.

Comparing the images::::::::    WOW,   what fun.  The "image" that I'm restoring is a compressed copy of the entire boot drive, about 10 gigs of data, appliations, ms windows, etc.  This image was saved a few weeks before the problem started.

If I image the drive now, and then reimage it in 20 minutes,  there will be thousands of changes on the drive, even if I don't do anything other than restart the computer a couple of times.   If I run an application or two,  check my email, check the sports news in those 20 minutes,  there will be hundreds of thousands of differences between the image and the present status of the drive.  This could take the rest of my life, even if I live to be 100.  The windows registry alone will have hundreds of change just from a restart.

Thanks for the suggestions.  For now,  I've been fine with just using the computers after restoring, they've been working fine,  I've installed new apps, uninstalled some, just done whatever I need to do, they're ok,  EXCEPT  that I've turned off windows updates.

I know this is heresy, but with a decent firewall and some common sense, I think that's safe.  One problem is that several employees use the internet, and I'm not sure of their common sense, and dont really want to "lock down" everything to the point where they can't look up useful information.   However, I've decided that it's better to take chances with the internet worms than with Windows Update.  I've had Windows Update  "fry" several machines  (wont boot after update, reproducible problem),  and a few other glitches that seem hard to explain.  Since turning off updates on all machines,  I've had fewer problems (for 9-10 months) than before.  Also, I'm not convinced of the value of these updates.  On most of my machines  (winxp, all sp2,  win2000,sp4)  the size of the Update files on disk is bigger than the original windows installation, and even after Microsoft has plugged hundreds of "holes" in the system,  the hackers and weirdos find another MAJOR  security flaw every week or so.  What a joke!!!!!!!!!!!!!!!!  

So, maybe it's time to close this question,  I'll keep an eye out for similar problems,  I imagine it will come back again someday, since I don't know what caused it.  the bottom line is this:   Somehow, windows is tracking each usb device when it first "sees" it  (which is a good thing, and I know some if the registry areas where this info is kept),  and then recognizes it in the future  (again, good thing),  however this system gets fouled up sometimes, and Microsoft either doesn't know how the "tracking" system actually works  (quite likely),  so they can't help, or they don't want to help, for some reason, which is also possible. More likely, in my opinion,  they just don't know how their op sys works, it has grown so compex and convoluted.  
0

Featured Post

NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many businesses neglect disaster recovery and treat it as an after-thought. I can tell you first hand that data will be lost, hard drives die, servers will be hacked, and careless (or malicious) employees can ruin your data.
Windows Server 2003 introduced persistent Volume Shadow Copies and made 2003 a must-do upgrade.  Since then, it's been a must-implement feature for all servers doing any kind of file sharing.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Suggested Courses
Course of the Month18 days, 23 hours left to enroll

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question