What is preventing connection between Toshiba Tecra S1 with inbuilt WIFIAtheros AR5001X+ and Access Point DWL-7100AP

I recently upgraded the firmware on my D-Link access point, DWL-7100AP, from version 1.0 to version 2.00au, this fixed an issue with the number of MAC's that could be recorded against the AP from 16 to unlimited, however, it now seems to have caused a problem in that any machine using the Atheros AR5001X+ WIFI 802.11a/b/g card cannot get connectivity with the network.  The network is seen but just cannot be connected to.  I have tried updating the Atheros driver 1st with the microsoft approved driver, this did not work , then I downloaded the Atheros driver, yet again this did not work.

I have 16 WIFI notebooks 14 of which use this card, the other 2 use the Intel Pro/Wireless 2915 cards.  Has anyone else experienced this and if so how have they overcome it.  

I have spoken to D-Link but they were not aware of the problem and therefore do not have a fix.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Irwin SantosComputer Integration SpecialistCommented:
Disable your WEP or WPA on your router, just for testing.  Can you connect then with the Atheros Notebook?

If not,

Replace the D-Link router...

with the following


Dlink is not the greatest product...  I've installed 25+ of the above model, and it works like a charm support 500+ WIFI devices.
Try a physical reset of the router, look for a small hole near the antenna, use the tip of a pen and insert it in the hole until all the lights flash, it should take 15-30 seconds.  You'll have to re-enter another password and any other security settings.
adaps1Author Commented:
I have disabled the wep and yes it now works.  Doesn't this reduce my security?
OWASP: Forgery and Phishing

Learn the techniques to avoid forgery and phishing attacks and the types of attacks an application or network may face.

yes it means people can boost your signal. I have a neighbor who has his router like that.  Have you tried a physical reset?
any removal of a security measure will, undoubtedly, reduce your security but you are using MAC address filtering as well.  this is crackable if you can clone existing MAC's.  have you tried WPA instead of WEP?  maybe an ASCII or HEX code in place of what you already had.  sounds like a stretch to me, but stranger things have worked in the past.

good luck,


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
that's a good idea... just try 64-bit wep instead of 128-bit.
Irwin SantosComputer Integration SpecialistCommented:
It's good that the d-link is working in some fashion.. I'm good with the 64-bit WEP....I find that that too is a common solution.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.