• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 423
  • Last Modified:

Identical NICs, One Unknown to System

Greetings,

I recently installed a second NIC in my file server (Gentoo Linux 2.6.15-r1).  The first network card works fine and comes up in lspci accurately. (Ethernet controller: D-Link System Inc (Gigabit Ethernet Adapter (rev 11))  The second identical card (DGE-530T) comes up in lspci as D-Link System Inc Unknown Device 4b01 (rev 11).  

I'm pretty sure that this is just a resource conflict, but I don't know how to go about fixing it in Gentoo. (bit of a newbie.)   Any help will be appreciated.

Thanks,
0
darksinclair
Asked:
darksinclair
  • 4
  • 3
  • 2
  • +2
1 Solution
 
ppfoongCommented:

The 1st network card should known as eth0 and 2nd known as eth1.

Check if it is recognised by Linux with this command:

ifconfig -a

If you can see both eth0 and eth1 listed, then they are both detected. You just need to configure the 2nd network card for IP address, etc.

To configure, use this command in Gentoo:

net-setup eth1

0
 
NopiusCommented:
Create another alias with the same value as eth0 in /etc/modules.conf:

alias eth0 ...
alias eth1 ...

reboot, then look for resource conflict (if any):
dmesg
0
 
darksinclairAuthor Commented:
Greets,

There is no eth1.  I would love to be able to do net-setup on eth1, however the device is not there.  It doesn't recognize what the card is (even though it recognizes what the other card is.)

As well, this is not a problem with the card.  If I take out the first card, then the second card will show up and become eth0.  it's fine detecting it.

It's a problem having two of them, I'm sure it's a resource conflict, however any other suggestions I am willing to try.

So to answer your question, ifconfig -a does not show eth1.  only eth0 and lo.

Regards,
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
darksinclairAuthor Commented:
Nopius, i did read that somewhere and tried myself, however on reboot it deleted it from modules.conf.

Do u know what exact commands I would give it?  I think the ones I used were specific to the NE2000 driver that I was following from an online documentation,

Regard,s
0
 
NopiusCommented:
If you have Linux kernel sources you may find all parameters for your driver module in

Documentation/networking/dl2k.txt

below kernel sources directory

It's from there:
'4. cp dl2k.ko /lib/modules/`uname -r`/kernel/drivers/net
5. Add the following line to /etc/modprobe.conf:
        alias eth0 dl2k
6. Run "netconfig" or "netconf" to create configuration script ifcfg-eth0
   located at /etc/sysconfig/network-scripts or create it manually.
   [see - Configuration Script Sample]
7. Driver will automatically load and configure at next boot time.'


Here is a list of NICs supported by this driver (also from that document):

D-Link DGE-550T Gigabit Ethernet Adapter.
D-Link DGE-550SX Gigabit Ethernet Adapter.
D-Link DL2000-based Gigabit Ethernet Adapter.

Also there are examples for 2 cards:
===============================================================
   example: insmod dl2k.o media=100mbps_hd
   or       insmod dl2k.o media=3
   or       insmod dl2k.o media=3,2     ; for 2 cards
  ===============================================================

  Please reference the list of the command line parameters supported by
  the Linux device driver below.

  The insmod command only loads the driver and gives it a name of the form
  eth0, eth1, etc. To bring the NIC into an operational state,
  it is necessary to issue the following command:

  ifconfig eth0 up

  Finally, to bind the driver to the active protocol (e.g., TCP/IP with
  Linux), enter the following command:

  ifup eth0




0
 
NopiusCommented:
oops, for 2.6.x kernels, edit /etc/modprobe.conf, not /etc/modules.conf
...

  2. Locate the boot module configuration file, most commonly modprobe.conf
     or modules.conf (for 2.4) in the /etc directory. Add the following lines:

     alias ethx dl2k
     options dl2k <optional parameters>

     where ethx will be eth0 if the NIC is the only ethernet adapter, eth1 if
     one other ethernet adapter is installed, etc.
0
 
NopiusCommented:
If the card exactly the same and you have correct driver.
Try this:
 ifconfig eth1 up
after adding 'alias eth1'
and then look for ifconfig -a
0
 
slow1000Commented:
I once got a 2nd card working by changing the pci slot.  I doubt if this would work on a newer mobo which should handle resource conflicts more gracefully, but it's worth trying.
0
 
Dragon_KromeCommented:
lspci "recognizes" devices by their IDs, so my guess is that if the second card is not recognized as the first one, then it's a different model.

If you look here, http://pci-ids.ucw.cz/iii/?i=1186  at the 4b01 entry, that's your board and it seems to be a new entry in the pci ids list (the one lspci uses to map PCI device IDs to vendor:product names).

Here is a driver for that model (I haven't tested it, since i don't have such card)

http://www.dlink.com/products/support.asp?pid=284&sec=0 
0
 
darksinclairAuthor Commented:
Thanks so much Dragon_Krome,

I didn't think that they would be recognized different and was trying to use the drivers from the first card (which is the exact same make and model but apparently a different firmware -- even though revision number is the same...).  After reviewing your list, they are identified differently and the downloaded drivers seem to work.

Thanks for the help all,

Regards,
0
 
Dragon_KromeCommented:
Glad I could be of assistance.
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

  • 4
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now