Public Folder Permissions problems after restore from tape - SBS 2000


I believe I have a bit of a "chicken and the egg" problem after rebuilding the SBS server, creating an NEW AD and restoring the exchange databases from backup (using ntbackup).  
For several long-winded reasons I decided to recreate the AD information by manually creating new user and computer accounts. I used the same OU names and domain information to make it work.
I got both databases to mount (priv and Pub) without incident and was sucessfull in remapping the mailboxes to new user accounts. So far so good.

My problem is specificaly with the Public folders.  I sensed we were having permision problems and after looking around it seems I was right ..
Here is what I got...

If I look at the public folder properties in Outlook I am not given the options to look at the security tab so I  can only look at the permissions in the SUMMARY tab which shows the folder is owned by an unresolved SID. I presume it to be the SID from the Admin account of the old AD.
I went to the ESM to try view/edit permissions there but I can NOT open any public folder properties.  When I try I get an LDAP error that looks like this:

There is no such object on the server

Facility: LDAP Provider
ID no: 800072030
Exchange System Manager

Additional symptoms  -  User can read and write to the public folders but can't create new ones nor can they CC email to them anymore.  
Can someone please recomend a tool I could use to assume administrative ownership over the public folders again?

thanks

jeff





 
jc07874Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ksharma4Commented:
Use Exchange System Manager to add a replica of the top-level folder (only). After you do so, you can propagate the folder rights successfully to all of the subfolders.

You can run pfdavadmin utility to reset the PF Permissions.

Thanks
Kunal
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jc07874Author Commented:
OK .. I used the PFDadmin tool to get 1/2 way there.  Now I can move the folders around and has solved my permissions problem.
I can move the folders around to the
But I still have the LDAP error. So I think I still need to do the replication of the top level folder.  However I have never done this and not sure how. I tried to chang he properties of the TOp level folder "PUBLIC FOLDERS" but the Pfadmin tool say  you can't change permissions on this folder.  I must be missing something.

COuld you point me to or walk me thru the process of how to replicate the top level folder as I have seen noted in several places. Also I am not sure which top level folder the docs refer too.

Much Thanks  - I think I am seeing light at the end of the tunnel.

JC
 

0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

jc07874Author Commented:

I guess I am saying is I am not clear how or why to set up replication if I only have one exchange server.

 
0
rakeshmiglaniCommented:
are you able to access the properties of the public folders now via Outlook.

do you get the LDAP error when you check the properties of the new folders or just all of the old folders.
0
jc07874Author Commented:
I was finaly able to do what Kunal suggested.
I was then able to see permissions and remove the unresolved cids from the prevoious defunct domain.
After doing that I was able to mail enable all the folders and set opject correctly.

Thanks.

 
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.