Issues runnign scripts under XP with ActivePerl 5.6

I've installed ActivePerl 5.6 on Windows XP Pro SP1, and it sort of works.  If I run a script from the command prompt, then the script doesn't pick up the arguments passed from the command line, however, if I preface the script with "perl", then it runs (well, until it hits another script called from this script...):

I created a simple script to test, and found that the arguments simply don't get passed:

print 'Hello';
print $ARGV[0];

C:\GKN>test.pl A
Hello
C:\GKN>perl test.pl A
HelloA
C:\GKN>

The package installed without error. My PATH environment variable is:

C:\Perl\bin\;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\WINNT\system32\nls;C:\WINNT\system32\nls\ENGLISH;C:\Program Files\QuickTime\QTSystem\

and PATHEXT is:

.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.PL

Any ideas as to what is going on here? It's driving me nuts! :-)

LVL 30
Duncan MeyersAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

FishMongerCommented:
You need to adjust the .pl file association and "tell it" to "look for" the arguments.

Tools > Folder Options > File Types
Locate the .PL extention and modify it this:

"C:\Perl\bin\perl.exe" "%1" %*
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
FishMongerCommented:
It's possible that you don't have a .PL extension configured in the file types.  If that's the case, then clickon the "New" tab in the 'File Types' dialog box and create a file association giving the line I posted as the application to use for the 'Open' action .
0
Duncan MeyersAuthor Commented:
>"C:\Perl\bin\perl.exe" "%1" %*

Bingo! That was it. The .PL file extension was associated, but instead of the Advanced button I'd normally expect to see under Tools>Folder Options>File Types, I had a Restore button in its place. I clicked on it, then the Advanced button returned and I could then confirm that the Application Used... string was correctly set.

Thanks! You're my hero!

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Perl

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.