Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Mount  Logical drive in Linux

Posted on 2006-04-13
5
Medium Priority
?
1,064 Views
Last Modified: 2008-03-03
Dear Friends

when I try to mount my windows drive D in my Linux, I get the error message bellow:

mount: wrong fs type, bad option, bad superblock on /dev/hda2,
       or too many mounted file systems
       (aren't you trying to mount an extended partition,
       instead of some logical partition inside?)

my drive D is logical drive, how can I mount it in linux and also, if I want it to be mounted at boot automaticallu, what should I do?

thanks alot for your help
0
Comment
Question by:Naserpour
5 Comments
 
LVL 50

Accepted Solution

by:
dbrunton earned 2000 total points
ID: 16443712
I think you have a logical drive inside an extended partition.

You are trying to mount the extended partition /hda2 instead of the logical drive inside the partition.

Now read the following link

http://whoiam55.at.preempted.net/?p=18

According to the article you may have to use /dev/hda5 for the partition because the first four partitions are used by Linux as the primary partitions and /hda5 up are used to the partitions within the partitions, in this case your logical drive.

This will show you how to mount the drive at boot time

http://www.tprthai.net/fslinux.htm
0
 
LVL 50

Expert Comment

by:dbrunton
ID: 16443762
And see here

http://www.linux.org/docs/ldp/howto/Large-Disk-HOWTO-13.html

This gives an example of /dev/hda3 has partitions within it that are labelled /dev/hda5 and /dev/hda6

0
 
LVL 3

Expert Comment

by:RiDo78
ID: 16444607
try mounting /dev/hda5

The first 4 partitions are considered to be primary or extended. Partition 5 and above are logical drives. So the first logical-disk is /dev/hda5.
0
 
LVL 1

Expert Comment

by:gsrecluse
ID: 16448757
Try fdisk /dev/hda
p
(see which partitions exist and what type they are, look for the NTFS one)
q (quit)

mkdir /mnt/hdaX
mount -t ntfs /dev/hdaX /mnt/hdaX     (Where X is the NT partition number)

If you don't find an NTFS partition on /dev/hda, are you sure your D drive isn't on a second physical hd? If so, look at fdisk /dev/hdb.
Obviously, if you are using SCSI or SATA hard drives, then look at /dev/sda or /dev/sdb

Hope this helps.
0
 
LVL 3

Expert Comment

by:sundeepgopal
ID: 16448785
add this to your /etc/fstab
     /dev/sda1 /mnt/hda1 auto user,noauto 0 0

  Make the directory for the usbdrive to mount on:
    mkdir /mnt/hda1

Mount all the devices in the /etc/fstab:
mount /mnt/hda1

Done.
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In a recent article here at Experts Exchange (http://www.experts-exchange.com/articles/18880/PaperPort-14-in-Windows-10-A-First-Look.html), I discussed my nine-month sandbox testing of the Windows 10 Technical Preview, specifically with respect to r…
Windows 10 is here and for most admins this means frustration and challenges getting that first working Windows 10 image. As in my previous sysprep articles, I've put together a simple help guide to get you through this process. The aim is to achiev…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question