?
Solved

I cannot access the shared directories on my computer over the network even though it is displayed in the workgroup

Posted on 2006-04-13
9
Medium Priority
?
178 Views
Last Modified: 2013-11-16
Hi

My DELL laptop is having WIN XP PRO and the LAN is connected via a workgroup.

From my computer I can access other computers on the network and others can see my computer
displayed in the list of computers in the workgroup. However they cannot open the shared
directories on my harddisk. I have given full control on a directory for copying and modifying
files on my hard disk but I always get the same message

"Computer not accessible. You do not have the permission to use this network source.
Network path not found."

We do not have server and we have a very simple LAN connected via switches.

We access internet via a gateway.  There is no special password to access. I take care of installing the operating
systems and configure the systems for network.  So we do not have a network administrator either.

Can somebody please give me a solution.

The majority of computers on the network have WIN XP and a couple are on WIN 2000.


thanks


 
0
Comment
Question by:fluidyn
7 Comments
 
LVL 32

Expert Comment

by:masnrock
ID: 16444101
You might need to create accounts on YOUR computer so that people on other machines can authenticate when trying to access your shares. You'll want want to use the same user name and password for the accounts that people use on the ohter machines.

Your only other choice might be to utilize Simple File Sharing, which I think uses the Guest account on your machine if it's enabled:
http://support.microsoft.com/default.aspx?scid=kb;en-us;304040
0
 

Author Comment

by:fluidyn
ID: 16444255

Thanks

I enabled simple file sharing  and also the guest account, but it does not work.

I created a the same user name and password as another computer on the network, but it did not work either.

I am still unable to access the shared directory from another computer

0
 

Author Comment

by:fluidyn
ID: 16444257

Sorry I forgot to add one more detail. It is a Toshiba laptop.

0
What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

 
LVL 1

Expert Comment

by:nickhills
ID: 16444314
try turning simple filesharing off!!

simple filesharing is only of use if all you machines are XP, in my experience SFS just complicates matters.

turn off the guest account, disable SFS, and you should be prompted fro a username and password to access the folder.

just as a side note, your user account MUST have a password, if your laptop automaticly logs on, or you do not need a password to log in, you need to create a password first.

regards,
Nick
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 16444399
--------------------
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, PC-cillin (yes, some AV products have built-in firewall), VPN client (Raptor Mobile, Cisco VPN), et al.
-------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
-------------
Turn on "Simple file sharing" on the XP (Pro only) machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
For complete explanation, see here:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;304040

--------------------------
There's a different Guest account setting that controls networked access to XP's shared disks and folders when simple file sharing is enabled.

To enable networked access, enter this line at a command prompt:

   net user guest /active:yes

To disable networked access, enter this line at a command prompt:

   net user guest /active:no

For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines

http://www.wown.com/j_helmig/wxpwin9x.htm
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP

   Click Start, click Control Panel
   Click Network Connections.
   Right-click "Local Area Connection", and then click "Properties".
   Click on (highlight) "Internet Protocol (TCP/IP)", and then click "Properties" button
   Click the General tab, and then click "Advanced" button , bottom right.
   Click the WINS tab.
   Under "NetBIOS setting" section, click Enable NetBIOS over TCP/IP, and then click OK two times, the "close".
     ( ) Default
     (*) Enable NetBios
     ( ) Disable NetBios

   Reboot the computer.


Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.
--------------------------

Windows XP (at least PRO) defaults a setting in Local Security Settings to something very unhelpful.
If all this does not solve your problem, check Local Security Settings, Network access: Sharing and security model for local accounts.  This may be set to (default) Guest only - local users authenticate as Guest.  Change this to Classic: local users authenticate as themselves. At this point you need same username/password on both machines. Log into 2nd PC with that username. Passwords cannot be blank.

Start/run: gpedit.msc
   Local Computer Policy
     Computer Configuration
      +Windows Settings
         +Security Settings
           +Local Policies
             +Security Options
         
          Double-click on Network Access:Sharing and Security Model for local accounts--
                 --change to "Classic - local users authenticate as themselves"

FOR HOME USERS ONLY WHEN ALL ELSE FAILS:
Look for and set these properties as shown also

Network access: Allow anonymous SID/Name translation     ==> Enabled
Network access: Do not allow anonymous enumeration of SAM accounts     ==> Disabled
Network access: Do not allow anonymous enumeration of SAM accounts and shares          ==> Disabled
Network access: Let Everyone permissions apply to anonymous users     ==>      Enabled

Now you may disable the Guest account as recommended for improved security (for the XP box).  Without this set properly nothing will work for XP!

--------------------------
There's a different Guest account setting that controls networked access to XP's shared disks and folders when simple file sharing is enabled.

To enable networked access, enter this line at a command prompt:

   net user guest /active:yes

To disable networked access, enter this line at a command prompt:

   net user guest /active:no


=======================
REFERENCES:

http://www.onecomputerguy.com/networking/xp_network.htm
http://www.annoyances.org/exec/show/article04-108
http://support.microsoft.com/default.aspx?scid=kb;en-us;304040
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
http://support.microsoft.com/default.aspx?scid=kb;en-us;314366
http://support.microsoft.com/default.aspx?scid=kb;en-us;315267
http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
http://www.michna.com/kb/WxNetwork.htm
0
 

Author Comment

by:fluidyn
ID: 16445290

Thank you for your solution.

On the Toshiba laptop, by disabling SFS and Guest account, I am now able to access the shared files.

However on the Dell laptop I did not find the option of SFS in the folder options under Tool menu as
mentioned before and guest account is disabled.  But I am unable to access the shared files.

However I have Macfee Anti virus installed on this system. Perhaps this could create the problems.

Iwill try your above mentioned solution and let you know if it works

thanks*

0
 
LVL 1

Expert Comment

by:thajuonline
ID: 16446455
log in as administrator
select start run and type this command with out quotes "SC sdset SharedAccess D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU) "

restart the system

this will work
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
This article will show you step-by-step instructions to build your own NTP CentOS server.  The network diagram shows the best practice to setup the NTP server farm for redundancy.  This article also serves as your NTP server documentation.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question