?
Solved

SBS 2003 EXCHANGE UNABLE TO SEND MAIL USING SMTP

Posted on 2006-04-13
11
Medium Priority
?
1,908 Views
Last Modified: 2012-05-05
hI,

This problem is very urgent and difficult.

We set up a sbs 2003 server, with a new domain. The server is alone as DC. Everything is working correctly except the mailing. Internally we can send and receive mails. Exchange is set up to receive internet mail with pop3 and to send them via the smtp server of the internet provider. When sending from a client computer(in the domain) we receive an answer from the local system administrator saying that the mail address does not exist. This mail address is working correctly on a workstation(not in the domain), or with outlook express.

We tried everything suggested in experts-exchange site (instants questions). But nothing works.

Help please,


regards,

Marcheblanc
0
Comment
Question by:Marcheblanc
9 Comments
 
LVL 6

Expert Comment

by:Azhrei1
ID: 16445932
is the server running a DNS service? Is that configured correctly?
0
 
LVL 5

Expert Comment

by:The_IT_Garage
ID: 16445943
Do you have the POP3 domain name in the defaul recipient policy?
0
 
LVL 10

Expert Comment

by:kgreeneit
ID: 16446885
hi, firstly from the clients open a command prompt and type:  telnet servername 25 (where servername is the name of your server)

if you don't get an error and the command prompt connects to the server, then your half way there.
If you DO get an error, then there is some firewall software on the clients stopping smtp access on port 25, try disabling all firewall software  - including the windows firewall, and try the command again.

If you could connect to the server via the command prompt, then your problem is with DNS. In Exchange System Manager, go to the properties of the SMTP connector and check how the connector is configured to use DNS. If 'FORWARD ALL MAIL THROUGH THIS CONNECTOR TO THE FOLLOWING SMART HOSTS' is enabled, you must have the DNS name/IP address of your ISP's server here, alternatively select, 'USE DNS TO ROUTE TO EACH ADDRESS SPACE ON THIS CONNECTOR'  - this is the preferred way to use DNS on your exchange server.

If the above option fails, then you could go into the 'Default SMTP Virtual Server' in servers\protocols\smtp and you could add dns entries directly into the SMTP server. You gain access to here by clicking on the 'Delivery' tab, then click on the advanced button, from here click on the 'configure' button. Then click on 'Add' and input the IP address of your ISP's DNS server. Try this as a last resort as it isn't really an ideal way to run your exchange server.

Hope this helps.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:Marcheblanc
ID: 16455966
Hi everyone,
Thank you for your answers.

Yes the DNS is configured correctly. I receive mail from outside via the pop3 connector. Internally everything is fine. I also can connect from a client to the internal server with telnet on port 25.
'FORWARD ALL MAIL THROUGH THIS CONNECTOR TO THE FOLLOWING SMART HOSTS'  is also enabled. I can now send mail outside from a local account.
The problem i have now is that the sender mail address is not the right mail address.
sbs is configured like this:
- local domain name: xyz.local
- internet domaine name : xyz.com  (i don't manage the mx record)
- username : account1
- local e-mail address : account1@xyz.local
- internet e-mail address : account1@xyz.com (configured by SBS)
when i send an email the sender is account1@xyz.com and i'd like to send as name@xyz.com
when i change the e-mail address in user properties from account1@xyz.com to name@xyz.com. everything is changed back to account1@xyz.com within a few minutes.
What is the right configuration for that ?

I'm sorry if it's a bit complicated to explain. I'm new to exchange.

Thanks a lot for your help.


I
0
 
LVL 4

Expert Comment

by:mattridings
ID: 16456170
When in the users account you need to add a new smtp address (not get rid of the other one, or try and edit it), then highlight the new address by clicking on it once, and click on the "Set as Primary" button.  Your new address should now be in bold whereas the other addresses are not.  When that account sends email to the outside now the bold address is what the recipient will see.

If you are creating an email address standard that will apply across the entire organization (i.e. firstname.lastname@domain.com or firstinitial lastname@domain.com, etc. then you can modify the entire organizations email addresses at once by using recipient policies.  If this is the case post back and we can address that.

Matt Ridings
MSR Consulting
0
 

Author Comment

by:Marcheblanc
ID: 16456263
I've done what you said : in the user account i ve added a new smtp address then i set it as primary. it was in bold and not the other.
but after a few minutes it came back to the old configuration. could it be an sbs2003 specific configuration ?

Thanks
0
 
LVL 4

Accepted Solution

by:
mattridings earned 1500 total points
ID: 16457144
It's possible I suppose that your recipient policy is overwriting it but it's a bit unusual for it to happen that way so quickly without you having modified them.

Anyway, on that same "email addresses" screen where you added the new smtp address, this time make sure that the "Automatically update email addresses based on recipient policy" checkbox is unchecked.

That should tell us whether or not recipient policies are interfering with your change.

Matt Ridings
MSR Consulting
0
 

Author Comment

by:Marcheblanc
ID: 16457810
You are right i add to uncheck "Automatically update email addresses based on recipient policy" to make it stay.
There is another point i had to do for what i wanted. I had to go in global parameters, internet mail ..., right click on by default, and in advanced parameters tab i had to uncheck the last param to send, not as the username but as the user email name.

Thanks a lot for your help
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16459375
You shouldn't have had to go to that extent to make this work right... because you will undoubtedly have issues later on by making these manual adjustments.

I'm not sure if you realize that when you run the Add-User wizard, you can specify an email address that's different from the username.  This would be the place to make this happen to begin with.

Jeff
TechSoEasy
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction At 19:33 (UST) on Tuesday 21st September the long awaited email arrived with the subject title of “ANNOUNCING THE AVAILABILITY OF WINDOWS SBS 7 PREVIEW”.  It was time to drop whatever I was doing and dedicate as much bandwidth as possi…
If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Loops Section Overview

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question