adding a vpn connection to a cisco pix

Posted on 2006-04-13
Last Modified: 2013-11-16
i have a pix with a current client and vpn group defined.  i want to add either a group or a client entry but not sure how.  here is my current config

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password  encrypted
passwd encrypted
hostname pixfirewall
domain-name lu
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list 100 permit ip
access-list 200 permit ip
pager lines 24
logging on
logging console debugging
logging monitor debugging
logging buffered debugging
mtu outside 1500
mtu inside 1500
ip address outside 66.xx.xx.xx 255.xx.xx.xx
ip address inside 192.168.x.x
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0 0
route outside 66.xx.xx.xx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set esp-3des-md5 esp-3des esp-md5-hmac
telnet inside
telnet timeout 5
ssh 208.xx.xx.xx outside
ssh 208.xx.xx.xx outside
ssh inside
ssh timeout 5
console timeout 0
dhcpd address inside
dhcpd dns
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username admin password eY/fQXw7Ure8Qrz7 encrypted privilege 15
vpnclient server 208.60.xx.xx
vpnclient mode client-mode
vpnclient vpngroup vpnLU password ********
vpnclient username vpntrans password ********
vpnclient enable
terminal width 80
: end
Question by:joewy1
    LVL 9

    Expert Comment

    You said you want to add a group or a client entry? Do you mean you want to have this PIX terminate a VPN Client connection? Because right now is just acting as an EZVPN client. Please elaborate if I misunderstood you.

    Author Comment

    here is the scoop.  this pix was set up by a third party vendor.  i need access to this network without disturbing any previous connections.  noone on site knows any of the existing vpn passwords, so i just wanted to create an additional client or group so i can also connect.

    LVL 9

    Accepted Solution

    Ok, here is the thing. First, even if somebody knows the existing VPN password, you still won't be able to access the PIX network over VPN since it is setup as EZVPN in client mode. Meaning, it is acting as a VPN client and not a server. All it can do is to connect to a remote server, it wont accept connection.

    Secondly, in EZVPN (regardless of mode use) it will only allow you to have one set of vpngroup and username. If you try to add one, it will just overwrite the previous one.

    If you want to be able to access this network, then you would have to reconfigure the PIX to act as a VPN termination point and not EZVPN.

    Featured Post

    Better Security Awareness With Threat Intelligence

    See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

    Join & Write a Comment

    Cisco Pix/ASA hairpinning The term, hairpinning, comes from the fact that the traffic comes from one source into a router or similar device, makes a U-turn, and goes back the same way it came. Visualize this and you will see something that looks …
    Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
    Need more eyes on your posted question? Go ahead and follow the quick steps in this video to learn how to Request Attention to your question. *Log into your Experts Exchange account *Find the question you want to Request Attention for *Go to the e…
    Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…

    732 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    25 Experts available now in Live!

    Get 1:1 Help Now