The size of the request exceeds the limit allowed by the server

I'm sending a large xml request to a Project Server 2003 web service (PDS), but I am getting the following error:

System.Web.Services.Protocols.SoapHeaderException: The size of the request exceeds the limit allowed by the server.
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCal
l)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at ProjectEMTS.PDSService.PDS.SoapXMLRequest(String sCookie, String sXML) in C:\Documents and Settings\clementc\My Documents\Visual Studio Projects\ProjectEM
TS\ProjectEMTS\Web References\PDSService\Reference.cs:line 39
   at ProjectEMTS.ProjectData.SendXMLRequest(StringWriter sWriter) in c:\documents and settings\clementc\my documents\visual studio projects\projectemts\project
emts\projectdata.cs:line 135

I have already maximized HKEY_LOCAL_MACHINE / SOFTWARE / Microsoft / MSSOAP / 30 / SOAPISAP / MaxPostSize, but still getting the error. I'm sure the size of the request is not even close to the value I set in the registry.

Any ideas of what else could be causing this error?

Thanks

Chris
ChrisClementAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jjardineCommented:
I believe your problem is set in the web.config of the webservice if it has one.   Try looking at this article to see if this helps.

Here is an article talking about the problem and how to solve it. The quickest thing to try is to update the webconfig to use a larger maxRequestLength value.   See the article for more detail on this.
 http://www.motobit.com/help/asp-upload/pa84.htm  

ChrisClementAuthor Commented:
Thanks, but we figured the problem out right after I posted this.  We changed the registry setting and restarted IIS, but for whatever reason the change still did not take affect until we rebooted the server.  What a pain.

Thanks for the response tho.
GranModCommented:
Closed, 500 points refunded.
GranMod
The Experts Exchange
Community Support Moderator of all Ages

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.