dns warnings about self reference

The DNS server encountered a packet addressed to itself on IP address 192.168.1.254. The packet is for the DNS name "m.2mdn.net.". The packet will be discarded. This condition usually indicates a configuration error.
 
Check the following areas for possible self-send configuration errors:
  1) Forwarders list. (DNS servers should not forward to themselves).
  2) Master lists of secondary zones.
  3) Notify lists of primary zones.
  4) Delegations of subzones.  Must not contain NS record for this DNS server unless subzone is also on this server.
  5) Root hints.
 
Example of self-delegation:
  -> This DNS server dns1.example.microsoft.com is the primary for the zone example.microsoft.com.
  -> The example.microsoft.com zone contains a delegation of bar.example.microsoft.com to dns1.example.microsoft.com,
  (bar.example.microsoft.com NS dns1.example.microsoft.com)
  -> BUT the bar.example.microsoft.com zone is NOT on this server.
 
Note, you should make this delegation check (with nslookup or DNS manager) both on this DNS server and on the server(s) you delegated the subzone to. It is possible that the delegation was done correctly, but that the primary DNS for the subzone, has any incorrect NS record pointing back at this server. If this incorrect NS record is cached at this server, then the self-send could result.  If found, the subzone DNS server admin should remove the offending NS record.
 
You can use the DNS server debug logging facility to track down the cause of this problem.

For more information, see Help and Support Center at


I don't understand this.

I have only one DNS server, the sbs server which is the only server I have.  I constantly get this warning.  I have checked the dns, and I don't see that there is anything wrong with the way it is setup.  Besides which sbs setup the dns in the first place, how could the default setup be wrong.  Microsoft couldn't have figured that a small business would have more that one server, could they.  I mean that is what it means to be small.


this is my zone list for my dc

Name      Type      Data
_msdcs            
_sites            
_tcp            
_udp            
DomainDnsZones            
ForestDnsZones            
(same as parent folder)      Start of Authority (SOA)      [422], exchange.omelet.local., hostmaster.
(same as parent folder)      Name Server (NS)      exchange.omelet.local.
(same as parent folder)      Host (A)      192.168.1.254
companyweb      Alias (CNAME)      exchange.omelet.local.
EXCHANGE      Host (A)      192.168.1.254
HP-LAPTOP      Host (A)      192.168.1.100
hplaptop      Host (A)      192.168.1.39
lap250      Host (A)      192.168.1.44
office-1      Host (A)      192.168.1.22
office-2      Host (A)      192.168.1.18
office-5      Host (A)      192.168.1.4
server      Host (A)      192.168.1.100
STEVENLAPTOP      Host (A)      192.168.1.5
Tintin      Host (A)      192.168.1.7
workstation-10      Host (A)      192.168.1.34

Is there a problem with the zone setup this way.


Thanks

Jon
toppropsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Do you know what m.2mdn.net is referring to?

Also, can you please post an IPCONFIG /ALL from your server?

Jeff
TechSoEasy

0
toppropsAuthor Commented:
no idea about m.2mdn.net, but there are numerous of these warnings, all with different domain references like this.



Physical Address. . . . . . . . . : 00-14-22-79-7F-44
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.254
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.254
                                    206.13.29.12
                                    192.168.1.1
                                    206.13.30.12
Primary WINS Server . . . . . . . : 192.168.1.254


thanks
jon
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Well, that's a good chunk of your IPCONFIG /ALL but it will help... it would really be better if you could post the entire thing because there are other items which could cause a problem.  You can always substitute domain names for privacy.

Your comment: "I have only one DNS server, the sbs server which is the only server I have" is true, so you need to not have any other DNS servers listed on your network interface card.

So, what you've posted will be a good start.  The ONLY IP address you want for your DNS server is 192.168.1.254.  Remove the others.  Then, rerun the Configure Email and Internet Connection Wizard (CEICW - linked as "Connect to the Internet" in the Internet and Email section of the Server Management Console).

See this for a how-to:  http://sbsurl.com/ceicw

Fulll overview of Networking Configuration on an SBS:  http://sbsurl.com/msicw

Jeff
TechSoEasy
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

toppropsAuthor Commented:
I must have been logged into the server of a client when I captured ipconfig.  those are the wrong address for my server.  but I was having the same problem on that server as well.  I removed the other references to dns on the server and this is the resulting ipconfig all

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : ntserver
   Primary Dns Suffix  . . . . . . . : actioncomputerservice.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : actioncomputerservice.local

Ethernet adapter Server Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet
NIC
   Physical Address. . . . . . . . . : 00-0F-EA-D3-B3-0C
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.50.148
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.50.254
   DNS Servers . . . . . . . . . . . : 192.168.50.148
   Primary WINS Server . . . . . . . : 192.168.50.148

I will also rerun the Configure Email and Internet Connection Wizard (CEICW - linked as "Connect to the Internet" in the Internet and Email section of the Server Management Console).

then check and see if error is gone or not.

thanks

jon
0
toppropsAuthor Commented:
interestingly, my exchange doesn't have the error messages any more, and hasn't for some time.  even before I changed the dns settings.  here is the full ipconfig /all from other server that is having the problem.

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : EXCHANGE
   Primary Dns Suffix  . . . . . . . : omelet.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : Yes
   DNS Suffix Search List. . . . . . : omelet.local

Ethernet adapter Server Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connectio
2
   Physical Address. . . . . . . . . : 00-14-22-79-7F-44
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.1.254
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 192.168.1.254
   Primary WINS Server . . . . . . . : 192.168.1.254

I did change the dns settings.  but am leary of rerunning internet connection wizzard, because so many people are depending on rpc, and active sync for getting their emails.  I don't want to inadvertently stop their service.

0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Um... wait a minute... you're running Exchange on a separate server?  Not only is this not supported with SBS, but you started out the question by stating that the SBS is the only server you have.  

Can you clarify this?  WHat is the IP LATA of your network?  Is it 192.168.1.x or is it 192.168.50.x???  

When you run the CEICW you have the option to exclude any part of it... and because you have folks using RPC and ActiveSync, you just want to be sure that you don't issue a new security certificate... otherwise you do need to run it to have the server accept the changes you made on the NIC and to configure everything else accordingly.

Jeff
TechSoEasy
0
toppropsAuthor Commented:
Yes,  I have sbs test machine at home, and sbs at clients office,  sorry for confusion.

oddly the nic setting where similar at both locations, but had error only at clients office.

thanks

jon
0
toppropsAuthor Commented:
the client server hasn't had error since 4/26/06

I'll keep checking to see if error returns.

thanks

jon
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
That didn't really clarify anything... can you please be specific?  Was this original question about your test server or the client server?

Jeff
TechSoEasy
0
toppropsAuthor Commented:
I had the problem on both servers.  but it apparantly went away on home server.  it seems to have stopped in early march.  not sure why.

but the problem is continuing on the client server.

it is currently continuing on client server last error was 5/2/06 7:32 PM.

I did change the nic and rerun the connect to the internet wizard. not changing any choices with the wizard.

thanks

jon
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Okay, so I'll ignore the 192.168.50.x postings and it should all make sense now.

The error seems to be from how your forwarders are configured... so rerunning the CEICW without changing ANY setting won't do a thing.  you at least need to make sure that when it asks for your ISP's DNS IP's on this screen:  http://www.12c4pc.com/sbs2k3/images/router%20ip-5.jpg,

that you have the correct IP's entered that have been provided to you by SBC/at&t:  (206.13.29.12 and 206.13.30.12)

If you get ANY errors in the CEICW those must be resolved.  You can post the error lines from the log to this thread for evaluation.

If you're still having problems, please post the revised IPCONFIG /ALL  to this thread as well.

Jeff
TechSoEasy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.