Post domain user account pw change getting network drive map error

Hi folks,

A little information:

Environment: I am running Windows Server 2003 SP1 AD enabled. I have GPO based logon map drive scripts associated with OUs. XP SP2 client workstations. The script is located on our FSMO DC and the UNC path for the mapping points to FileServer1 (for example).

Issue: I just changed my domain account password (from a complex 9 character to a complex 12 character pw) and now when I log in to the domain, Windows Script Host throws the following error:

******************************************************************************************************************

Script:  \\mydomain.com\SysVol\mydomain.com\Policies\{EAAA5FB0-DDB2-496C-A80E-7590AF2FDC9C}\User\Scripts\Logon\TS-Map-T.vbs
Line:     16
Char:    1
Error:    Logon failure: unknown user name or bad password.

Code:    8007052E
Source: WSHNetwork.MapNetworkDrive

******************************************************************************************************************

It doesn't seem to matter which mechanism I use to change the password. Be it the Options page from the OWA interface, ADUC or Ctrl+Alt+Delete (or even a "force pw change" script) the failed result persists.

I *can* successfully map to the same UNC (from the logon script) using the Windows Map Network Drive function with my new credentials. However, if I run the script locally, I receive the same error minus the DC's script location directory path.

The script does not contain any user/credential information. I'm not sure where to begin.

Thanks in advance,

Greg
mediaogreAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TheCleanerCommented:
What does line 16, char 1 say?  If you can post the script that would be great...or at least portions that would let us know.  Are you setting something in the .vbs script that uses a username/pwd to authenticate?
0
grayeCommented:
I'd be thinking that the Domain Controller with the PDC Emulator role is offline... and that the credentials changes haven't had time to replicate.

I'd be curious to know if the problem "goes away by itself" with a few hours.
0
mediaogreAuthor Commented:
TheCleaner- following is the scipt I'm using (note the lack of domain/acount credentials):

***SNIP***
' TS-Map-T.vbs
' VBScript to map the T: drive for the TST.
' -----------------------------------------------------------------'

Option Explicit
Dim objNetwork
Dim strDriveLetter, strRemotePath

strDriveLetter = "T:"
strRemotePath = "\\FS1\IST"

' Purpose of the script to create a network object. (objNetwork)
' Then to apply the MapNetworkDrive method. Result X: drive

Set objNetwork = WScript.CreateObject("WScript.Network")
objNetwork.MapNetworkDrive strDriveLetter, strRemotePath

WScript.Quit
***SNIP***

graye- *Sheesh* that's a good and scary thought. I have verified that the FSMO and subsequently the PDC emulator is online. Also, I forced a manual password change from ADUC on said emulator. :-{  I too was hoping that the issue would go the way of the X-file and "correct* itself as things trimmed out. However, I changed my passwork yesterday at around 10:00 AM.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

TheCleanerCommented:
script looks fine.

what about this...try doing a net use command (cmd prompt)

is T listed already?

What about trying something like net use T: /del

then run the script again.  It could just be that the old drive mapping was caching old credentials.
0
mediaogreAuthor Commented:
Hmm. net use yields only my Home Folder.  The delete usage outputs, "The network connection could not be found". You got me thinking though...(Thanks!- That's what we're doing here right?) I UNCd to the share associated with drive mapping and received a login dialog for that file server. However, when I UNC to other shares (on the same file server) to which I *don't* map drives, I do *not* receive a login dialog.  Thoughts?
0
TheCleanerCommented:
check the share permissions on the share you are mapping and the NTFS perms.  Make sure you didn't get removed from it somehow.

If you go to \\servername and then just try to open the share does it prompt you for username/pwd?
0
mediaogreAuthor Commented:
TheCleaner- Perms are Ok. I do receive a login prompt.
0
TheCleanerCommented:
but other shares on the same server work just fine?  That's strange.

Is your home folder that's mapped going to the same file server too?

If so I would try this:

net use driveletter: /del

for all drives mapped

also net use path /del

for anything showing in a net use that isn't associated to a drive letter.

Then do a gpupdate /force on your PC and restart.


I'd also try going to a different computer and testing.
0
mediaogreAuthor Commented:
I thought the different-shares-on-same-server inconsistent behavior was weird too.

Home Folder lives on a different file server. However, I have that configured through AD account properties and not via logon script in a GPO.

I'll try your net use and force policy update suggestions and post the results.
0
mediaogreAuthor Commented:
Ding-ding-ding. I logged in from another machine and... no error. (BTW- I tried your other suggestions to no avail) Logging in via console or TS/RDP doesn't make a difference; it works either way. FWIW- I tried with success on three separate machines.

So, getting closer. Any idea why my personal machine would be the culprit?
0
TheCleanerCommented:
only thing I can think of is that something isn't communicating right.  check the system log for errors connecting to the domain, etc.

If that isn't the deal, then you may need to delete your local profile and start with a new one.  I can walk you through that if that is the case.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.