event id 7022 The Kerberos Key Distribution Center service hung on starting.

After getting event id 7022 in the event viewer, I checked to see if the Kerberos service was starting.  It was, however, this error message on every restart is annoying.  Does anyone know where in the registry to change the time that a service must start before a message will be logged in the event viewer?
LVL 2
bleujaegelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TheCleanerCommented:
DISCLAIMER:  I haven't tried this but it sounds logical

you could in essence, make the KDC service dependent on the server service...that may take care of it.

from a command prompt (assuming you have the 2003 resource kit installed)

sc config kdc depend= server


you may check this KB article too:  http://support.microsoft.com/kb/883268/en-us
0
Netman66Commented:
I wouldn't change any default behaviour for KDC - this could be a recipe for disaster.

Sometimes service startup is a little delayed depending on what else is running on this server.  It's a harmless annoyance.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

TheCleanerCommented:
while I agree with Netman that I personally wouldn't change it, I'd live with the annoyance, I understand your frustration as well, so I gave a "possibility" although again it could do more harm than good.

You could also try changing the registry START value in HKLM/system/currentcontrolset/services/KDC to a different value.  I'm not certain on the value to use though.  I don't know if the higher the number the longer the wait or what.  You can look at other services in there and see what they are set at to help determine it, but again, it could lead to disaster as well.
0
TheCleanerCommented:
Found this:  http://www.jsifaq.com/SUBA/tip0300/rh0324.htm

SORRY DON'T CHANGE THE START value, that would be bad, it's the ErrorControl value you can change.  Change it to 0 and it won't produce any error messages.  However, that doesn't do you much good if it never starts and you don't know it...so that's up to you on the risk.

0
bleujaegelAuthor Commented:
Guess I'll have to live with it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.