Exchange Install Can't see E-Mail Addresses

Ok I finally got Exchange installed on my SBS 2003 server.

Here is my situation:
When I create a mail box for a user, it never populates the e-mail address.
It shows me the alias but not the E-Mail address. If I right click on the user acct and go to
e-mail address, it doesn't have anything in there.

The account that I used to install Exchange has a mail box though.

any suggestions
dakeysAsked:
Who is Participating?
 
Jeffrey Kane - TechSoEasyConnect With a Mentor Principal ConsultantCommented:
You should NOT be manually creating mailboxes... you need to use the ADD-USER WIZARD which will automatically create the mailbox correctly.

Jeff
TechSoEasy
0
 
Pete LongTechnical ConsultantCommented:
Yes send it some mail :) or restart the system attendant service - this is normal behaviour :)
0
 
Pete LongTechnical ConsultantCommented:
0
Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

 
Pete LongTechnical ConsultantCommented:
Also MAke sure you have a recipient policy that has your domain name in it
http://searchexchange.techtarget.com/originalContent/0,289142,sid43_gci1119797,00.html
0
 
dakeysAuthor Commented:
problem ended up being that in the recipient update policy I had the wrong Server. Once I changed it to the correct server name, the e-mail addresses came up
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
This is why you shouldn't be configuring it manually!

Jeff
TechSoEasy
0
All Courses

From novice to tech pro — start learning today.