Outlook Web Access not rendering properly for hosts.

We are having a problem at a customers site with Outlook Web access.  It works when I load the webpage locally on the server, page renders fine, but when we come from any other host, internal or external, it renders all funky. (see examples below)  I didn't see anything out of the ordinary in the logs, and if I keep hitting refresh, it will render a different way with a different error each time.

Is there either an easy fix for this, or an easy way to reset the webserver to its default settings?  I am not hosting any other websites on the server, and need to get this working for outside users.  Is there any reason this would load on IE on the server but no where else?

 http://members.arstechnica.com/x/seedless/OWA.jpg

http://members.arstechnica.com/x/seedless/OWA2.jpg
LVL 1
veruscorpAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
I can tell from the screenshots, but it would help if you posted the Exchange version in your question.

If it works on the server, then it looks like classic authentication issues. If it wasn't working anywhere, then I would suspect application.

Check the authentication of the Exchange virtual directories in IIS Manager:

/exchange - basic and integrated ONLY
/exchweb - anonymous ONLY
/exadmin - integrated ONLY
/public  - basic and integrated ONLY
/oma - basic ONLY
/Exchange-Server-ActiveSync - basic and integrated only

I would also check the application pools are correct:

/exchange - ExchangeApplicationPool*
/exchweb - ExchangeApplicationPool*
/exadmin - ExchangeApplicationPool*
/public  - ExchangeApplicationPool*
/oma - ExchangeMobileBrowseApplicationPool
/Exchange-Server-ActiveSync - ExchangeApplicationPool

Simon.
0
veruscorpAuthor Commented:
Thanks Simon, sorry for leaving out some of the details.  It is a Windows 2003 server running Exchange 2003 SP2.  Some of the permissions and App Pools we're definately not set as you suggested, so I changed them to match up.  This seems to allow me to get a bit further, but the page still is not loading completely, and will load differently and with a different error every time I hit refresh ( see new screenshots below).  It seems like it will render any number of ways, I don't think I've seen the same page come up twice, it always looks different and has a new error.

http://members.arstechnica.com/x/seedless/OWA3.jpg
http://members.arstechnica.com/x/seedless/OWA4.jpg

Let me know if I am leaving out any other details that would be helpful.

Thanks

Nate
0
SembeeCommented:
Did you do an iisreset after making the changes?
If not, do that first.

Drop in to a command prompt and type

iisreset

press enter and wait.

Before you trying connecting again, flush the temporary internet files in the browser.

Simon.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

veruscorpAuthor Commented:
I tried the iisreset and flushed all temp internet files out of the browser.  If I refresh the page 4 or 5 times, I can get a bit closer to a working interface, but it still isnt quite there. See new screenshot:  http://members.arstechnica.com/x/seedless/OWA5.jpg

Is this still looking like a permissions issue?  It seems to accept my username and password, and the errors all looked like the server isn't sending a page that will render properly judging by some of the errors, see below:

g_winDocAll.idFontSize.offsetHeight' is null or not an object

Unterminated string constant

'm_fAttach' is undefined

'L_ErrComm' is undefined


Thanks again for your help

Nate
0
SembeeCommented:
You have the elements there, so it isn't an authentication issue.
Now it elsewhere in the OWA system.

I would be tempted to simply reset the virtual directories to their default and see if that fixes it.
http://support.microsoft.com/default.aspx?kbid=883380

Otherwise it could be something with the .net framework or something like that.

Simon.
0
veruscorpAuthor Commented:
Well, we finally found what the problem was.... The binding order of the two adapters in network connections>advanced>advanced settings was backwards, and for some reason, even though the adapter was disabled in Windows, it was set higher in the binding order and this was causing the problem.  After switching the binding order and rebooting, OWA came up fine.

Thanks for your help along the way Simon.

Nate
0
SembeeCommented:
Glad to hear that you got it fixed.
Don't forget the close the question. If you aren't sure on how to award the points, then post in the Support TA (top right corner) with a link to this question and the moderators will assist you.

Simon.
0
GranModCommented:
PAQed with points refunded (500)

GranMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.