Locking Computer Desktops and Citrix

If I could set this to 1000 points I would.

We have set a Group Policy on a Test OU to enforce desktop lockouts after 10 minutes.  This is a user policy set through Admin templates/Control Panel/Display.

This works just like it should.  After 10 minutes of no activity the desktop locks.  However, for the people that use Citrix, the Citrix session will also lock after 10 minutes because the same user account is being used.

Does anyone know of a workaround so this does not affect the Citrix users?  

We could put all the users in a exception OU without this policy applied, but that is over half the employees.  
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I make one GPO for the OU where your user accounts reside and another GPO for a "TerminalServers" OU.  I put my standard policies on the first OU and the Citrix specific policies on the other OU.  This should only apply the user policies when the account logs onto a Terminal Server; the other policy is in effect on the other machines.  Does this sound like what you were asking for?  
jjparrottAuthor Commented:
It does.  Do you use loopback processing for the policy on your TS servers?
Yep, and "Block Policy Inheritance".  I try to stop all upstream policy on my Terminal Servers and re-do the domain wide stuff at the OU level.  It lets me keep a bit more control over what is going to apply.  

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jjparrottAuthor Commented:
The loopback processing works, just disabled screensaver timeout on the policy applied to the Terminal Servers.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.