[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Applying access lists on a PIX

Posted on 2006-04-13
7
Medium Priority
?
163 Views
Last Modified: 2010-04-09
Hello,

   If I am trying to block a range of IPs like 59.124.0.0 255.252.0.0 using an access list like access-list 105 deny ip 59.124.0.0 255.252.0.0 any  <- to block traffic from this range
My question is that if I enter this access-list into the PIX do I have to assign an access-group or apply to the outside interface if I already have an access-group and access-list applied to the outside interface?

                                     Thank You
0
Comment
Question by:vreyesii
  • 4
  • 3
7 Comments
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16450715
You can make this access-list part of your existing access-list which is already applied.

Cheers,
Rajesh
0
 

Author Comment

by:vreyesii
ID: 16450733
How can I do that? Is it automatically part of the existing access-list after I enter this rule into the PIX?


                                 Thank You
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16450750
Yes.

How is your access-list setup right now? Post the config?

Cheers,
Rajesh
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 

Author Comment

by:vreyesii
ID: 16450773
Below is the config.

                                           Thank You

PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password EEtyji/acyn/O8Zt encrypted
passwd EEtyji/acyn/O8Zt encrypted
hostname pixfirewall
domain-name pix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0
access-list allow_inbound permit tcp any interface outside eq smtp
access-list allow_inbound permit tcp any interface outside eq pop3
access-list allow_inbound permit tcp any interface outside eq www
access-list allow_inbound permit icmp any any source-quench
access-list allow_inbound permit tcp any interface outside eq ssh
access-list allow_inbound permit tcp any host 216.x.x.236 eq www
access-list allow_inbound permit tcp any host 216.x.x.236 eq ssh
access-list allow_inbound permit tcp any host 216.x.x.236 eq h323
access-list allow_inbound permit tcp any host 216.x.x.236 eq 5060
access-list allow_inbound permit tcp any interface outside eq pptp
access-list allow_inbound permit gre any interface outside
access-list allow_inbound permit tcp any interface outside eq 3000
access-list allow_inbound permit tcp any interface outside eq 13492
access-list allow_inbound permit udp any interface outside eq 13492
access-list deny_outbound deny tcp any host 63.x.x.73 eq www
access-list deny_outbound deny tcp any host 63.x.x.73 eq https
access-list deny_outbound deny tcp any host 209.x.x.7 eq https
access-list deny_outbound permit ip any any
access-list deny_outbound permit gre any any
access-list 105 deny ip 59.124.0.0 255.252.0.0 any
no pager
logging on
logging timestamp
logging monitor debugging
logging trap notifications
logging queue 24
logging host inside 10.1.1.23
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside 216.x.x.85 255.255.255.0
ip address inside 10.1.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.1.2.1-10.1.2.254
pdm location 10.1.1.6 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 10.1.1.0 255.255.255.0 0 0
static (inside,outside) tcp interface www 10.1.1.6 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ssh 10.1.1.6 ssh netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pptp 10.1.1.23 pptp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 10.1.1.23 pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp 10.1.1.23 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3000 10.1.1.23 3000 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1000 10.1.1.23 1000 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 13492 10.1.1.2 13492 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 13492 10.1.1.2 13492 netmask 255.255.255.255 0 0
static (inside,outside) 216.x.x.236 10.1.1.7 netmask 255.255.255.255 0 0
access-group allow_inbound in interface outside
access-group deny_outbound in interface inside
route outside 0.0.0.0 0.0.0.0 216.x.x.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
http server enable
http 10.1.1.0 255.255.255.0 inside
snmp-server host inside 10.1.1.23
no snmp-server location
no snmp-server contact
snmp-server community nyc4u2me
snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client authentication LOCAL
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 default-domain pix.com
vpngroup vpn3000 split-tunnel 101
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
vpngroup vmr2 address-pool ippool
vpngroup vmr2 default-domain pix.com
vpngroup vmr2 split-tunnel 101
vpngroup vmr2 idle-time 1800
vpngroup vmr2 password ********

telnet timeout 30
ssh 10.1.1.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
username vmr2 password XXXXXXXXXXXXXXx encrypted privilege 15
username victor password XXXXXXXXXXXXXXX encrypted privilege 3
privilege show level 15 command access-group
privilege clear level 15 command access-group
terminal width 80
banner motd Unauthorized access and use of this network/device will be prosecuted.
Cryptochecksum:44d22a9c1f239b03af8dca4feb3b5ffa
: end
0
 
LVL 32

Accepted Solution

by:
rsivanandan earned 2000 total points
ID: 16450844
So here you need to do this;
 
On the PIX config mode, type in;

access-list allow_inbound line 1 deny ip 59.124.0.0 255.252.0.0 any  

This should add your requirement at the first line of your access-list statements. So after you do this; issue 'show run' and make sure it is at the first line.

Cheers,
Rajesh
0
 

Author Comment

by:vreyesii
ID: 16450892
Alright thank you thats excatly what I needed.
   
                                                      Thank You
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16451158
Glad I could help you.

Cheers,
Rajesh
0

Featured Post

Rewarding opportunities for women in IT

Across the nation, technology jobs are vacant because there aren’t enough qualified professionals to fill them. With a degree from WGU, you can get the credentials it takes to become an in-demand IT professional. Plus, WGU’s IT programs include industry certifications.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses
Course of the Month18 days, 2 hours left to enroll

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question