Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Cisco PIX 501 config

Posted on 2006-04-13
16
Medium Priority
?
948 Views
Last Modified: 2013-11-16
Help! I just setup my first Cisco PIX 501. It is a very simple single internal network setup. The server behind the pix is running a Tomcat webservers that I need users on the Internet to be able to access. That part actually works but the internal host cannot access the internet which means it can't send the emails that I need it to. Here is the config. Any help would be great.

PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100

hostname cwccupix
domain-name wealthcu.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit tcp any host 65.203.33.211 eq www
access-list 100 permit udp any host 65.203.33.211 eq www
access-list inside_access_in permit tcp any any
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 65.203.33.201 255.255.255.192
ip address inside 192.168.1.1 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.1.2 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 65.203.33.210
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 65.203.33.211 192.168.1.2 netmask 255.255.255.255 0 0
access-group 100 in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 65.203.33.193 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 5
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
0
Comment
Question by:tmelo49
  • 7
  • 4
  • 3
  • +1
16 Comments
 
LVL 20

Accepted Solution

by:
calvinetter earned 2000 total points
ID: 16451072
no access-group inside_access_in in interface inside

  The "inside_access_in"  ACL is blocking outbound traffic.  You don't need any ACLs applied to the inside interface unless you have specific traffic you want to block outbound.

cheers
0
 

Author Comment

by:tmelo49
ID: 16451122
thanks but still no luck. i removed that ACL and still cannot do anything outbound.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16451182
Do you have your internal host's default gateway pointed to PIX firewall? Can you verify that on the host with 'ipconfig' command?

Also you don't seem to be delievering DNS addresses through PIX dhcp server. DNS resolution wouldn't work without it.

Try pinging 68.142.226.52 (thatz yahoo) and see if you can do it. If it works, then you need to provide the DNS server address to the dhcp clients.

Cheers,
Rajesh
0
Managing Security Policy in a Changing Environment

The enterprise network environment is evolving rapidly as companies extend their physical data centers to embrace cloud computing and software-defined networking. This new reality means that the challenge of managing the security policy is much more dynamic and complex.

 

Author Comment

by:tmelo49
ID: 16451203
There is only one host and it is using the PIX internal interface as its default gateway (192.168.1.1). The pix can ping that yahoo IP just fine but the internal host cannot. I do not have a router behind the pix. Do i need one in order to route packets back to the internal host?
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 16451206
Hmm, the PIX isn't the DHCP server, since I don't see "dhcpd enable inside".  Agree with Rajesh that the PIX must be the default gateway of the inside hosts.
  If you've made any changes to your 'nat' or 'global' statements, you must run this afterwards:
clear xlate

cheers
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16451220
Yeah. I noticed it just now Calvinetter :-)

If it doesn't work after 'clear xlate', would it hurt to bounce the pix once?


Can you post 'ipconfig/all' output from the host you are trying?

Cheers,
Rajesh
0
 

Author Comment

by:tmelo49
ID: 16451267
no luck with a 'clear xlate' and a reload. I cant get an IPconfig from that server becasue it is at the office and remote access is disabled but i stared at it all day today and it looks like this:

IP Address. . . . . . . . . . . . : 192.168.1.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : ISP assigned DNS server's. I don't remember those by heart.
                                           
I can get a full ipconfig /all posted in the morning.

Do my global and nat statements look ok?
                                   
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16451278
Yeah, NAT looks fine. tomorrow when you get the full 'ipconfig/all' from the machine, also post the latest config from the PIX.

Cheers,
Rajesh
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 16451292
 Try :
no global (outside) 1 65.203.33.210  <- any special reason to use this IP for inside hosts' NAT IP?
global (outside) 1 65.203.33.210 netmask 255.255.255.192
clear xlate

  Or just the old tried & true:
global (outside) 1 interface
clear xlate

cheers
0
 

Author Comment

by:tmelo49
ID: 16451316
just tried both with the same result.
0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 16451795
Remove the anti-spoofing line
ip verify reverse-path interface outside

add
no sysopt noproxyarp
0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 16451799
PS
Cannot remeber if this needs to be applied to an interface or not, you might need to try it like this
add
no sysopt noproxyarp outside
0
 

Author Comment

by:tmelo49
ID: 16453672
still nothing. I just checked and that host can ping its gateway (192.168.1.1). Do I need to add a static route for the inside interface? Here is an ipconfig and my latest PIX config:

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet #2
   Physical Address. . . . . . . . . : 00-14-22-7C-52-36
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.1.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 199.45.32.40
                                       199.45.32.41

interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname cwccupix
domain-name wealthcu.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit tcp any host 65.203.33.211 eq www
access-list 100 permit udp any host 65.203.33.211 eq www
access-list 100 permit tcp any host 65.203.33.211 eq 3389
access-list inside_access_in permit tcp any any
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 65.203.33.201 255.255.255.192
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.1.2 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 65.203.33.211 192.168.1.2 netmask 255.255.255.255 0 0
access-group 100 in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 65.203.33.193 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 5
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
0
 

Author Comment

by:tmelo49
ID: 16453754
I just noticed something weird. If i tracert from the host to its default gateway it gets there with 1 hop. If i tracert to any external IP, i dont even get to the default gateway as the first hop.
0
 

Author Comment

by:tmelo49
ID: 16455042
Thanks for the help everyone! It was indeed the default ACL applied to the inside interface.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16455085
Glad you got it working.

Cheers,
Rajesh
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
Considering cloud tradeoffs and determining the right mix for your organization.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question