Configuring Cisco 1800/2800 Routers for MPLS

Posted on 2006-04-14
Last Modified: 2010-05-19
Good morning everyone,

I am hoping that I can find some documentation on configuring some Cisco 1800/2800 Routers to work with an MPLS. I am working with multiple sites, a main office running the 2800, and satellite offices running the 1800's. It will be handling VoIP and Data traffic, with each satellite office having 3-4 people.

So, can anyone point me to some documentation for this sort of thing? All I have found so far is documentation for setting up the MPLS cloud itself.

Question by:WelfleyTech
    LVL 79

    Accepted Solution

    MPLS really only does work "in the cloud"
    For your local edge router it is nothing more than (typically) a frame-relay PVC connection and using BGP as the routing protocol..

    It could be as simple as something like this:

    //-- Interfaces config

    interface FastEthernet 0/0
     ip address

    interface Serial 0/0/0
     encap frame-relay ietf  <== "ietf" or not will be determined by provider

    interface Serial 0/0/0.1
      ip address <== IP address for wan link provided by provider
      frame-relay interface-dlci 222   <== DLCI # determined by provider

    //-- routing
    router bgp 65002  <== your bgp AS# (private AS's used in MPLS)
     neighbor remote-as 65001 <== your provider's AS#
     network mask  <== network (LAN) you will advertise
     ip route   <== default may point to the cloud

    //-- quality of service example
    //-- acls define traffic. This is VOIP server traffic, yours could be by precedence bits..

    access-list 112 permit ip host any
    access-list 112 permit ip host any
    class-map match-all HI
     match access-group 112
    policy-map IPFRCOS
     class HI
      bandwidth remaining percent 60
      set ip dscp af31  
     class class-default
      bandwidth remaining percent 20
      set ip dscp default
    ! Apply the policy to the Egress interface
    interface Serial 0/0/0.1
     max-reserved-bandwidth 100
     service-policy output IPFRCOS
    LVL 12

    Expert Comment

    Chances are it WON'T be frame relay; HDLC or PPP would be likely.

    And for a routing protocol, it can be RIPv2, OSPF, EIGRP, IS-IS, or BGP.  The provider might not support one or more, but they're all possible.
    LVL 79

    Expert Comment

    It all depends on the provider. I've worked with AT&T, MCI, BellSouth, and Verizon building MPLS networks and every one is a Frame connection if it's a T1, and every one required BGP. QoS with Diffserv was an option.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Maximize Your Threat Intelligence Reporting

    Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

    The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
    There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now