LG GCC-4521B DVD-ROM/CD-RW won't burn CD's

I have an LG Electronics  GCC-4521B combo DVD-ROM/CD write. It reads CD's and plays DVD's. It refuses to burn either CD-R or CD-RW discs.(never did since the day I built the PC)
Using Nero Express(Nero Burning ROM 5.5.9.9) Also have In CD - CD-RW UDF tools 3.39.0
Updtaed combo drive drive firmware to 1.05 (the most recent I could fin on the net. Couldn't find any direct from LG sites.) Followed instructions and it seemed to go OK.
I'm in Ireland but the internal CD/DVD drive was bought from UK.

I have also tried different versions of Nero.

I go through the motions and when I press 'burn' out pops the tray and it asks me to insert appropriate media - bought and tried both CD-R and CD-RW- even though the CD is already in the drive. Even if I re-insert it doesn't recognise the CD's.
Any ideas?
giardapAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

maramomCommented:
Do you have a problem burning to DVD as well?
Have you tried a different brand of media? Sometimes drives are picky about the actual media being used.
You may have a software conflict. Try uninstalling all versions of Nero and any other burning software. After all is removed, install the latest version of Nero and check the website for updates.

You can check to see if the drive will work outside of windows by using a live cd to try to burn with the drive: http://www.knopper.net/knoppix/index-en.html
(You'll have to use another system to burn the disk, however.)

If it works with Knoppix you are assured that the drive works and the problem is in windows.
0
giardapAuthor Commented:
Hi maramom,
Thanks for speedy reply.

It's a DVD-ROM so doesn't claim to burn DVD.
Yes tried Datawrite DVD-R and Verbatim CD-RW. Am not really anxious to spend more on testing other brands (may be cheaper to bin the drive!)
Have uninstalled and reinstalled several times to no avail. Only Nero software running at the moment.

I have quad-booted this machine with Win XP Home, Ubuntu 'Breezy Badger',SUSE Linux 10 and Mandriva Linux Powerpack 2006. I also have a Knoppix CD.
Just feeling my way with Linux at the moment (GUI stuff mainly - not too much CLI). Will boot Knoppix and try a burn.

(Spec summary: Win XP Home/320 GB+ hard drives/Intel Celeron 2.4 cpu/1 GB DDR RAM/Intel D865GBF motherboard)
 
0
giardapAuthor Commented:
Correction:
  "Yes tried Datawrite CD-R and Verbatim CD-RW"
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

willcompCommented:
Using Knoppix to test is an excellent idea.  Eliminates OS as problem, which it very well might be.

Also, it's a good practice to test burn using XP built-in burning software prior to installing any other CD burning software.

If Knoppix doesn't pan out, may want to install drive in another PC to test.
0
giardapAuthor Commented:
As luck would have it, I have 2 optical drives installed so booted with Knoppix from other CD-ROM drive and fired up  K3b.
Knoppix didn't configure sound (What is it with Linux and sound...).
LG Electronics  GCC-4521B combo drive wouldn't burn either type of CD, -R or -RW. Asked for media. Couldnt see a CD with various test files that I use (Word/PowerPoint/JPEG etc).
Could play video from a DVD I created with DVD Shrink though !! So this drive 'sort of' works.

Will try a few more things;
1. try to burn from within Mandriva Linux 2006- to be sure, to be sure...
2. try Knoppix burn on  my other PC
3. Uninstall all burning software and see what Windows XP built in burning software thinks of this drive - where is this XP 'burning software' located?
4. Finally install drive in other PC to see if it works there
0
willcompCommented:
XP burning software - Right click file -> Send To -> Select CD burner as destination
0
willcompCommented:
Forgot: Windows CD burning software and drivers will not affect Linux.  I suspect you have a faulty drive.
0
maramomCommented:
http://gb.lgservice.com/
click: device drivers
under product, click 'combo drive'
you'll see a list of firmware updates, including your model for a newer firmware release 1.07
GCC4521B107(ew).zip is the file name

Hopefully this update may fix your problem.
0
maramomCommented:
If all steps show know results, I'm guessing that either the drive is faulty
or
more likely, it's extremely picky about the media used.

There have been issues with this combo model with cd-r and cd-rw recogniition, and your 1.05 firmware addresses this issue. Hopefully the newer update will fix it.
0
maramomCommented:
I just looked at the firmware page, again, and there seems to be a discrepancy, in that the file is named for your model, but it's listed for a 5421B. Typo, perhaps? Even if you click the model link, the firmware description alternates between both model numbers.
I would think that it's safe to say the firmware is for your model, but, just a caution........using the wrong firmware can render the drive useless. The software usually will have protection for this, in searching for a drive that matches it's criteria.
0
maramomCommented:
I checked the US site, and it is definitely listed for your drive..so you will be fine if you try that update.
http://us.lgservice.com/index_b2c.jsp

Just be sure to follow the instructions completely..they say to use it as the only drive as master on the secondary IDE channel. Disable all running programs, and don't interupt the update, or the drive will be damaged.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
giardapAuthor Commented:
Further update. I went into Mandriva Linux 2006 powerPack and started K3b.
It (the combo drive GCC-4521B) failed to burn a bunch of files to a Datawrite CD-R but...to my immense surprise... it successfully burned them to a Verbatim CD-RW. So it works, sometimes, under very specific conditions. What does this tell me?? Is it faulty, or just tempremental to the point of uselessness in Windows XP Home?

maramom- Yes I'd googled this problem and there are a few unhappy punters with similar experiences to mine. Other than the firmware update I didn't really see a definitive solution. And so to EE...  
I had spotted the 5421/4521 thing and I assumed they were 2 different models, that's why I went with the 1.05 firmware.

0
giardapAuthor Commented:
maramom - I downloaded the 1.07 firmware as suggested. Installed OK.
The combo drive now gives the options, automatically on insertion of a CD-RW disk, to (i) format the disk with InCD or, (ii) to open Nero Burner and burn.
Both options then work as expected in that I can now burn files to the CD.
It still fails to recognise the CD-R discs. But this is progress, and CD-RW disks aren't that much more expensive than CD-R nowadays.

As many of the firmware update notes mention recognition of CD's of various sorts, it looks like it has taken LG several attempts to fix non-recognition problems with this drive - and it's still not perfect.
Any further thoughts on CD-R?
0
maramomCommented:
I would suggest you try Verbatim cd-r disks, since your drive recognizes the cd-rw version.
0
maramomCommented:
You may just have to test out which brands work with the drive. As I said earlier, unfortunately, some drives are picky about the media they use.

If it gets annoying enough, you may want to get a different drive (as you eluded to doing).
0
giardapAuthor Commented:
Many thanks maramom, and willcomp, for your assistance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.