?
Solved

Error code 80070035 from VBS script at login

Posted on 2006-04-14
6
Medium Priority
?
2,220 Views
Last Modified: 2010-05-18
We use a group policy to run a login script that will map our user drives whenever anyone logs into the windows network. We run Windows 2003 on the domain controller and all of our computers are runnningeither windows 2000 or windows XP.

I have 83 users that can log into the network without issue One user running a new DELL laptop and windows XP gets an error message whenever the VBS script to map the drives runs.

The message says "error at line 21 network path not found" error code is listed as 80070035.

This is the initial part of the vbs script we are running.
<<<<<<<<<<<<<<<<<<<<<<<
Option Explicit
Dim objNetwork, objUser, CurrentUser
Dim strGroup

Const Marketing_group = "cn=market_dept"
Const Managers_Group = "cn=manage"
'Const What_ever_you_Like = "cn=any_lower_case_group"
'Const Users_Group = "cn=users"
Const Administrators_Group = "cn=administration"
Const Business_Group = "cn=business"
Const Logan_Group = "cn=logan"

Set objNetwork = CreateObject("WScript.Network")

Set objUser = CreateObject("ADSystemInfo")
Set CurrentUser = GetObject("LDAP://" & objUser.UserName) <<<<< This is line 21 mentioned in the error message box.
strGroup = LCase(Join(CurrentUser.MemberOf))
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

I can insert a write.echo command just after the CreateObject command and the information returned seems to be correct. but after that the script wil fail. BUt it only fails on this one computer, so it has to be a setting or configuration issue on the computer itself. Hoever, I am at a lose as to were to look. Can you make a suggestion?
Regards and thanks in advance
Rick Hanzlik
Network Engineer
Spectrum Engineers
0
Comment
Question by:cvc505
  • 2
  • 2
5 Comments
 
LVL 7

Expert Comment

by:Isigow
ID: 16455050
Try copying the file locally and running it by hand vs over the GPO with the WScript.Echo added in. Does it work then?
What does RSOP.msc show when it runs, are all GPO's applying successfully to this computer or is something different from other systems?
Is there are O/S Differences on this new computer like XP-SP2? Is .NET Installed on other systems and not this one or vice versa? I'm wondering if because it is a new system, some setting has been missed that was previosly made to your domain...

Isi
0
 

Author Comment

by:cvc505
ID: 16455449
Isi:

I have tried running the script locally from this computer and it does not work there either, I get the same error. As for the other issues you raised , I am afraid I do not know what the RSOP or the GPO mean. This machine is running XP-SP2 and as far as I know it does have the .net installed. it is not the newest machine in the stable I have other lapto0ps that were purchased after this one that will run the script.

Thansk for your input, any other suggestions?
0
 
LVL 7

Expert Comment

by:Isigow
ID: 16456107
RSOP is Resultant Set of Policy, logon to the machine as an administrator who does not have a group policy object (GPO) running on him and start->run RSOP.msc. It should return every policy that is successfully applying to your machine, or an error if they arent. (more of a check just to make sure everything is kosher with the machine's domain information) What is the output that the wscript.echo is producing?
0
 

Author Comment

by:cvc505
ID: 16596123
I finally resolved this problem. The user has a copy of the McAfee firewall installed. He was blocking the access to the wsscript host functions. once we removed this, the problem went away.
0
 
LVL 1

Accepted Solution

by:
DarthMod earned 0 total points
ID: 17241147
PAQed with points refunded (500)

DarthMod
Community Support Moderator
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Downtime reduced, data recovered by utilizing an Experts Exchange Business Account Challenge The United States Marine Corps employs more than 200,000 active-duty Marines with operations in four continents, all requiring complex networking system…
This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question