?
Solved

PIX syslog error Message

Posted on 2006-04-14
17
Medium Priority
?
2,564 Views
Last Modified: 2010-04-08
Hi there,

       I was looking at a PIX syslog and in the logs I noticed that there were a couple of entries which had a priority of error. When I took a look at them closer I saw that in the syslog it stated

>> 04-14-2006      11:42:13      Local4.Error      10.1.1.1      Apr 13 2006 22:29:50: %PIX-3-305005: No translation group found for udp src inside:192.168.197.1/123 dst outside:207.46.232.189/123
04-14-2006      11:42:13      Local4.Error      10.1.1.1      Apr 13 2006 22:29:50: %PIX-3-305005: No translation group found for udp src inside:192.168.153.1/123 dst outside:207.46.232.189/123
04-14-2006      11:42:13      Local4.Error      10.1.1.1      Apr 13 2006 22:29:50: %PIX-3-305005: No translation group found for udp src inside:192.168.197.1/123 dst outside:207.46.130.100/123
04-14-2006      11:42:13      Local4.Error      10.1.1.1      Apr 13 2006 22:29:50: %PIX-3-305005: No translation group found for udp src inside:192.168.153.1/123 dst outside:207.46.130.100/123
 
Can someone please explain to me why did this error occur on the PIX, what was the outside: IP(207.46.130.100) trying to do I know that they were using port 123, however what exactly happen that the PIX gave an error?

                                                              Thank You in Advance
0
Comment
Question by:vreyesii
  • 6
  • 5
  • 3
  • +2
17 Comments
 
LVL 9

Expert Comment

by:jabiii
ID: 16455053
looks like one of your internal devices is still configured for time.windows.com for NTP

basically it says that your not allowing that host to go to NTP at windows.
0
 

Author Comment

by:vreyesii
ID: 16455082
Thank You for the reply.

         Well the problem is that none of the internal devices have an ip address of 192.168.197.1. So I do not know if maybe someone from the outside was trying to do something, however, I do not understand what excatly they were trying to do?

                                Thank You
0
 
LVL 9

Expert Comment

by:jabiii
ID: 16455577
NTP is a network time protocol, being that this one is connecting to windows, I assume it is a windows machine trying to connect back to windows, to ensure it has the correct time.
It could be a misconfigured computer.
0
Cyber Threats to Small Businesses (Part 2)

The evolving cybersecurity landscape presents SMBs with a host of new threats to their clients, their data, and their bottom line. In part 2 of this blog series, learn three quick processes Webroot’s CISO, Gary Hayslip, recommends to help small businesses beat modern threats.

 
LVL 9

Expert Comment

by:jabiii
ID: 16455704
can you check your arp table on the pix and see if it see's the 192 address? can you try tracing to it from the 10.1.1.1 interface?
0
 

Author Comment

by:vreyesii
ID: 16456451
I looked at the ARP table and I do not see any 192 address.

outside 216.x.x.1 0090.1a40.a29f
        inside 10.1.1.3 0003.478f.1def
        inside 10.1.1.2 0013.20d5.be65
        inside 10.1.1.8 0013.20cf.6dd4
        inside 10.1.1.23 0001.0271.f301
        inside 10.1.1.30 0011.509a.95ea
        inside 10.1.1.6 0020.3512.6eb2
        inside 10.1.1.12 0008.a3f7.0a00
        inside 10.1.1.7 0004.ac3e.f730
                                                           Thank You
0
 

Author Comment

by:vreyesii
ID: 16458707
Any other suggestions?

                       Thank You
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16462205
> No translation group found for udp src inside:192.168.197.1/123 dst outside:207.46.232.189/123

Somebody has something with IP address 192.168.197.1 trying to set its time using NTP.
The PIX does not recognize it as being routable on inside interface and can't set up an xlate for it, hence the error.
Suggest using "capture" command on PIX to find source MAC address, or use Solarwinds' switchport mapper to find the culprit
http://www.solarwinds.net/Tools/Network_Discovery/Switch_Port_Mapper/index.htm
This will tell you exactly which switchport this offendor is connected to and you can chase them down.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16462542
I'm wondering how come this 192.168.197.1 address made it up to the PIX firewall? I mean technically you need to have a router to do it right? Between 10.1.1.0 and 192.168.197.0 ??

Cheers,
Rajesh
0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 16463227
vreyesii, been a while since we saw your config; have you got other interfaces (real or virtual) on your PIX?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16463991
I saw the exact same thing on my pix when I put a secondary IP address on my PC so that i could access another box that I brought home from the office. I saw that secondary IP address as the source for NTP requests (and it only seemed to be for ntp) with the appropriate no translation message.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16464614
Lrmoore,

  Secondary IP as in a different network with no way to route it?

Cheers,
Rajesh
0
 

Author Comment

by:vreyesii
ID: 16465339
Here is a copy of the config on the PIX.

PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XXXXXXXXXXXX encrypted
passwd XXXXXXXXXXXXXXXX encrypted
hostname pixfirewall
domain-name pix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0
access-list allow_inbound permit tcp any interface outside eq www
access-list allow_inbound permit icmp any any source-quench
access-list allow_inbound permit tcp any interface outside eq ssh
access-list allow_inbound permit tcp any host 216.254.X.X eq www
access-list allow_inbound permit tcp any host 216.254.X.X eq ssh
access-list allow_inbound permit tcp any host 216.254.X.X eq h323
access-list allow_inbound permit tcp any host 216.254.X.X eq 5060
access-list allow_inbound permit tcp any interface outside eq pptp
access-list allow_inbound permit gre any interface outside
access-list deny_outbound deny tcp any host 63.236.X.X eq https
access-list deny_outbound permit ip any any
access-list deny_outbound deny tcp any host 209.202.X.X eq https
access-list deny_outbound deny tcp any host 63.236.X.X eq www
access-list deny_outbound permit gre any any
no pager
logging on
logging timestamp
logging monitor debugging
logging trap notifications
logging queue 24
logging host inside 10.1.1.23
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside 216.254.X.X 255.255.255.0
ip address inside 10.1.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.1.2.1-10.1.2.254
pdm location 10.1.1.6 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 10.1.1.0 255.255.255.0 0 0
static (inside,outside) tcp interface www 10.1.1.6 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ssh 10.1.1.6 ssh netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pptp 10.1.1.23 pptp netmask 255.255.255.255 0 0
static (inside,outside) 216.254.X.X 10.1.1.7 netmask 255.255.255.255 0 0
static (inside,outside) 216.254.X.X 10.1.1.24 netmask 255.255.255.255 0 0
access-group allow_inbound in interface outside
access-group deny_outbound in interface inside
route outside 0.0.0.0 0.0.0.0 216.254.X.X 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
http server enable
http 10.1.1.0 255.255.255.0 inside
snmp-server host inside 10.1.1.23
no snmp-server location
no snmp-server contact
snmp-server community nyc4u2me
snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client authentication LOCAL
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 default-domain pix.com
vpngroup vpn3000 split-tunnel 101
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
vpngroup vmr2 address-pool ippool
vpngroup vmr2 default-domain pix.com
vpngroup vmr2 split-tunnel 101
vpngroup vmr2 idle-time 1800
vpngroup vmr2 password ********
vpngroup grace address-pool ippool
vpngroup grace default-domain pix.com
vpngroup grace split-tunnel 101
vpngroup grace idle-time 1800
vpngroup grace password ********
telnet timeout 30
ssh 10.1.1.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
username vmr2 password XXXXXXXXXXXXX encrypted privilege 15
username victor password XXXXXXXXXXXXXX encrypted privilege 3
privilege show level 15 command access-group
privilege clear level 15 command access-group
terminal width 80

banner motd Unauthorized access and use of this network/device will be prosecuted.
Cryptochecksum:2bb92fa13153e9f7a4f8e20416ba3e46
: end
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 400 total points
ID: 16466206
There is nothing wrong the the PIX config.. except your deny acl:

access-list deny_outbound deny tcp any host 63.236.X.X eq https
access-list deny_outbound permit ip any any  <== this is too high and the next two entries will not be evaluated, so you will not block what you think you will

access-list deny_outbound deny tcp any host 209.202.X.X eq https
access-list deny_outbound deny tcp any host 63.236.X.X eq www


>Secondary IP as in a different network with no way to route it?
Raj, yes that is exactly right. Apparently Windoz throws it out to the default gateway with the wrong source IP.

0
 
LVL 9

Expert Comment

by:jabiii
ID: 16469044
might want to check your arp table on your switch that is on the same internal network as the FW see if it knows where the culprit is.
0
 

Author Comment

by:vreyesii
ID: 16479148
I did what everyone suggested however I didn't find the ip address . I also fixed the access lists.
0
 
LVL 9

Accepted Solution

by:
jabiii earned 1600 total points
ID: 16479469
You should check all of your windows computers and see who is configured for NTP to microsoft.
http://technet2.microsoft.com/WindowsServer/en/Library/b43a025f-cce2-4c82-b3ea-3b95d482db3a1033.mspx

then see if any of themhave a dual homed nic. ipconfig /all.

on xp. HKLM/System/CurrentControlset/services/w32time/config/ntpserver
0
 

Author Comment

by:vreyesii
ID: 16513237
Thank You everyone for all your help I will see if another message like this appears again in the logs. Thanks again.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question