?
Solved

MRxSmb Event ID 50 Application is trying to save data to server.

Posted on 2006-04-14
27
Medium Priority
?
3,718 Views
Last Modified: 2012-05-05
I have a scanning app that save the Images and Information filed to a Folder on my DC in Sporatically pops up an error of Write delay error. I emmediatly go to the event view and I see this event:

Event Type:      Warning
Event Source:      MRxSmb
Event Category:      None
Event ID:      50
Date:            4/14/2006
Time:            10:59:15 AM
User:            N/A
Computer:      RCOBLENS
Description:
{Delayed Write Failed} Windows was unable to save all the data for the file \Device\LanmanRedirector. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

I have seen a few fixes but none seem to work. O B ONE please help,,,



For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 04 00 04 00 02 00 56 00   ......V.
0008: 00 00 00 00 32 00 04 80   ....2..€
0010: 00 00 00 00 0c 02 00 c0   .......À
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0028: 0c 02 00 c0               ...À    
0
Comment
Question by:rcoblens
  • 13
  • 7
  • 7
27 Comments
 
LVL 15

Expert Comment

by:venom96737
ID: 16455014
check here http://support.microsoft.com/default.aspx?scid=kb;%5BLN%5D;321733 should solve the problem the work around or fix for xp is toward the bottom
0
 

Author Comment

by:rcoblens
ID: 16455037
I already saw that fix, but the laptop was already set to that......
0
 
LVL 11

Expert Comment

by:star_trek
ID: 16455061
Did you try these hot fixes?
http://support.microsoft.com/default.aspx?scid=kb;en-us;321733#XSLTH3123121125120121120120

If it does not work then there might be something to do with the scanning app??
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 11

Expert Comment

by:star_trek
ID: 16455072
oops sorry venom, i didn't refresh the page
0
 

Author Comment

by:rcoblens
ID: 16455091
That is what I think, but I need to be sure before I pitch a fit with them...
0
 

Author Comment

by:rcoblens
ID: 16455114
I saw this also:

1. Click Start, click Run, in the Open: box type regedit, and then click OK.
2. Locate the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
3. In the right pane, right-click the value SystemPages, and then click Modify.
4. In the Value data box, type the following value: 0xFFFFFFFF and then click OK.
5. Exit Registry Editor.
0
 
LVL 11

Expert Comment

by:star_trek
ID: 16455116
I think so, because windows xp sp2 has fixed this, so if you have two already installed then there is no need for hotfix. Problem shld be either with windows or the client app if the windows is fine then client app is work checking..
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16455120
ok try checking your I/O subsystem and also your physical network cabling
0
 

Author Comment

by:rcoblens
ID: 16455130
All done with that already:

New GB card on server
New Dell PC2708 GB switch
New CAT5e cables from Laptop to switch, switch to server.

Complete GB back bone...
0
 
LVL 11

Expert Comment

by:star_trek
ID: 16455150
Also, did it occur just one time or everytime you are using? if it had occured just one time then may be the network drive went offline due to network issues?
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16455155
ok try turning enable cache writing on the disk off see if that helps.
0
 

Author Comment

by:rcoblens
ID: 16455191
I checked that also went through all EVent and cleared them up, ran trace route prog no packets lost. It can happen a few times usually went it sit for awhile.
0
 

Author Comment

by:rcoblens
ID: 16455207
Last fix I saw was to disable that, it was turned on...
0
 

Author Comment

by:rcoblens
ID: 16455327
I will work with the software and see if it help.... Thanks for the quick response....
0
 

Author Comment

by:rcoblens
ID: 16455681
That didn't last long.. I saw these event befor eit happened again... They are in order of effect..

Event Type:      Warning
Event Source:      BROWSER
Event Category:      None
Event ID:      8021
Date:            4/14/2006
Time:            12:25:47 PM
User:            N/A
Computer:      RCOBLENS
Description:
The browser was unable to retrieve a list of servers from the browser master \\NAT-LAW-1 on the network \Device\NetBT_Tcpip_{64C27A4B-6193-4935-898A-BBB22930651D}. The data is the error code.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 40 00 00 00               @...    

Event Type:      Error
Event Source:      NetBT
Event Category:      None
Event ID:      4321
Date:            4/14/2006
Time:            12:25:57 PM
User:            N/A
Computer:      RCOBLENS
Description:
The name "NATHANSONLAWFIR:1d" could not be registered on the Interface with IP address 192.168.1.103. The machine with the IP address 192.168.1.102 did not allow the name to be claimed by this machine.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 04 00 56 00   ......V.
0008: 00 00 00 00 e1 10 00 c0   ....á..À
0010: 01 01 00 00 01 00 00 c0   .......À
0018: 03 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........


Event Type:      Warning
Event Source:      Tcpip
Event Category:      None
Event ID:      4226
Date:            4/14/2006
Time:            12:27:26 PM
User:            N/A
Computer:      RCOBLENS
Description:
TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 01 00 54 00   ......T.
0008: 00 00 00 00 82 10 00 80   ....‚..€
0010: 01 00 00 00 00 00 00 00   ........
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........

Event Type:      Information
Event Source:      Application Popup
Event Category:      None
Event ID:      26
Date:            4/14/2006
Time:            12:40:22 PM
User:            N/A
Computer:      RCOBLENS
Description:
Application popup: Windows - Delayed Write Failed : Windows was unable to save all the data for the file \\192.168.1.102\data\IPRO Tech\eScan-IT2.5\Data\American National Bank vs Potash.prj\BAT0033.bch\BAT0033Meta.cdx. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Please any advise is greatly needed...


0
 
LVL 11

Expert Comment

by:star_trek
ID: 16456313
Seems like you  are losing are you network connection when this error is happening

"The name "NATHANSONLAWFIR:1d" could not be registered on the Interface with IP address 192.168.1.103. The machine with the IP address 192.168.1.102 did not allow the name to be claimed by this machine."
Looks like there is a same netbios name existing as the name of your computer. Try changing that if not do the following.
Add your wins server to the wins list if it is not added.Also this is something to do with the NETBIOS names. If you have Enable NetBIOS over TCP/IP then do it default and see if it goes away. If it doesn't then disable and enable netbios over TCP/IP

The browser was unable to retrieve a list of servers from the browser master \\NAT-LAW-1 on the network \Device\NetBT_Tcpip_{64C27A4B-6193-4935-898A-BBB22930651D}. The data is the error code.

Also having problems with the master browser. To find the master browsers you can try BrowStat.exe  or NLTest can be found on MS website or in resource kit


>>TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts.

looks like something else is running during that time hogging all your tcp/ip connections. Do netstat -a and check for all the TCP/IP connections. this is the reason that might be causing the error when you are using the app as it is losing network conenction.



0
 

Author Comment

by:rcoblens
ID: 16456441
This is everything from Netstat -a:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\richc.NATHANSONLAWFIR>browstat
'browstat' is not recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\richc.NATHANSONLAWFIR>Netstat -a

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    rcoblens:epmap         rcoblens.NathansonLawFirm.local:0  LISTENING
  TCP    rcoblens:microsoft-ds  rcoblens.NathansonLawFirm.local:0  LISTENING
  TCP    rcoblens:ms-sql-s      rcoblens.NathansonLawFirm.local:0  LISTENING
  TCP    rcoblens:31038         rcoblens.NathansonLawFirm.local:0  LISTENING
  TCP    rcoblens:1059          rcoblens.NathansonLawFirm.local:0  LISTENING
  TCP    rcoblens:62514         rcoblens.NathansonLawFirm.local:0  LISTENING
  TCP    rcoblens:netbios-ssn   rcoblens.NathansonLawFirm.local:0  LISTENING
  TCP    rcoblens:1075          192.168.1.102:http     ESTABLISHED
  TCP    rcoblens:1098          baym-cs41.msgr.hotmail.com:1863  ESTABLISHED
  TCP    rcoblens:1138          192.168.1.102:microsoft-ds  ESTABLISHED
  TCP    rcoblens:1226          192.168.1.102:epmap    TIME_WAIT
  TCP    rcoblens:1227          192.168.1.102:1026     TIME_WAIT
  TCP    rcoblens:1237          207.68.178.61:http     ESTABLISHED
  TCP    rcoblens:1238          194.129.79.6:http      TIME_WAIT
  TCP    rcoblens:1239          64.215.164.242:http    ESTABLISHED
  TCP    rcoblens:1241          ams.ftl.affinity.com:pop3  TIME_WAIT
  TCP    rcoblens:1242          a68-22-73-137.deploy.akamaitechnologies.net:http
  ESTABLISHED
  UDP    rcoblens:microsoft-ds  *:*
  UDP    rcoblens:1025          *:*
  UDP    rcoblens:1028          *:*
  UDP    rcoblens:1044          *:*
  UDP    rcoblens:1106          *:*
  UDP    rcoblens:ms-sql-m      *:*
  UDP    rcoblens:ntp           *:*
  UDP    rcoblens:1026          *:*
  UDP    rcoblens:1039          *:*
  UDP    rcoblens:1053          *:*
  UDP    rcoblens:1099          *:*
  UDP    rcoblens:1127          *:*
  UDP    rcoblens:1234          *:*
  UDP    rcoblens:1900          *:*
  UDP    rcoblens:62514         *:*
  UDP    rcoblens:discard       *:*
  UDP    rcoblens:ntp           *:*
  UDP    rcoblens:netbios-ns    *:*
  UDP    rcoblens:netbios-dgm   *:*
  UDP    rcoblens:1900          *:*
  UDP    rcoblens:51369         *:*

C:\Documents and Settings\richc.NATHANSONLAWFIR>
0
 
LVL 11

Expert Comment

by:star_trek
ID: 16456690
did you try one of this?

Looks like there is a same netbios name existing as the name of your computer. Try changing that if not do the following.
Add your wins server to the wins list if it is not added.Also this is something to do with the NETBIOS names. If you have Enable NetBIOS over TCP/IP then do it default and see if it goes away. If it doesn't then disable and enable netbios over TCP/IP
0
 

Author Comment

by:rcoblens
ID: 16456717
I disabled and Enabled Netbois over TCP/IP. I don't have any wins server setup. Just DC\DNS and DHCP resides on Cisco Pix. What is the best way to see if a dual name exisists..
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16456982
that is his computer listening for netbios connections it in that case would have the same name.
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16457118
are you running any kind of load balencing server?
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16457130
service i mean
0
 
LVL 15

Assisted Solution

by:venom96737
venom96737 earned 1000 total points
ID: 16457221
here is a site that should help troubleshoot the master browser problem http://support.microsoft.com/kb/q135404
0
 
LVL 11

Accepted Solution

by:
star_trek earned 1000 total points
ID: 16468638
ALso check the following link for better understanding of the computer browser:
http://technet2.microsoft.com/WindowsServer/en/Library/43dce7f8-0741-4672-a7e3-762671110e9f1033.mspx
0
 

Author Comment

by:rcoblens
ID: 16469266
I am not running any load balancing. I do have two NIC cards in the server but only use the PCI GB card. The internal Nic is not used but is enabled.  I have no WINS server.
0
 

Author Comment

by:rcoblens
ID: 16469308
When I started up my Laptop this morning this is what events were active. In order.

Event Type:      Error
Event Source:      TrueVector Service
Event Category:      None
Event ID:      5003
Date:            4/17/2006
Time:            8:59:27 AM
User:            N/A
Computer:      RCOBLENS
Description:
TrueVector driver: Driver install or load failure: LoadNTDeviceDriver. Win32 error: The system cannot find the file specified.

Event Type:      Warning
Event Source:      EventSystem
Event Category:      (52)
Event ID:      4356
Date:            4/17/2006
Time:            9:01:51 AM
User:            N/A
Computer:      RCOBLENS
Description:
The COM+ Event System failed to create an instance of the subscriber partition:{41E90F3E-56C1-4633-81C3-6E8BAC8BDD70}!new:{6295DF2D-35EE-11D1-8707-00C04FD93327}.  CoGetObject returned HRESULT 8000401A.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Event Type:      Error
Event Source:      Folder Redirection
Event Category:      None
Event ID:      101
Date:            4/17/2006
Time:            9:01:51 AM
User:            NATHANSONLAWFIR\richc
Computer:      RCOBLENS
Description:
Failed to perform redirection of folder My Documents. The new directories for the redirected folder could not be created. The folder is configured to be redirected to <\\NAT-LAW-1\Users\%USERNAME%\My Documents>, the final expanded path was <\\NAT-LAW-1\Users\richc\My Documents>. The following error occurred:
The network path was not found.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Event Type:      Error
Event Source:      Userenv
Event Category:      None
Event ID:      1085
Date:            4/17/2006
Time:            9:01:51 AM
User:            NT AUTHORITY\SYSTEM
Computer:      RCOBLENS
Description:
The Group Policy client-side extension Folder Redirection failed to execute. Please look for any errors reported earlier by that extension.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


0
 

Author Comment

by:rcoblens
ID: 16469421
I renamed my laptop and rebotted here are the events after reboot.

Event Type:      Error
Event Source:      TrueVector Service
Event Category:      None
Event ID:      5003
Date:            4/17/2006
Time:            9:36:17 AM
User:            N/A
Computer:      COBLENS
Description:
TrueVector driver: Driver install or load failure: LoadNTDeviceDriver. Win32 error: The system cannot find the file specified.

Event Type:      Error
Event Source:      Folder Redirection
Event Category:      None
Event ID:      101
Date:            4/17/2006
Time:            9:36:55 AM
User:            NATHANSONLAWFIR\richc
Computer:      COBLENS
Description:
Failed to perform redirection of folder My Documents. The new directories for the redirected folder could not be created. The folder is configured to be redirected to <\\NAT-LAW-1\Users\%USERNAME%\My Documents>, the final expanded path was <\\NAT-LAW-1\Users\richc\My Documents>. The following error occurred:
The network path was not found.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Event Type:      Error
Event Source:      Userenv
Event Category:      None
Event ID:      1085
Date:            4/17/2006
Time:            9:36:55 AM
User:            NT AUTHORITY\SYSTEM
Computer:      COBLENS
Description:
The Group Policy client-side extension Folder Redirection failed to execute. Please look for any errors reported earlier by that extension.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Disclosure: Use this tutorial only when no other options helps to get Windows XP running without any problems and you don't want to format the drive. The back up of the data is the responsible of the user, however there is a description of how t…
Can I legally transfer my OEM version of Windows to another PC?  (AKA - Can I put a new systemboard in my OEM PC?) Few of us are both IT and legal experts but we all have our own views of Microsoft's licensing rules and how they apply.  There are…
Integration Management Part 2
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Suggested Courses
Course of the Month14 days, 9 hours left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question