ESEUTIL.. Help. Store Unmounted

c1041724

database name: priv2.eb

I have located the eseutil.exe,

in the command prompt, what is the proper syntax?
my eseutil is not in the same folder as my database.
LVL 11
phileocaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
ESEUTIL & ISINTEG

Integrity

Test Database integrity using Isinteg

isinteg -s <servername> -test Alltests

Check database integrity using Eseutil

ESEUTIL /G "C:\Program files\exchsrvr\mdbdata\priv1.edb"

Defragmentation

Providing you have 110% of the database size free (note it creates a temp db in the working directory!)

ESEUTIL /D "C:\Program files\exchsrvr\mdbdata\priv1.edb"

Assuming theres a lot of space on drive f: (NOTE you need to put C:\PROGRA~1\Exchsrvr\bin on the end of the path statement {system variables}) for the following to work. This also assumes you've copied priv1 to the f: drive.

eseutil /d f:\priv1.edb /t f:\temp.edb

Repair

 WARNING Copy the priv.edb and priv.stm elsewhere before doing the following

ESEUTIL /P "c:\program files\exchsrvr\mdbdata\priv1.edb"

Repair using ISINTEG (Last Resort)

isinteg -s <servername> -fix -test alltests
phileocaAuthor Commented:
hey pete.. thanks!!

i did figure out the syntax... but i'll keep you up to date... on what happens with that error msg.
Pete LongTechnical ConsultantCommented:
Hi Kyle didnt realise that was you Mate :) Keep me posted
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

phileocaAuthor Commented:
well i'm still getting the exact same error.
i ran the eseutil with /p and /i

there is no e00.log file
do i just create a new one?
Pete LongTechnical ConsultantCommented:
Whats listed in

Exchange system manager> admin groups > first admin group > servers > servername > storage group
right click storage group > Properties > general

will give you the path to where the log files should be (and their naming convention)

Whats up with the store will it just not mount or something?
phileocaAuthor Commented:
it's unmounted.  It crashed sometime this morning.  when I try to mount, i get that error message above.
phileocaAuthor Commented:
the antivirus gave quarantined the log file.
i turned off the AV and put the log file back.

now i'm trying to figure out how to sync the datbase with the log file.
Pete LongTechnical ConsultantCommented:
Dont throw things at me but there is plenty of spare room on the volume holding the priv2.edb file isnt there?
and you have been through http://support.microsoft.com/?kbid=827283


and if you ran eseutil with a /p switch you should manually delete the log files anyway :)
phileocaAuthor Commented:
So i don't even need the log files is what you're saying.  

there is plenty of spare room on the volume yes. and the database is far from being full.  I enforoce archiving.

I went through that support page and everything was okay. mounting still failed with the same error msg.
Pete LongTechnical ConsultantCommented:
>>So i don't even need the log files is what you're saying.  

Well Thats what Ive Read online - though Id move the log files elsewhere instead of deleting them then try to remount the store
Pete LongTechnical ConsultantCommented:
if all else fails run through the complete http://support.microsoft.com/?id=313184

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
phileocaAuthor Commented:
thanks PETE.. that last comment gave me the FINAL clue.

repair the pub.edb (this was dirty shutdown)
then
delete all .log, .chk, and temp.edb file.

you're a gentlemen and a scholoar
phileocaAuthor Commented:
crap.. i jumped the gun.
my stores mounted.. but send/receive isn't working.  

boot and reboot were sitting on a fence, boot fell off...who's left?
Pete LongTechnical ConsultantCommented:
Hello M8 - it is still snookered?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.