Cannot get media type from 'cgi-script'

Hi all.  I'm running Apache on both a Fedora Redhat Server, and a Windows PC (that I use for offline testing).  The following error is placed in the error log each time a CGI script is run on both the Fedora and Windows machine:

Cannot get media type from 'cgi-script'

The scripts execute correctly, but that error message shows up after every CGI script execution.

Here's the config section for this website:
<VirtualHost *:80>
    ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot "C:\Design and Programming\current\gbcommerce\httpdocs"
    ServerName offline.gbcommerce.net
    ErrorLog "C:\Design and Programming\current\gbcommerce\error_log.txt"
 
    ScriptAlias /prgs "C:\Design and Programming\current\gbcommerce\httpdocs\prgs"  
   

    <Directory "C:\Design and Programming\current\gbcommerce\httpdocs">
    AddType cgi-script .cgi
    AddHandler cgi-script .cgi
    XBitHack Full
    Options Indexes FollowSymLinks ExecCGI
 
    </Directory>

</VirtualHost>

Incidentally, the error doesn't occur when I remove the AddType and AddHandler directives, such as in the following configuration (note that they're commented out):

<VirtualHost *:80>
    ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot "C:\Design and Programming\current\gbcommerce\httpdocs"
    ServerName offline.gbcommerce.net
    ErrorLog "C:\Design and Programming\current\gbcommerce\error_log.txt"
 
    ScriptAlias /prgs "C:\Design and Programming\current\gbcommerce\httpdocs\prgs"  
   

    <Directory "C:\Design and Programming\current\gbcommerce\httpdocs">
    #AddType cgi-script .cgi
    #AddHandler cgi-script .cgi
    XBitHack Full
    Options Indexes FollowSymLinks ExecCGI
 
    </Directory>

</VirtualHost>

The thing is that I need to be able to use those directives to allow CGI script execution outside of the actual defined script directory.  Don't ask me why, just trust me that I need to be able to do this.

So, the 164 point question is, how do I prevent this from happening.

Thanks,
Gregg

gboethinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sleep_furiouslyCommented:
Maybe try using:

   AddType application/x-httpd-cgi   .cgi

Instead of:

   AddType cgi-script   .cgi

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gboethinAuthor Commented:
Hey, that did it!  Thanks a lot.  

This is the first time I've created a post that was resolved here, so I'm not sure who I need to notify to let know this has been resolved.  Is that something that one of the moderators do?

Thanks again,

Gregg
0
sleep_furiouslyCommented:
You should see an "Accept" button in the upper right of other's comments.  Click it to accept an answer.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.