server: msg 17, level 16, state 1

I have installed two instance of sql in win2k3 system. I can connected to both instance from query analyser from the sql server ( local system ) but i can connected only to the first instance ( default ) from a client machine through lan. when i try to connect to second instance from client machine i get  this error

Unable to connect to server URANUS\TEST_INSTANCE_2:

Server: Msg 17, Level 16, State 1
[Microsoft][ODBC SQL Server Driver][DBNETLIB] SQL Server does not exist or access denied.

Can any body pls guide me what has to be done to resolve this issue.

Regards

Toney
ToneysAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

imran_fastCommented:
On your server
=========
Computer Management ---> Services And Application --> Sql Server Configuration Manager---> URANUS\TEST_INSTANCE_2 --> Network Configuration -- > enable TCPIP

On your Client
=========
Create new Odbc and check inside network configuration check TCPIp
ToneysAuthor Commented:
tcpip is enabled for URANUS\TEST_INSTANCE_2 but still i cannot connect to URANUS\TEST_INSTANCE_2. I enabled named pipe and tried to connect to URANUS\TEST_INSTANCE_2. with named pipe it is working but its not working with tcpip how to resolve this problem.
imran_fastCommented:
At the server site check
===============
Computer Management ---> Services And Application --> Sql Server Configuration Manager---> URANUS\TEST_INSTANCE_2 -->Sql Client Configuration -- > double click TCPIP  and then check the default port





At your client machine for testing
=======================

Control Panel --->Administrative Tools--->Data Source-->Add -->Sql Server

specify server name then next in client configuration network library select TCP/IP Uncheck dynamically determine port and specify the port you have at the server site.then see if it is connecting

try the same with check and see if it is connecting
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

ToneysAuthor Commented:
I tried it but i am getting this errors

Connection failed
SQLState: ‘01000’
SQL Server Error: 10061
[Microsoft][ODBC SQL Server Driver][TCP/IP Socket]ConnectionOpen 9Connect()).
Connection failed:
SQLState: ‘08001’
SQLState Error: 17
[Microsoft][ODBC SQL Server Driver][TCP/IP Socket]SQL Server does not esist or access denied
imran_fastCommented:
it could FIREWALL:
i think check what is the default port for you second instance may be it is blocked by the firewall at the client machine.
ToneysAuthor Commented:
i tried interchanging the port no for default and second instance ( uranus port no 1433 was changed to 65000 and uranus/test_instance_2 was changed 65000 to 1433 ) but still i am getting the same error.
ToneysAuthor Commented:
firewall is not enabled on my system.
imran_fastCommented:
imran_fastCommented:
in the above link they say
=================
You may not be able to connect to an instance of SQL Server 2000 Service Pack 2 or earlier that is installed on a Windows Server 2003 computer through the TCP/IP port


so you should have SQL Server 2000 Service Pack 3 or higher.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ToneysAuthor Commented:
i have installed sql server 2000 with sp3
imran_fastCommented:
what happend then does it work?
ToneysAuthor Commented:
Thanks imran now i am able to connect to both instances using tcp/ip. the problem i think was while installing sql sp3 my colleque didn't notice that the default option has been checked. later i installed the mssql sp3 and unchecked the default option and selected the new instance name ( test_instance_2 )
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.